...Am I screwed?

Discussion in 'iPhone, iPod & iPad' started by xakota, Sep 23, 2010.

Sep 23, 2010

...Am I screwed? by xakota at 11:54 PM (1,030 Views / 0 Likes) 6 replies

  1. xakota
    OP

    Member xakota GBAtemp Fan

    Joined:
    Mar 18, 2010
    Messages:
    340
    Country:
    United States
    I have a new iPhone 3gs, just got it a week or so ago. Sadly, it came with 4.0.2. I understand this is unjailbreakable with the new bootrom. Obviously it's a new device so i don't have any SHSH blobs from older firmwares. Sn0wbreeze just came out but it only works if you're on 3.1.2. Greenpois0n is coming, but 3GS new bootrom isn't on the supported list. Will there ever be hope for my iPhone?
     
  2. metamaster

    Member metamaster GBAtemp Advanced Fan

    Joined:
    Mar 7, 2010
    Messages:
    876
    Country:
    Canada
    I thought greenpois0n works for all devices on all firmwares
     
  3. spruced

    Newcomer spruced Advanced Member

    Joined:
    Jun 28, 2010
    Messages:
    64
    Country:
    United States
    Yes, sooner or later it will be jailbroken. They almost always are.
     
  4. DeMoN

    Member DeMoN GBAtemp Guru

    Joined:
    May 12, 2004
    Messages:
    7,647
    Country:
    United States
    The wait may take a long time though. Especially the 3.1.3 iPod 3rd gens. The jailbreak for those took months to create.
     
  5. Slyakin

    Member Slyakin See ya suckers

    Joined:
    Oct 15, 2008
    Messages:
    4,450
    Location:
    Soviet Slyakin
    Country:
    United States
    The 3G model iPhone already had a jailbreak for 4.1, I think. The jailbreak is Mac only, though.
     
  6. xakota
    OP

    Member xakota GBAtemp Fan

    Joined:
    Mar 18, 2010
    Messages:
    340
    Country:
    United States
    Well fuck, just confirmed gp doesn't work on the 3GS. Fuck. Now what? Oh and I upgraded to 4.1.
     
  7. metamaster

    Member metamaster GBAtemp Advanced Fan

    Joined:
    Mar 7, 2010
    Messages:
    876
    Country:
    Canada
    When in doubt, use f0recast.
    It will tell you if the current device that is plugged in can be jailbroken, tethered or not, and using what exploit.
     

Share This Page