Acekard 2i with 1.4 U

Discussion in 'Acekard' started by Rypherior1251, Jun 16, 2010.

  1. Rypherior1251
    OP

    Rypherior1251 Member

    Newcomer
    10
    0
    Jun 16, 2010
    United States
    Does the Acekard 2i flawlessly host DS games with firmware 1.4 on the DSi as most people boast it does or is there a superior alternative?
     
  2. coattails

    coattails GBAtemp Regular

    Member
    212
    0
    Mar 29, 2010
    Canada
    Montreal
    The Acekard 2i flawlessly hosts DS games with firmware 1.4 on the DSi.
    However, you have to update the Acekard2i firmware on a DSL/Phat/DSi with firmware 1.3 or below.
    Once it's updated, the Acekard 2i flawlessly hosts DS games with firmware 1.4 on the DSi.
     
  3. YayMii

    YayMii hi

    Member
    4,915
    423
    Jun 24, 2009
    Canada
    that place
    Hosting games? What is this "hosting games"?

    But yeah, the Acekard 2i works flawlessly if you update it using an older DS or buy it from somewhere that updates it for you (i.e. Shoptemp if you purchase the Premium Updating/Flashing service for $1).
     
  4. exangel

    exangel executioner angel

    Member
    1,574
    267
    Apr 20, 2010
    United States
    Tucson, AZ
    He means being the host of a multiplayer or online multiplayer game. For instance Phantasy Star Zero requires a "host" to start a party, or Blue Dragon Awakened Shadow requires a "host" to allow people on the friends roster to join his game.

    If your question was sarcastic it was completely lost on me >.>
     
  5. YayMii

    YayMii hi

    Member
    4,915
    423
    Jun 24, 2009
    Canada
    that place
    1. I was sarcastic.
    2. I'm pretty sure he was talking about 100% compatibility.
     
  6. nuke888

    nuke888 Advanced Member

    Newcomer
    67
    0
    Jul 27, 2006
    United States
    I have an Acekard 2i,I cant remember they released 2 firmware updates,one was for the language fix and the other for the 1.4 dsi firmware right ? Or were they 3 updates ?
     
  7. tk_saturn

    tk_saturn GBAtemp Psycho!

    Member
    3,327
    14
    Jan 26, 2010
    Officially Acekard have released 2 language updates, one for the HW81 carts and another for the HW44 carts.

    Unofficially they also have 2 1.4 updates, the original and an updated version which solved the 0% progess issue on newer carts. The 1.4 update also includes the language fix.
     
  8. Miser

    Miser Banned

    Banned
    249
    0
    Mar 25, 2010
    There are superior alternatives, cards with more features and better build quality like Supercard DSONEi and DSTwo. The Acekard 2i doesn't not have much official support, the build quality isn't very good and it lacks in features. Also, there are AK2i clones out there on which AKAIO doesn't work. An Acekard 2i without AKAIO pretty much sucks.