Acekard 2i language fix released

Discussion in 'GBAtemp & Scene News' started by shaunj66, May 4, 2009.

  1. shaunj66
    OP

    shaunj66 Administrator

    Administrator
    10,024
    1,637
    Oct 24, 2002
    United Kingdom
    South England
    [​IMG] Acekard 2i language fix released
    Runs on any language DSi!
    [​IMG]
    Now that the beta testing is completed; the Acekard Team have released their update tool that fixes the known compatibility issue of the Acekard 2i running on DSi's that have their system language set to anything but English.

    Unlike the usual loader updates, this fix updates the actual cart firmware, so be careful when running (and ensure you have a charged up battery). The fix is simple to run though -- just copy the .nds file in the attached zip file to the root of your micro SD card, and then proceed to boot up your DS. The automatic update will then run.

    [​IMG] Warning: This update should only be used on Acekard 2i's that have a hardware ID of "81". You can check your HW ID by booting up your AK2i (WITHOUT this fix on your SD card!) and going to Start > Help. If your HW ID is anything but "81" do NOT apply this update as you will most likely brick your cart. The team are working on an update for other AK 2i HW revisions.


    [​IMG] Download
    [​IMG] Discuss
     


  2. wchill

    wchill Resident chillxpert

    Member
    1,407
    34
    Jun 12, 2008
    United States
    Wait, so in theory, if you modified this update file, you could make a flashing tool for bricked AK2is or to circumvent firmware updates?
     
  3. Chris_Skylock

    Chris_Skylock GBAtemp Advanced Maniac

    Member
    1,501
    0
    Dec 26, 2008
    Philippines
    it said "actual cart firmware". Is this a step on updating the acekard itself just in case the DSi has a blocking update on all the carts?
     
  4. wchill

    wchill Resident chillxpert

    Member
    1,407
    34
    Jun 12, 2008
    United States
    The thing is, Acekard specifically mentioned that they won't release a tool to circumvent updates.
    In theory you could possibly inject update code into this, bypassing that problem.
    That's what I'm thinking.
     
  5. manaphy4ever

    manaphy4ever GBAtemp Advanced Fan

    Member
    505
    1
    May 7, 2008
    Bosnia and Herzegovina
    Bahrain
    Nice update fix language for german , france....etc i have the acekard 2i and i only need dsi cause my ds lite broken [​IMG]
     
  6. Eon-Rider

    Eon-Rider GBAtemp Maniac

    Member
    1,021
    15
    Jun 15, 2008
    There's no need for me to run this because my DSi is Australian but it's nice to see the Acekard team acknowledging a common problem. =)
     
  7. agentgamma

    agentgamma I dont know what to put here

    Member
    876
    2
    Oct 5, 2007
    Sydney, Australia
    Wait- the AceKard2i can update the actual card firmware?
    So in theory, they could circumvent updates?
    [​IMG]
     
  8. wchill

    wchill Resident chillxpert

    Member
    1,407
    34
    Jun 12, 2008
    United States
    Yeah, it's been known for a while now.
     
  9. need4speed

    need4speed GBAtemp Regular

    Member
    130
    0
    Nov 4, 2006
    I've just check my acekard 2i hw id and its 81. Can I go ahead and update my card then? Thanks.
     
  10. P.S

    P.S Advanced Member

    Newcomer
    96
    0
    Apr 9, 2009
    Coolio
     
  11. A-Z

    A-Z Member

    Newcomer
    37
    0
    Nov 8, 2008
    surely all u who r saying this culd get round updtes u need 2 riun the nds file surely and correct me if im wrong if it stops tyhe acxekard from turning on then you cannot acces the nds file.?
     
  12. Maz7006

    Maz7006 iSEXu

    Member
    3,634
    30
    Aug 2, 2008
    Nice to see that AK did something about the problem. I think it has won back a a lot of potential customers.
     
  13. LUGiA

    LUGiA GBAtemp Fan

    Member
    425
    0
    May 14, 2008
    whats Carts are newer HW: 44 or HW: 81 and also whats the differance
     
  14. g.crow

    g.crow beide mittelfinger hoch

    Member
    770
    2
    Feb 26, 2006
    United States
    took them ages
    now i cant even use it as my hardware is 44
    sucks
     
  15. Morku

    Morku Advanced Member

    Newcomer
    64
    1
    Sep 11, 2007
    Gambia, The
    I have 44 too. Damn :\
    How long will we wait again?
     
  16. Dimensional

    Dimensional GBAtemp Advanced Fan

    Member
    576
    69
    Dec 7, 2008
    United States
    Texas
    I also have hardware 44, and I expect that the firmware update for it will be out within a week of this release.
     
  17. RPG Hacker

    RPG Hacker GBAtemp Regular

    Member
    200
    24
    Jan 20, 2008
    Gambia, The
    Kaperich
    Wow! I just got ma Acekard 2i today (HW: 81) and then this patch is released. Lucky! That's what I call "perfect timing". And I thought the Acekard team was just ignoring the problem. Seems I was wrong. That's what I call "good support"!
     
  18. LUGiA

    LUGiA GBAtemp Fan

    Member
    425
    0
    May 14, 2008
    should I update even if i am just going to use English

    also can thgis update be run on a DSLite or is it recommend to run on DSi
     
  19. tenshinoneko

    tenshinoneko GBAtemp Regular

    Member
    101
    0
    Feb 14, 2009
    United States
    Cool [​IMG] I was waiting for this update before being able to give away one DSi for my mom cuz she speaks spanish.

    I hope they get to fix the language issue on the other carts too [​IMG]
     
  20. Hakoda

    Hakoda GBAtemp Addict

    Member
    2,133
    2
    Feb 2, 2008
    United States
    San Jose, CA
    I do believe it is recommended to run on DSi since it was the DSi that is region-locked.

    As I'm reading this post, I thought to myself, "How will this affect AKAIO?". I read a bit closer and I realize it updates the cart firmware, not the system firmware. I'm guessing, that if you were to temporarily run the official Acekard FW to apply this patch to your HW81 Acekard2i then re-install AKAIO, it would run. Although this is just a theory. Please someone correct me if I'm wrong that way don't have a billion posts asking if this is compatible with AKAIO. Perhaps you don't even need to temporarily swap to the official Acekard FW, but we're going to need someone of higher intelligence to confirm.

    ~ Jon