Acces browser exploit after 9.5-23?

Discussion in '3DS - Console, Accessories and Hardware' started by Jerros, Mar 17, 2015.

  1. Jerros
    OP

    Jerros Newbie

    Newcomer
    8
    0
    Mar 17, 2015
    Netherlands
    Hey,

    So... since 9.5-23 fixer the QR exploit thingy (Pokémon shuffle hack and the like), I wondered if there's any way to still make use of that exploit after having upgraded emuNAND to 9.5-23. Currently, my sysNAND is at 4.5 and emuNAND is at 9.5-23, and the exploit worked only in sysNAND 9.0 or 9.5 (if I'm correct?). I own the blue and red gateway cards, and have a backup of my origional sysNANd at 8.1.

    Would it be possible to upgrade sysNAND to 9.0 in order to acces the exploit, and later on revert back to 4.5 again? (the reverting back shouldn't be a problem, more the getting sysNAND to 9.0 part).

    - Downgrade emuNAND to 9.0, make a backup, then use that backup to restore sysNAND to 9.0?

    - Install cia on sysNAND (with 3DNUS or something) to acces the exploitable browser version?

    - Restore sysNAND to 8.1 --> set emuNAND to 8.1 --> Use 3DNUS to update browses to the exploitable version --> create backup of 8.1 emuNAND (with exploit) --> restore that backup on sysNAND (which should work right?) --> use the exploit in 8.1 (with different browser) on sysNAND --> revert sysNAND to 4.5?

    - Reset emuNAND to 4.5 --> 3DNUS the browser in emuNAND to 9.0 --> create backup of emuNAND 4.5(with exploitable browser) --> load that backup to sysNAND, resulting in having sysNAND 4.5 with exploitable browser?

    Though the exploit works in 9.5-22, I wouldn't want to update beyond 9.0 (9.2 technically) as that'd remove the ability to downgrade to 4.5 again.
    It just feels like there should be a possibility to use the browser exploit when having sysNAND on 4.5 and emuNAND on 9.5-23...

    Any thoughts?
     
  2. Pippin666

    Pippin666 SSF43DE Master

    Member
    1,828
    248
    Mar 30, 2009
    Canada
    Montreal, Qc
  3. Jerros
    OP

    Jerros Newbie

    Newcomer
    8
    0
    Mar 17, 2015
    Netherlands
    Suggesting I've posted this in the wrong place? By all means, I'm sorry - wasn't sure. If pointing out the answer can be found there - I did read a lot of relevant topics (inspiring to the mentioned ideas) but no definite way of doing so yet...
     
  4. Aurora Wright

    Aurora Wright GBAtemp Advanced Maniac

    Member
    1,544
    4,099
    Aug 13, 2006
    Italy
    You can't update SysNAND to 9.0-2 very easily from 4.5. Your only options are the updated Smash cart for US or Cooking Mama 5 for EU, or a Sky3DS to emulate them. There's another way but it requires having someone with a working 9.0-9.2 sysNAND dump (from a non-New 3ds) sharing with you the firm0 and firm1 partitions from the decrypted sysNAND dump, and injecting them into a 9.2 emuNAND (emunand is easy to update, just use the ROMs of said carts and hold up while booting gw emuNAND mode)
     
  5. Jerros
    OP

    Jerros Newbie

    Newcomer
    8
    0
    Mar 17, 2015
    Netherlands
    But you CAN make a backup from emuNAND, then load that backup safely to sysNAND right? That'd enable te sysNAND to run on 9.0. Also for the pkmnShuffle exploit, only 9.0 specifically works and 9.5, but... yeah - can't revert then).
    And it's a myth then that updating emuNANd form a gamecard updates your sysNAND as well?

    Better yet; any posibility of just installing the 9.0 browser .cia to the 4.5 sysNAND? That'd be the easiest. There are some experimental posts about this, but I couldn't find any clear "sure you can" (a user named "Cearp" has something about it, but no 123-way of doing it, or so it seemed to me).
     
  6. Aurora Wright

    Aurora Wright GBAtemp Advanced Maniac

    Member
    1,544
    4,099
    Aug 13, 2006
    Italy
    No, don't do that! emuNAND dumps lack the correct firm0/1 partitions and this bricks sysNAND.
     
  7. Aurora Wright

    Aurora Wright GBAtemp Advanced Maniac

    Member
    1,544
    4,099
    Aug 13, 2006
    Italy
    You can't just "install the browser", since the offsets for the other exploits (arm11 kernel, process9) differ slightly.

    Edit: gamecard (legit or ROM) updates update emuNAND, at least in recent GW releases
     
  8. Jerros
    OP

    Jerros Newbie

    Newcomer
    8
    0
    Mar 17, 2015
    Netherlands
    I understand, thank you.
    So there would be no way to exploit the 9.0 (and 9.0 only; not 9.5 or 9.2) browser thing on a system having emuNAND 9.5-23, despites sysNAND being 4.5 eh? (apart from the "using another device and ripping 9.0 from that") *sadface*
     
  9. Aurora Wright

    Aurora Wright GBAtemp Advanced Maniac

    Member
    1,544
    4,099
    Aug 13, 2006
    Italy
    Sadly not. 9.0 and 9.2 are the same anyway, only home menu changes between the two (browser is the same, arm 11 kernel and process9 are the same).
     
  10. Jerros
    OP

    Jerros Newbie

    Newcomer
    8
    0
    Mar 17, 2015
    Netherlands
    And I just realized that a lot of benefits are useless anyways - for example, getting 9.2 for pkmn Shuffle wouldn't work, as as soon as you'd enter the shop to buy the "free" items, it will force an update beforehand anyways (otherwise you can't enter the shop).

    Thanks anyways though.