A button mal function?

Discussion in 'NDS - Flashcarts and Accessories' started by Giangsta, Sep 5, 2008.

  1. Giangsta
    OP

    Giangsta GBAtemp Regular

    Member
    2
    Mar 17, 2007
    My ds lite is having problems with registering button presses with the A button, all the other buttons require a light tap and they will register immediately but my A button needs a firm press for it to work.

    I have 2 theories on what may be wrong:

    The conductive pad has gone shoddy and the A button isn't making contact properly with the main board

    The main board is broken?!?

    I'd like to hear your thoughts guys, and what should i do to fix it
     
  2. Joey90

    Joey90 Not around any more

    Member
    2
    Apr 21, 2007
    UK
    I vote conductive pads... after heavy use the conductive part actually rips out - it happened to my d-pad (2 years playing every day).

    Get new ones from dealextreme and you should be fine [​IMG]
     
  3. Giangsta
    OP

    Giangsta GBAtemp Regular

    Member
    2
    Mar 17, 2007
    luckily for me i already ordered some and they should be arriving on wednesday, i sure hope it makes the A button register normally.
     
  4. Vague Rant

    Vague Rant Deceptively cute

    Member
    5
    Aug 7, 2008
    Melbourne
    It could just be a bit of dust, you know.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice