6.20 to 6.60

Discussion in 'PSP - Hacking & Homebrew' started by obs123194, Mar 17, 2015.

  1. obs123194
    OP

    obs123194 GBAtemp Advanced Fan

    Member
    678
    85
    Mar 9, 2014
    United States
    Hello everyone. So I'm trying to update my psp to the latest firmware however I keep getting an error message saying that the data is corrupt or something. The psp was on 6.20 lme-2.3 perma patch or something I believe but I want to update it to the latest firmware so that I can get my dual 128gb memory cards to work on it.
     
  2. zfreeman

    zfreeman GBAtemp Fan

    Member
    379
    116
    Mar 9, 2013
    United States
    Pennsylvania
    Have you tried 6.61?
     
  3. obs123194
    OP

    obs123194 GBAtemp Advanced Fan

    Member
    678
    85
    Mar 9, 2014
    United States
    im trying to get on that firmware