4.2U firmware issue and backup loaders

Discussion in 'Wii - Backup Loaders' started by pralaya, Jan 11, 2010.

Jan 11, 2010
  1. pralaya
    OP

    Newcomer pralaya Newbie

    Joined:
    Nov 11, 2009
    Messages:
    7
    Country:
    Brazil
    Hi guys, I dont even know if this is the exactly area I should be asking this but, oh well...
    After I upgraded my american Wii to firmware 4.2U, it became, obviously, unable to read any Japanese games I tried to play. What I wanted to know is that if I'm able to play those games via Backup Loaders, I'm asking this because I dont know how do they actually work (as far as I know they work like a FlashCard YSMenu...) and if it is difficulty to use/install them on my (chip moded) Wii safely and wich ones would you guys recommend me [​IMG] ; because from what I've heard, downgrading is a pretty bad idea...
    Thank you guys in advance, sorry for my horrible english, and yes, thats it...
     
  2. Krestent

    Member Krestent What to post?

    Joined:
    Mar 31, 2009
    Messages:
    3,952
    Country:
    United States
    Loaders will play jp games. I recommend using Gecko
    oS or neogamma
     
  3. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Installing homebrew channel is easy and almost 100% risk-free. Then you just need a sd card with the loader you want(Gecko OS or SoftChip as modchip user) and you can launch it from the HBC from sd card. You can install the loader as channel as well if you want, you need a wad for this. But if you install a not working channel, your wii is bricked. (confirmed to work channels should be safe)

    Which Gecko OS version is the best, i don't know. The latest one seems to have some bug. My modded Gecko OS(based on the very old version), should work and plays most games(no instrument games).

    SoftChip should be able to play all games, you may only need to install the game IOS manually(not the case on 4.2) or force the video mode that matches the region of the game. And on japanese games, you most likely need to force japanese lannguage. Set SoftChip to use IOS36 and set it to load the requested IOS.
     
  4. pralaya
    OP

    Newcomer pralaya Newbie

    Joined:
    Nov 11, 2009
    Messages:
    7
    Country:
    Brazil
    From what I understood, between neogamma, gecko and softchip, SoftChip is the best for me because my Wii has a modchip, right? Also, I only need the backup loader software (in this case softchip software or wathever) and an SD card right? Also whats a HBC??
    The case is, I dont want to install any homebrew channel on my wii, I just want a way to get japanese games working on it again, and I just want to make sure its safe to use backup loaders on it because my wii has a modchip and I've never used such softwares on it before, So yeah, sorry for that much questions,

    Thanks WiiPower and tattar8 for helping me!
     
  5. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Then you can try to launch SoftChip via bannerbomb. But sorry, it's hard for me to understand your worries about the HBC if you hardware modified your Wii. Why do you worry about it?
     
  6. zx3junglist

    Newcomer zx3junglist Member

    Joined:
    Dec 24, 2009
    Messages:
    24
    Country:
    United States
    HBC == homebrew channel
     

Share This Page