3.60 Remote Play

Discussion in 'PS Vita - Hacking & Homebrew' started by dr_d00m, Jan 21, 2017.

  1. dr_d00m
    OP

    dr_d00m Member

    Newcomer
    21
    18
    Jan 21, 2017
    Gambia, The
    Hey guys,

    I've tried this both tutorials to activate remote play on 3.60:





    My problem is, everytime I want to setup remote play in the PS4 Link app, my vita tolds me to update my system software. Can I bypass this or is there a trick? I have factory resetted my vita few days ago and activated it with my PS3.

    Has anybody an idea or anybody got this working?
     
  2. Tom Bombadildo

    Tom Bombadildo Honk!

    pip Contributor
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    10,797
    10,913
    Jul 11, 2009
    United States
    I forgot
  3. dr_d00m
    OP

    dr_d00m Member

    Newcomer
    21
    18
    Jan 21, 2017
    Gambia, The
    Thank you for the hint with DNS but it won't work. The update message still appears. :(
     
  4. Dr. Dew

    Dr. Dew GBAtemp Regular

    Member
    280
    62
    Oct 31, 2015
    Sudan
    Khartoum
    reboot vita in airplane mode and then try to turn the wifi back on
     
  5. ma16v3

    ma16v3 GBAtemp Regular

    Member
    128
    34
    Aug 11, 2016
    United States
    I have tried for the last 3 days to reproduce the issues outlined and have failed, both on the PSTV the video was recorded on, and my Vita handheld. Out of curiosity, are you able to use CMA or QCMA without an update prompt using any of the methods outlined above?
     
  6. jorian995

    jorian995 Member

    Newcomer
    15
    0
    Jun 18, 2007
    Netherlands
    Unfortunately got the same problem, do you also get the error has occured (C2-17037-8) whenever you press cancel at the update prompt?
     
  7. Dave_Chad

    Dave_Chad GBAtemp Regular

    Member
    218
    37
    Jun 29, 2016
    Same situation I just don't think it's possible for us :(

    Sent from my ONEPLUS A3003 using Tapatalk
     
  8. GeneralSmiley

    GeneralSmiley Advanced Member

    Newcomer
    53
    13
    Oct 10, 2013
    Yes I fear we are all in the same boat. Activated with PS3 but still no matter what I do, I get the log in to PSN prompt and then the update nag. Never goes to the manual setup.
     
  9. dr_d00m
    OP

    dr_d00m Member

    Newcomer
    21
    18
    Jan 21, 2017
    Gambia, The
    Now I'm one step closer! When I boot my vita up in airplane mode and then launch the PS4 Link app, I got the setup screen where I can enter the code from my PS4. After that my vita abort the linking process after few seconds. :(

    Error: NP-15452-7

    @jorian995
    I don't got in all tried cases error C2-17037-8.
     
    Last edited by dr_d00m, Jan 22, 2017
  10. Tom Bombadildo

    Tom Bombadildo Honk!

    pip Contributor
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    10,797
    10,913
    Jul 11, 2009
    United States
    I forgot
    Hmmm...odd, I don't have any issues when just using Henkaku's update DNS server...Just tried again, mine connects just fine.

    Have you tried changing the "version spoofing" setting in Molecular Shell? Maybe that's why, mine is set to 3.63. (Note that this does not enable PSN access)
     
  11. dr_d00m
    OP

    dr_d00m Member

    Newcomer
    21
    18
    Jan 21, 2017
    Gambia, The
    Version Spoofing is set on 3.63, Henkaku's update DNS server is working. I think all my settings are right ... but somehow it won't work. I don't know where the problem is ... maybe some flag or something else is not set and so I can't bypass the update message or I had to login in PSN a few months ago when it was possible.
     
    Last edited by dr_d00m, Jan 22, 2017
  12. ma16v3

    ma16v3 GBAtemp Regular

    Member
    128
    34
    Aug 11, 2016
    United States
    So I just upgraded to a 64GB card and lost the Remote Play capability again. Now it goes straight to a PSN login and if I cancel it goes back to the first screen for remote play. So my hypothesis is that it has something to do with the Vita database. I suspect anything that has gone wrong has to do with the database update since going back to the 32GB card did not resolve the issue. This means it is not an issue with data stored on the memory card itself or the registry. That said, my knowledge of the inner workings of the Vita is limited so perhaps someone much more knowledgeable could weigh in.

    I am attempting a database rebuild to see if the issue can be resolved this way.

    UPDATE: So no, a database rebuild did not resolve this issue. Like I said, the issue came up after moving to the 64GB card. It still works on my PSTV so I am going to look around for anything that might be related. I somehow doubt this will be related to the registry, but I'll still look.
     
    Last edited by ma16v3, Jan 28, 2017
    dr_d00m likes this.
  13. ma16v3

    ma16v3 GBAtemp Regular

    Member
    128
    34
    Aug 11, 2016
    United States
    Alrighty, so I was digging around the various directories of the Vita and found the app for PS4 Link, NPXS10013, located in vs0:/app. I decided to see exactly what the vs0 partition contains and I found something from Yifan_lu about what each directory contains, more specifically vs0:

    Source:
    https://yifan.lu/2014/10/17/ps-vita-3-30-filesystem-listing/

    It also seems like we do not have write access to this partition(probably for a damned good reason) as I tried sending a basic text file to it both via FTP and from within VitaShell so it doesn't look like transplanting from my PSTV to my Vita will work either. Something altered the behavior of the application though and that means we can change it back given proper access.
     
  14. Tom Bombadildo

    Tom Bombadildo Honk!

    pip Contributor
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    10,797
    10,913
    Jul 11, 2009
    United States
    I forgot
    http://wololo.net/2016/08/19/releas...vitas-protected-partitions-wheres-downgrader/
     
  15. ma16v3

    ma16v3 GBAtemp Regular

    Member
    128
    34
    Aug 11, 2016
    United States
    Thank you for that. RW seems pretty scary, but I'll still snag a vpk while I grasp what each file does specifically. I don't think I want to try overwriting anything just yet since I don't know exactly how these files are written to the Vita at present.

    I'm starting to wonder if anyone has looked into a plugin that blocks PSN nags now. That would be a better solution for the end user.
     
    Dave_Chad likes this.
  16. ma16v3

    ma16v3 GBAtemp Regular

    Member
    128
    34
    Aug 11, 2016
    United States
    So I chickened out and have not replaced the PS4Link app with the one from my PSTV, primarily because I'm pretty sure that is going to break something(damned system partitions being scary). I have to concede I am out of my element from this point forward. However, one thing of interest is that if you boot the Vita up in flight mode and the first thing you launch is PS4 Link, it yells at you a couple times about flight mode, then goes to the pairing screen. However going right into wifi and proceeding hits you with an update nag(or if you're using the DNS, it returns an error), if you try to use update blocker, the connection returns an error, and trying to load HENkaku via offline installer(or from the webpage) closes all the other open windows and then you keep going back to the PSN screen. If someone who actually knows how to make the Vita do things needs me to send them more specific data, I'll be more than happy to get that info for you(error codes, specific methodology, whatever).

    Good news is this no longer seems like an issue of having the unit activated before a certain time. My Vita was activated long ago and only stopped working for Remote Play after the card upgrade.
     
  17. godreborn

    godreborn GBAtemp Psycho!

    Member
    3,801
    697
    Oct 10, 2009
    United States
    rw isn't too bad. the one partition u don't want to mess with is os0: vs0 - even if u were to delete the entire partition, it wouldn't brick the system. it would just force u to install the firmware again.
     
  18. ma16v3

    ma16v3 GBAtemp Regular

    Member
    128
    34
    Aug 11, 2016
    United States
    So to verify, if I were to break something in vs0:, for example the PS4Link app, I wouldn't compromise my system and simply resinstalling the FW would fix everything I did? And how might I go about reinstalling 3.60?

    I was thinking of just transplanting the PSTV NPXS10013 folderI(the PS4Link folder) onto my Vita since it logically follows there must be something different about the app on the PSTV vs the Vita handheld to see if I could dodge the nag. However, and I realize this does not necessarily mean anything, the file sizes for the actual eboot and suprx files are identical, the only differences being the keymap folder being slightly larger from the Vita than the same directory on the PSTV. I would probably just overwrite the suprx files and the eboot.bin and leave everything else since the rc.json is simply just a failback template for restoring the RP settings, keymap is just pngs of button mappings. The only file that isn't the eboot or suprx that I am not certain of what it does specifically is the remoteplay_plugin.rco file in vs0:/NPXS10013/resource/. RCO seems like a common container for files on Playstation devices based on my extremely cursory research on the extension.

    Anyway, that was my plan and I don't know if it is a good plan.
     
  19. dr_d00m
    OP

    dr_d00m Member

    Newcomer
    21
    18
    Jan 21, 2017
    Gambia, The
    Last edited by dr_d00m, Jan 28, 2017
  20. Dave_Chad

    Dave_Chad GBAtemp Regular

    Member
    218
    37
    Jun 29, 2016
    Following this with interest as I bought my Vita recently so can't use Remote Play at all! But would like to have the choice.

    Sent from my ONEPLUS A3003 using Tapatalk