Windows 10 Anniversary Update: Notify to Schedule Restart Missing

Discussion in 'Computer Software and Operating Systems' started by HaloEffect17, Aug 10, 2016.

  1. HaloEffect17
    OP

    HaloEffect17 Splatoon Fan

    Member
    1,033
    976
    Jul 1, 2015
    Canada
    Before the Windows 10 Anniversary Update, I used to be able to select "Notify to schedule restart" in the Windows Update settings to prevent my computer from doing a sudden restart after it finished downloading updates. It worked perfectly as I was able to hit decide when I wanted to restart my computer to complete the update.

    However, after the Windows 10 Anniversary Update, you'll notice that this option is no longer available in the advanced update options. Go see for yourself - it's not there, and it's replaced with this stupid "active hours" setting that tells Windows the hours not to restart your computer for updates. Sounds good? Well... think again, you can only set 12 active hours and not the entire day.

    As you can tell, this is problematic because say I was working outside active hours while Windows was conducting updates and I had some important documents, other downloads, or windows open. I go to do something else for awhile (leaving my computer idle), and then return, only to find that my computer restarted itself and I lost everything that I had open. I find this really frustrating. :angry:

    Apparently, a handful of people on Reddit are concerned about the same issue that I have. I'd advise you to check out this link for some context.

    Does anyone here have a problem with this, too? And also, does anyone know of a fix that can prevent Windows from restarting automatically even outside of active hours? I want to be able to decide when I want my computer to restart like I was able to before the anniversary update. Thanks.
     
    Last edited by HaloEffect17, Aug 10, 2016


  2. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    21,178
    10,068
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Always leave it to Microsoft to screw people over as usual.
     
    HaloEffect17 likes this.
  3. Armadillo

    Armadillo GBAtemp Psycho!

    Member
    3,586
    1,551
    Aug 28, 2003
    United Kingdom
    If you're on pro, you can use the group policy manager to do it.

    You can set it to notify only. So Windows will tell you there are updates, but won't download or install them until you tell it to (this is the setting I use)
    Or you can set it to, download and notify (it will download and tell you, but won't install automatically).

    Both those options will stop it randomly restarting as it won't install stuff automatically and then need a restart.

    http://www.howtogeek.com/224471/how-to-prevent-windows-10-from-automatically-downloading-updates/

    If you're on home, you're fucked & stuck with it.
     
    Last edited by Armadillo, Aug 10, 2016
    HaloEffect17 likes this.
  4. HaloEffect17
    OP

    HaloEffect17 Splatoon Fan

    Member
    1,033
    976
    Jul 1, 2015
    Canada
    Damn... I used winver and it said I'm using a Windows 10 Home operating system. :angry:
     
  5. xy2_

    xy2_ GBAtemp Regular

    Member
    256
    144
    Feb 4, 2016
    France
    You might want to look into getting a Linux distro in order to be able to use your computer for the entire day.
     
    NutymcNuty likes this.
  6. HaloEffect17
    OP

    HaloEffect17 Splatoon Fan

    Member
    1,033
    976
    Jul 1, 2015
    Canada
    Or maybe if Microsoft can have their head screwed on straight for once, they would recognise this is a major problem and fix this.
     
    the_randomizer likes this.
  7. xy2_

    xy2_ GBAtemp Regular

    Member
    256
    144
    Feb 4, 2016
    France
    I think moving on from blaming a company (hint: it's not a person!) to using the free, superior solutions will get you somewhere else.
     
    HaloEffect17 likes this.
  8. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    21,178
    10,068
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    This is one of many reasons I've refused to update from 7 to 10, if it ain't broke, don't fix it. Besides, my GPU can't take advantage of the DX12 API, so really, nothing compels me to update, and Win 7 support ends in 2020, so I'm good. Windows 7 has been the most stable Windows OS I've ever used.
     
    HaloEffect17 likes this.
  9. Armadillo

    Armadillo GBAtemp Psycho!

    Member
    3,586
    1,551
    Aug 28, 2003
    United Kingdom
    Let me know when Linux is fully compatible & gives the same performance for the 94 games in my library and I'll be the first to jump over.
     
  10. xy2_

    xy2_ GBAtemp Regular

    Member
    256
    144
    Feb 4, 2016
    France
    Can you provide a comprehensive list?
     
  11. Armadillo

    Armadillo GBAtemp Psycho!

    Member
    3,586
    1,551
    Aug 28, 2003
    United Kingdom
  12. dankzegriefer

    dankzegriefer GBAtemp Advanced Fan

    Member
    829
    437
    Aug 19, 2015
    United States
    You only play 10 of those games, and they easily run under Linux with WINE or without WINE.
     
  13. xy2_

    xy2_ GBAtemp Regular

    Member
    256
    144
    Feb 4, 2016
    France
    All of these are steam games, and most of these are steam indie games. This means they will run pretty much perfectly under Linux natively, via the Steam Linux client, and otherwhise run under Wine with minimal effort. I could only find two (that you played over 5 hours) that do not run under Wine. In case you really want to run Windows, know that there is the option to have - multiple - operating systems on your hard drive, as well as run multiple operating systems (such as your linux distro + Windows whatever) at the same time.
     
    dankzegriefer likes this.
  14. HaloEffect17
    OP

    HaloEffect17 Splatoon Fan

    Member
    1,033
    976
    Jul 1, 2015
    Canada
    Alright, figured it out guys. :)It revolves around disabling "Reboot" in Task Scheduler. I'm going to try this out now: http://winaero.com/blog/how-to-permanently-stop-windows-10-reboots-after-installing-updates/. Here's an excerpt of it below.

    With Windows 10 Anniversary Update, Microsoft implemented a new feature called "Active Hours". It is intended to not disturb the user during the specified period of time. You can use it to postpone reboots.

    If you do not want to wait for Anniversary Update (which will be released in July 2016) or if Active Hours is not a solution for you, you can permanently stop Windows 10 reboots after updates are installed if you follow the steps below.

     
    Last edited by HaloEffect17, Aug 10, 2016
  15. dankzegriefer

    dankzegriefer GBAtemp Advanced Fan

    Member
    829
    437
    Aug 19, 2015
    United States
    It's also dangerous and worse than changing to Linux.
     
  16. HaloEffect17
    OP

    HaloEffect17 Splatoon Fan

    Member
    1,033
    976
    Jul 1, 2015
    Canada
    Um... how is this method dangerous?
     
  17. dankzegriefer

    dankzegriefer GBAtemp Advanced Fan

    Member
    829
    437
    Aug 19, 2015
    United States
    Security flaw needs to be fixed; Update sent; Refuse to reboot for said update; Computer gets exploited.
     
  18. HaloEffect17
    OP

    HaloEffect17 Splatoon Fan

    Member
    1,033
    976
    Jul 1, 2015
    Canada
    This method only disables Windows Update from auto-rebooting after installing updates. I can still click "Restart Now" in settings to commence the update process. This was how it was before the anniversary update anyways; I have control of when I want to restart and thus update the computer.
     
    Last edited by HaloEffect17, Aug 10, 2016
  19. dankzegriefer

    dankzegriefer GBAtemp Advanced Fan

    Member
    829
    437
    Aug 19, 2015
    United States
    And how many times a day do you READ the update notes?
    Never you say?
    Hmmmm
     
  20. HaloEffect17
    OP

    HaloEffect17 Splatoon Fan

    Member
    1,033
    976
    Jul 1, 2015
    Canada
    Are you concerned with a Windows 10 computer not updating as soon as an update becomes available? Because I've disabled auto-reboot that I would not get it updated in time? I am always diligent anyways in ensuring my computer updates on Patch Tuesdays; I don't defer it to later. If there is a security flaw that the update rectifies, I update... obviously.