Will Pokemon X and Y Require to update?

Discussion in '3DS - Games & Content' started by Cha0tic, Oct 5, 2013.

  1. Cha0tic
    OP

    Cha0tic GBAtemp Fan

    Member
    452
    131
    Mar 14, 2013
    United States
    I have a Super Card DSTWO but curious when x and y are here will they require a update as soon as you play? Or is there update available for it already? my fw is 4.5.0-10u
    should I just update to the latest? What do you think?
     


  2. Xexyz

    Xexyz GBATemp's™ Official Xexyz

    Member
    1,386
    440
    Jul 29, 2013
    沖縄県
    You can't play 3DS games on DSTwo. Just update the DSTwo FIRST then update your 3DS.
     
  3. GamerzHell9137

    GamerzHell9137 GBAtemp Psycho!

    Member
    3,824
    1,645
    Nov 1, 2011
    Bosnia and Herzegovina
    First of all Pokemon XY is a 3DS game.
    DSTWO can't run 3DS games, only Gateway 3DS can.
    Its 80 $ and it supports fimrware 4.1-4.5, so if you want to play 3DS games get the gateway and don't update ur 3DS.
    And Pokemon won't be possible to pirate for a while, its 100% pirated protected so the gateway team needs to crack the protection first which is gonna take a while.
     
    Margen67 and Nusdogg like this.
  4. Nusdogg

    Nusdogg GBAtemp Fan

    Member
    369
    45
    Feb 3, 2013
    United States
    St. Paul, MN
    What GamerzHell said.
     
  5. Dartz150

    Dartz150 GBATemp Official Lolicon Onii-chan™

    Member
    1,406
    845
    May 5, 2010
    Mexico
    On a Strange Journey
    Source? Is the game already dumped? and it REALLY HAS AP protecion? o.O, my Aruceus desu... the scene battle has begun.
     
  6. Xexyz

    Xexyz GBATemp's™ Official Xexyz

    Member
    1,386
    440
    Jul 29, 2013
    沖縄県
    It's not dumped.
     
  7. Niksy

    Niksy Advanced Member

    Newcomer
    97
    72
    Oct 23, 2010
    You have to be pretty stupid and/or naive to think that Pokemon X/Y will not have an update. Of course it will, unless Nintendo are that stupid.
     
    Ammako likes this.
  8. Dartz150

    Dartz150 GBATemp Official Lolicon Onii-chan™

    Member
    1,406
    845
    May 5, 2010
    Mexico
    On a Strange Journey
    Then I didn't missed anything, is just Gamerzhell making wild assumptions, thanks for the answer, but I wont be really surprised if it comes with strong AP protection, if I'm correct, Munster Hunter 4 has a strong one.
     
  9. calmwaters

    calmwaters Cat's best friend

    Member
    1,718
    375
    May 27, 2013
    United States
    happy land
    I keep thinking these games have already come out, what with all the activity on this particular section of the forum relating to Pokemon.
     
  10. GamerzHell9137

    GamerzHell9137 GBAtemp Psycho!

    Member
    3,824
    1,645
    Nov 1, 2011
    Bosnia and Herzegovina

    Ofc the game is gonna be AP Protected, Ninty is not so stupid to not AP Protect a game like Pokemon.
     
    Ra1d and Ethevion like this.
  11. Ra1d

    Ra1d GBAtemp Maniac

    Member
    1,207
    679
    Jul 31, 2010
    Canada
    Of course there will be AP,it's not like NDS where it takes a few hours to get a patch for AP,in this case it could take days/weeks,which will force a lot of people to buy the game rather than wait for AP patch which even if released won't let them play online which is what Pokemon is all about.
     
  12. MrAnalysis

    MrAnalysis Member

    Banned
    32
    6
    Aug 15, 2013
    UK
    Even if its not AP patched, and it does work on gateway you can't play it online and wont be able to use pokebank anyway so it would be pointless. You will end up playing on your Todd unable to trade online and stuff you won't really be playing the game at its best.

    If you plan on buying the game and already have a gateway 3ds but want to use your 4.5 3DS to play games with gateway and still run retail pokemon then you are out of luck. No one is sure at the moment but its near enough 100% that you will be FORCED TO UPDATE from 4.5 to a higher firmware. This would make the gateway 3ds unusable unless the get it working on higher firmware.

    So in short, If you have a gateway 3ds and want to run pokemon x or y retail on the same DS you wont be able to you will get forced to update and the gateway will no longer work.

    Your only hope is gateway manage to make an online mode and make it work with new firmware. Oh and also that they crack any AP pokemon has. Not gonna happen anytime soon far to many If's, Buts and whens.

    Sell the gateway 3ds and play pokemon x and y legit or don't play pokemon. Oh i guess buy a second 3ds for it?

    If its just Pokemon X and Y LEGIT you want and still want to run games from DSTwo / R4 in DS mode then this is possible if the DSTWO / R4 works on the same firmware Pokemon X or Y is on. Since it has shipped and was compiled / Places onto cards over a month ago you can guess firmware will be at 6.1 or less. So if the DStwo or R4 is working on that firmware you have nothing to worry about. Only worry when the DStwo/R4 stop making updates to allow it to run on new firmware.
     
    Nusdogg and SuzieJoeBob like this.
  13. UltraMew

    UltraMew GBATemp's Mew PRETENDING TO BE FOXI4 4 A DAY

    Banned
    861
    146
    Aug 7, 2013
    United States
    Flying a blue hedgehog around
    Yeah, to 6.1.0... DSTwo is compatible with all firmware :)
     
  14. Cha0tic
    OP

    Cha0tic GBAtemp Fan

    Member
    452
    131
    Mar 14, 2013
    United States
    You guys all misunderstood, I'm not talking about running x and y on my supercard. I'm talking about a update for the 3DS to play x and y, a required software update. Just how the wii requires updates for new games or did.
    Curious, because when I get it i'll be in the mall with my girlfriend so I would like to know if there is a update already so I can update it and play it as soon as I get it or if it requires one so then I don't have to get excited for nothing and just wait till we get back to her house.
     
  15. Snailface

    Snailface My frothing demand for 3ds homebrew is increasing

    Member
    4,324
    1,983
    Sep 20, 2010
    Engine Room with Cyan, watching him learn.
    It is included on the card and will update before you play. It will probably be v6.1-v6.2, so you likely won't even have to update if you're already up-to-date on 6.3. You will be able to play at the mall in any case.
     
  16. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,932
    Sep 8, 2009
    One's inner self
    Pokemon X & Y have the 6.1.0 update built into the Rom

    if you 3DS is not up to that version the game will ask to update when you boot it
     
    Snailface likes this.
  17. WiiUBricker

    WiiUBricker Insert Custom Title

    Member
    6,897
    3,925
    Sep 19, 2009
    Argentina
    Espresso
    How do you know?
     
  18. gamefan5

    gamefan5 Kid Icarus Uprising connoiseur

    Member
    4,946
    2,067
    Aug 29, 2010
    Canada
    Somewhere in this Earth
    Same here.
    He keeps making assumptions like this every year.
     
  19. KazoWAR

    KazoWAR GBAtemp Advanced Maniac

    Member
    1,799
    681
    Aug 12, 2008
    United States
    Winter Haven
    probably from all the pokemon leakers
     
  20. Arras

    Arras GBAtemp Guru

    Member
    5,858
    2,673
    Sep 14, 2010
    Netherlands
    Just make sure the Supercard is updated and you'll be fine. The latest 3DS firmware is supported by the DS2.