WiiSX 2.1 - How do I load using SAMBA?

Discussion in 'Wii - Emulation and Homebrew' started by Vincent Panetta, Jul 24, 2013.

  1. Vincent Panetta
    OP

    Vincent Panetta Newbie

    Newcomer
    1
    0
    Jul 24, 2013
    United States
    I want to be able to load .bin files stored on a share of my WD MyBook thru SAMBA on WiiSX

    The version of WiiSX I am using is straight off of the Homebrew Browser; WiiSX Beta 2.1.

    I have been able to successfully play some .bin files using SD with BIOS settings HLE as well as scph1001.bin.

    I have also successfully used smb for WiiMC, NES:FCE Ultra GX, SNES9xGX, and VBAGX for playing roms.

    I edited the settings.cfg as follows:
    smbusername = ""
    smbpassword = "**SHAREPW**"
    smbsharename = "PS"
    smbipaddr = "192.168.1.108"
    When I click load samba it opens successfully but shows none of the .bin files. Occasionally one of the files will show up but will not successfully load and the next time I try to open it, it will memory dump.

    Originally I had the share folder containing only the .bin files. Then I tried setting up the share similar to the SD:

    "Device:/apps/wiiSX/" Put boot.dol, icon.png and meta.xml here
    "Device:/wiisx/bios/" Put your bios here
    "Device:/wiisx/isos/" Put your ISO/BIN/CUE here
    "Device:/wiisx/saves/" your memory cards will be stored here (each game its own memory card).

    I have tried to comb through the threads with varied success as I have yet to read about an identical issue with SMB. Thanks in advance.

    ********************************************
    UPDATE: I was trouble shooting to make sure I could also read off of USB and when I realized it was only my SD card that had functionality. I came across a recompiled version of 2.1 with better usb support and consequently also has improved SMB functionality and everything works great. The version of WiiSX directly off the Homebrew Browser for some reason would not support the SMB setup likely due to the previously known 'anonymous user' bug. Although I thought 2.1 was supposed to have it solved I guess the HBB version was not recompiled so.

    P.S. Thank you Cyan for the swift reply
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,045
    8,564
    Oct 27, 2002
    France
    Engine room, learning
    Maybe you can try to add a username.

    I used smb to load ISO without problem, the only different is that I'm having a username.
    Maybe on your computer, set all rights to the folder for the said user, or for guest user.
     
  3. paradoxgrowth

    paradoxgrowth Newbie

    Newcomer
    1
    0
    May 22, 2016
    United States
    Hi, I am having problems too. Everytime, I click the samba button, it says samba not configured. I don't understand because, when the program first booted it told it to save the settings config to the SD card. I then found the wiisx folder in the root of my SD card, I changed it to my LAN settings just like Vincent above (except I have a password). I saved it both to the wiisx folder in the root and to the wiisx folder in the apps folder and it still doesn't work. It says in the documentation that it loads that settings.cfg file automatically so why is it not reading my settings?

    Audio = 1
    Volume = 3
    FPS = 0
    ScreenMode = 0
    VideoMode = 0
    FileSortMode = 1
    Core = 0
    NativeDevice = 0
    StatesDevice = 0
    AutoSave = 1
    BiosDevice = 0
    BootThruBios = 0
    LimitFrames = 1
    SkipFrames = 0
    PadAutoAssign = 1
    PadType1 = 2
    PadType2 = 0
    PadAssign1 = 0
    PadAssign2 = 1
    RumbleEnabled = 1
    LoadButtonSlot = 4
    ControllerType = 0
    smbusername = “myusername”
    smbpassword = “mypassword”
    smbsharename = “Boy-05”
    smbipaddr = “192.168.0.100”
     
    Last edited by paradoxgrowth, May 22, 2016