WiiFlow and the occurring exception

Discussion in 'Wii - Emulation and Homebrew' started by wiikend, Aug 2, 2014.

  1. wiikend
    OP

    wiikend Newbie

    Newcomer
    5
    2
    Aug 2, 2014
    Once upon a time,
    My Wii got hacked, 4.3E, using letterbomb or bannerbomb, I forget exactly which one as it was a long time ago, in a galaxy far far away.
    It worked great, I had some emulators on there and enjoyed Megadrive and Spectrum classics.
    All was well.
    Then I discovered WiiFlow, via a youtube user, my eyes were lit with joy at the visuals.
    I managed to fluke my way to getting it installed, eventually, tbh the whole ios version thing still is not crystal to me, I just follow instruction, and seemed to had got lucky. WiiFlow was working and showing the few Wii titles I had on my usb.
    But then I got greedy, I wanted more and better things, having seen a WiiFlow Masterpiece Pack on youtube, showing off WiiFlow with other emulators including Megadrive and Spectrum. I had to have it.
    I saw a google code page with a WiiFlow plugins pack, and downloaded it.
    I encountered problems on the journey...
    ...Plugins not found...
    But overcome these, again with some luck and posts I found on these forums.
    At first I was not referencing the correct source of usb1, then when changed that the plugins were found.
    They even showed in my WiiFlow, I could see the thumb icons for all the emulated systems.
    I tried to get them working, by adding my roms to:
    \[usb root]\wiiflow\plugins\roms\megadrive\
    Then updating the megadrive plugin ini to point to that as a rom path.

    I failed my mission.
    When I rebooted, I came face to face with more troubles...
    ...Games not found...
    The WiiFlow menus looked themeless, all white looking and without the arrow buttons which were in the menus previously, like when you visit a webpage and the css has vanished.
    I went and changed my source to usb2, I'm not even sure why, I was clutching at straws and confused why it wasn't finding any games now.
    Rebooted again, and my path is blocked by the dreaded Exception [DSI] Occurred, followed by an army of numbers which mean nothing to me.

    Can anyone help me live happily ever after, I just want Spectrum games showing within the eye candy that is WiiFlow.
    Each time I start WiiFlow now, I get this same screen.

    Help me GBAtemp, you're my only hope
     
    mightymuffy likes this.
  2. VashTS

    VashTS Beat it, son

    Member
    3,896
    698
    Mar 14, 2009
    United States
    Upstate NY
    First, clean install. Delete all but your WBFS folder and any other Apps you want to keep. Grab Abz masterpiece and copy all of it over to USB if thats where you keep your homebrew.

    second, grab the latest Wiiflow, r1075 and copy ALL of the files and overwrite ALL of the files. (its important, not copying the folders in the Wiiflow archive will break things!!!)

    Third, add roms and stuff. Check the Wiiflow/plugins folder for the .ini files. Open it with notepad or something similar and check when the roms go. Put the roms there. If you want covers, the info is in the ini as well.

    This should do it.
     
  3. mightymuffy

    mightymuffy fatbaldpieeater

    Member
    GBAtemp Patron
    mightymuffy is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,327
    522
    Nov 6, 2002
    United Kingdom
    Wigan, land of the Pies
    What an awesome post! :D Well worth a read, even though VashTS has answered your question perfectly. A couple of things may have gone wrong, so 'wipe n start again' is definitely the best option.
    Extra tip: if you want to put your roms in a different folder, my suggestion would be to create a 'roms' folder on your root, ie for megadrive have it as root:roms\megadrive, then of course change the plugin ini accordingly (personally I'd just follow the structure in the plugin, at least until you've got everything firing up)
     
  4. wiikend
    OP

    wiikend Newbie

    Newcomer
    5
    2
    Aug 2, 2014
    Hi guys, I'm back, and I've brought more questions with me :)

    But first, I want to thank you VashTS!
    Your suggested solution worked a treat, and I actually have a slightly better understanding of the roms path structure now... In that it references from root level rather than a relative path from the ini, which I had thought.

    So, I deleted all files from my usb, also removed the WiiFlow dir I had on my sd card.
    Copied over the excellent Abz Masterpiece pack to my usb [https://dl.dropboxusercontent.com/u/101209384/MasterPiece/Wiiflow_Pack.html]
    Downloaded the latest WiiFlow 4.2.1 [https://code.google.com/p/wiiflow/downloads/list]
    Patched that with the r1075 beta, and renamed the 'wiiflow-beta' dir within apps to 'wiiflow', so it overwrote the existing dol [http://fix94.no-ip.org/wf_revs/]
    Copied a few SMD roms to the default location, as per the plugin ini file

    Booted up the Wii again and BINGO! Back in the game :)

    Got the prompts again to define my usb as source of plugins and games.

    Clicked the button in WiiFlow to get to the source input, then selected Megadrive, and it loaded my few games in the nice flow gallery.
    Didn't have any cover art images but I will work on that soon enough, at least my main problem you have sorted for me, so thanks!


    Now, my new question :)

    When I accessed the game from the WiiFlow menu, which was Herzog Zwei, it didn't just start up the game...
    ...It loads the emu Genesis Plus GX.
    Wherein, I went into the options to change the value for 'ROM Load Device' from 'sd' to 'usb'.
    Then when I return out of the emu menu and go into game selection, I can see my few SMD roms which I added :) And can launch it successfully and it's game on!

    That is all as it should be, right?
    Selecting the game from the list should then load the emu, where you then use the emu menu to load the actual game up.
    I tried to be clever, as saw a setting in Genesis Plus GX options menu which was 'auto ROM load' and changed it from 'off' to 'on' ... My thinking was it might allow the game to boot direct from the WiiFlow menu rather than having to go into the emu menu first.
    Guess what that does... gives me DSI Occurring Exception again :)
    I sorted that though, by deleting the 'genesis' dir which had been created on my sd card, which has the settings and history ini files.
    On reboot again, those were created as defaults and all is well once more.

    I'm just checking really to make sure that is how it should be, and I'm not missing a step which would allow me to boot the game directly from WiiFlow, bypassing the individual emulator screens.

    Thanks again for your help, worked a treat


    mightymuffy, cheers. I'm going to keep the games in their default paths I think, just for ease. And will spend this evening sourcing the cover art and making it look that bit more complete and pretty :)
     
  5. mightymuffy

    mightymuffy fatbaldpieeater

    Member
    GBAtemp Patron
    mightymuffy is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,327
    522
    Nov 6, 2002
    United Kingdom
    Wigan, land of the Pies
    Ahh, the covers! Yep, just grab the downloads from mastershoes sticky (another tip, do one at a time! It's a fair amount of work.... Also grab some of the mentioned programs like Bulk Rename Utility)

    Not sure about your Genesis Plus GX problem - I get the same thing on the Intellivision plugin (selecting game but having to select again in the menu), but I actually use Retroarch for the Megadrive stuff (which loads straight to the rom)..... I'm currently doing some covers so have my hard drive plugged in - give us 5 minutes, I'll give Gen GX a go then edit...

    EDIT: Boots straight to game here :lol:, sorry but I'm not sure how to fix your problem either - perhaps try the emu via the HBC and point it to the right directories .....I bet someone on here knows more than me though!
     
  6. wiikend
    OP

    wiikend Newbie

    Newcomer
    5
    2
    Aug 2, 2014
    Thanks for checking. I'll look into it tonight, though doesn't really matter if I can't sort that out, I can live with the couple extra clicks.
    Checked out those covers, wow, quite a collection in there! I d/l a batch and used the fuzzy tool, it matched and renamed about 40 or so for me, which is great, the rest I will do manually.
    Going to take a backup copy of my usb drive as it is right now, just in case I mess things up.
    ....slowly but surely