Wii u - DLC?

Discussion in 'Wii U - Hacking & Backup Loaders' started by S-toon, Jun 22, 2015.

  1. S-toon
    OP

    S-toon Newbie

    Newcomer
    8
    0
    Jun 19, 2015
    United States
    I am very new to this, and I tried searching but still confused after reading a bit.

    I have installed The Homebrew Chanel on the vwii and using nintendont, and an emulator for nes, snes, and n64 and that's as far as I'm going with this. Basically was looking to make it my all in one Nintendo gaming system. Being able to play, Nes, Snes, Game Cube, Wii, and Wii U games.

    I don't have internet at home so don't really worry about my wii u updating by itself.

    But there are some dlc that I would like to get for games like smash bros, mario kart 8, ect...

    So is there any way to get dlc for games without updates or whatever it is that will mess up the wii u or whatever it is that it does?

    I would basically be bringing in my wii u to work and use the internet here to get the dlc.

    Thanks!
     
  2. EmceeKerser

    EmceeKerser GBAtemp Maniac

    Member
    1,374
    503
    Jun 3, 2014
    The fuckin' Blue Mountains brah
    No, to get access to the eshop, you must update.
     
  3. Slartibartfast42

    Slartibartfast42 GBAtemp Advanced Fan

    Member
    825
    237
    Mar 6, 2013
    United States
    You have to make a choice, DLC now, and wait for the 5.4.0 exploit to come out, or exploit now, and wait for an updated exploit or EmuNAND before DLC. I would guess that by the time the exploit is really useful, they would have figured out 5.4.0. It's just the userspace exploit that would need updating. The kernel exploit and the IOSu exploit would still work on 5.4.0. I would suggest getting the DLC and anything else you want, games, demos, etc, now, and then don't go past 5.4.0.
     
  4. kprovost7314

    kprovost7314 GBAtemp's Official Bara Master

    Member
    1,713
    923
    Dec 24, 2014
    United States
    In that bara manga ( ͡° ͜ʖ ͡°)
    You can't get it now. There's an update blocking it.
     
  5. Slartibartfast42

    Slartibartfast42 GBAtemp Advanced Fan

    Member
    825
    237
    Mar 6, 2013
    United States
    He can do the update, then get the DLC. His vWii will still work. IMHO, the DLC is more important then not updating.
     
  6. Antonio Ricardo

    Antonio Ricardo GBAtemp Fan

    Member
    358
    230
    Apr 29, 2013
    Brazil
    Rio de Janeiro
    Hykem said on twitter Webkit Exploit 5.4.0 has a lot of bugs and will be hacked but wiiu scene focus is 5.3.2 now.

    Hykem 06/19/2015: The WebKit source code wasn't updated that much (536.28 to 536.30). Tons of vulnerabilities have been found since then.

    On the beggining when 5.4.0 out Hykem said not to update because will take longer but now he found tons of vulnerabilities so preview 5.4.0 hacked is more optimistic.
     
    Last edited by Antonio Ricardo, Jun 23, 2015
    Simonwayneee likes this.
  7. S-toon
    OP

    S-toon Newbie

    Newcomer
    8
    0
    Jun 19, 2015
    United States
    So if I hook up my Wii U to the internet and get DLC for like Smash Bros, it will update and I won't be able to use the Homebrew Channel and the stuff I installed anymore?

    Or what exactly will happen?

    Thanks,
     
  8. Slartibartfast42

    Slartibartfast42 GBAtemp Advanced Fan

    Member
    825
    237
    Mar 6, 2013
    United States
    You will still be able to use the HomeBrew Channel and everything else you have on the vWii side. You just won't be able to use the brand new Wii U side exploit for a little while. It doesn't do that much yet. If all your care about is playing unmodifified, correct region, Nintendo games, then the update is safe. If you want to participate in hacking the wii U, make your own homebrew software, cheat online, play game modifications, region-free hacks, etc, then maybe not update. Updating now means you have to wait a bit longer to do that stuff , on the Wii U side. Your vWii side is safe.
     
  9. S-toon
    OP

    S-toon Newbie

    Newcomer
    8
    0
    Jun 19, 2015
    United States
    So it only affects the Wii u side, got it.

    What I have done is all I am looking to do! Just be able to play Nes, Snes, N64 roms, and Game Cube isos on vwii.

    I will not be messing with anything on the Wii U side.

    So I should be good then, right? Just want to be clear lol
     
  10. rufuszombot

    rufuszombot Assassin

    Member
    408
    175
    Apr 13, 2010
    United States
    The Moon
    As long as you follow the vWii guides, you'll be fine. If you happen to mess something up, it could prevent you from updating on the Wii U side and possibly brick the vWii side. So, stick to the guide.
     
  11. S-toon
    OP

    S-toon Newbie

    Newcomer
    8
    0
    Jun 19, 2015
    United States
    Yes I followed and installed on the vwii what I wanted already.

    This is what I have.

    The Homebrew Channel.
    FCE Ultra GX 3.3.4 to play Nes roms.
    Snes9x GX 4.3.2 to play Snes roms.
    Not64 to play N64 roms.
    Nintendont to play Game Cude isos.
    VBA GX 2.3.2 to play gb/gbc/gba roms.

    Everything is working great!

    So as long as I don't add anymore stuff, well as long as I make sure first it is ok, I should be good?

    Or what I have installed on the vwii mess up once I go to get DLC for the games on Wii U?

    Being as I only have been reading about this and installed this stuff over the weekend just want to be sure everything is good, and I won't mess anything up by getting DLC for my Wii U games.
     
  12. rufuszombot

    rufuszombot Assassin

    Member
    408
    175
    Apr 13, 2010
    United States
    The Moon
    As long as everything is working fine, and it allows you to update the Wii U and download DLC one won't affect the other. So, you should be fine.
     
  13. EmceeKerser

    EmceeKerser GBAtemp Maniac

    Member
    1,374
    503
    Jun 3, 2014
    The fuckin' Blue Mountains brah
    Should be fine
     
  14. S-toon
    OP

    S-toon Newbie

    Newcomer
    8
    0
    Jun 19, 2015
    United States
    Ok great! Thanks for the help :)