Wii system update

Discussion in 'Wii - Hacking' started by DrMDGG, Oct 23, 2016.

  1. DrMDGG
    OP

    DrMDGG Newbie

    Newcomer
    1
    0
    Oct 23, 2016
    Canada
    Hello....

    I have a soft modded Wii and usually use a hard drive with backups. However I went to play Mario kart Wii with my daughter and it told me I had to do a system update.
    I've had this problem before and installing a certain ios fixed it. But this time k can't seem to find that information. How do I get rid of this?

    I have tried using priiloader to change the update setting but it didn't work.

    Any information is welcome and appreciated
     
  2. pokemonster
    This message by pokemonster has been removed from public view by Cyan, Oct 31, 2016, Reason: spam.
    Oct 29, 2016
  3. kittensauce

    kittensauce Got a spare screen?

    Member
    202
    67
    Mar 22, 2016
    United States
    NOTE: MAKE A NAND BACKUP BEFORE DOING ANY OF THIS BECAUSE I MIGHT BE WRONG
    I presume you've installed a cIOS, most likely d2x-cIOS. You simply need to reinstall the cIOS's via the installer, this time selecting a cIOS revision of 65535.
    If that doesn't work, you might not be on OS 4.3, in which case you should update to OS 4.3 and reinstall the Homebrew Channel via Letterbomb, afterwards following the guide I had previously linked.
     
    Last edited by kittensauce, Oct 29, 2016
  4. Wizardkoer

    Wizardkoer Wii Veteran

    Member
    428
    81
    Jul 14, 2015
    Australia
    I haven't been at the Wii scene for a while so I forgot a lot of stuff, but won't using a usb loader like USB Loader GX remove any need for system updates? And for MK Wii it uses non-patched IOS36 (v3608). Try installing this to an IOS slot that's free and set it to boot ti MK Wii with that IOS it should fix the problem I believe but idk.
     
  5. kyle9252

    kyle9252 Advanced Member

    Newcomer
    98
    9
    Oct 4, 2016
    United States
    Do you have 4.3?
     
  6. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,586
    8,925
    Oct 27, 2002
    France
    Engine room, learning
    yes, he can use a loader to launch the game, and it will not ask to update.

    I guess he just tried to play from your disc.
    Kittensauce gave the right answer, it's because of your cIOS version. The disc have the same data with a higher version and think it has to update it. this is nintendo's way to prevent piracy. replacing hacked files with newer non-hacked ones.
    the counter to this is to install a hacked one with an even higher version number (65535 being the max version a title can have).

    Another solution is to install Priiloader, and enable the option "do not ask to update from disc". I don't know why it didn't work.

    the easiest solution is to install your game on USB and launch it from the USB Loader. You can even launch the disc directly from the USB Loader without installing the game to USB if you want.
     
  7. banjo2

    banjo2 child

    Member
    228
    28
    May 31, 2016
    United States
    USA
    I suggest Priiloader. It's an easy install (all you need to do is run the installer app), and it doesn't require running any apps when you want to play. I think you can also set the Wii to boot to an app so you can set USBLGX, CFG USB Loader, or WiiFlow to boot on startup instead of the system menu. But it's your choice.