Wii power problem

Discussion in 'Wii - Hardware, Devices and Utilities' started by Xaphatro, Aug 28, 2012.

Aug 28, 2012

Wii power problem by Xaphatro at 1:57 PM (379 Views / 0 Likes) 0 replies

  1. Xaphatro
    OP

    Newcomer Xaphatro Member

    Joined:
    Mar 17, 2010
    Messages:
    25
    Country:
    India
    My wii's firmware is 4.2U, softmodded. It has darkcorps(can't remember which version), priiloader, bootmii(IOS) installed, and I still have a virgin NAND backup. I have a third party(I bet it's Chinese) power adapter, the third one after my original fried after unknowingly plugging it to a 240V plug point without a step down adapter. The others all fried(they all fried during summer, so I assume it's the heat).

    This happened like about a year ago. I had studies, so I wasn't allowed to play the wii, but my cousin used to play on it everyday. I have no idea if she did anything to it. Then one day it just wouldn't turn on. The red light would show up, but no matter what you would press it won't turn on. I left it as it was.

    Then recently I removed the power cable, left it for a couple of minutes and plugged it back in to wall outlet. The blue disc light started flashing and the red power light came on, but it didn't turn on. A multimeter check showed that the power adapter was fine.

    I bought a friend's power adapter(also 240V) and tried it. The wii turned on, but nothing came on the TV. Note that by this time the batteries on my wii remotes died out. It didn't occur to me to try priiloader then, but meh.

    Now to be clear Nintendo doesn't market where I live, we just have imported wiis. Backup loading is also quite common here, so I CAN give it for repair. But I just want to know whether I can fix my wii by myself(by trying out different cables) to save me the exorbitant prices the electricians are going to charge me.

    I'm also going to try to connect my wii at my friend's house(nobody else I know nearby has a wii) to rule out the possibility of a TV or VGA cable issue. Will post later on how it works out.

    UPDATE:
    I went to my friend's house and tried my wii out; same result, so none of the cables are bad. But I tried to boot into priiloader, and whoo! It worked. But I couldn't select anything as I didn't have my remote(the nyko rechargeable batteries ran out a long time ago; and I couldn't sync his remote to my wii on the priiloader screen, and I'm not sure if my remote is still in sync with my wii).

    Is there any way to sync my remotes or control priiloader without my remote? And if I restore my nand, will it overwrite my save files?
     

Share This Page