Wii no longer working after some time

Discussion in 'Wii - Hacking' started by ince, Jan 24, 2015.

  1. ince
    OP

    ince Newbie

    Newcomer
    5
    1
    Jan 24, 2015
    United States
    Hi

    I have a Wii which was soft modded and worked great. I had a third party power supply which was always plugged in and showed a red light when the wii was off but would not power the wii on.

    I have recently bought an official power supply and the wii now powers on but there is no picture on screen.

    when the sd card is inserted the the drive flashes once then a black screen.

    when the sd card is not inserted the drive flashes once then twice quickly and then a black screen.

    can anyone help with this or is the wii display bricked.
     
  2. nikeymikey

    nikeymikey This is now a Spiderman thread.........

    Member
    962
    134
    Nov 19, 2008
    Simple things first, i take it you have checked your av lead and its connections?
     
  3. ince
    OP

    ince Newbie

    Newcomer
    5
    1
    Jan 24, 2015
    United States
    thanks for the reply.

    yes i have tried both a component and standard av lead and same result on both.
     
  4. ince
    OP

    ince Newbie

    Newcomer
    5
    1
    Jan 24, 2015
    United States
    quick update.

    with the sd card in the wii when i switch on holding the eject button the Bootmii screen loads.

    can anyone guide me from here.
     
  5. nikeymikey

    nikeymikey This is now a Spiderman thread.........

    Member
    962
    134
    Nov 19, 2008
    Right you have bootmii so do you have a nand backup anywhere?

    Can you access the Homebrew channel from bootmii?

    If you can get to the HBC then i would try this.

    1. Download program called Modmii on your pc.
    2. Download program called Syscheck for your wii (you can get this from modmii)
    3. Run syscheck from the Homebrew Channel, let it do its thing and test your system ios etc
    4. Copy the syscheck.csv file that has been craeted on your sd card to your pc and drag it onto the modmii.exe
    5. Choose to download everything Modmii tells you to download and then follow the guide it creates to install everything onto you wii.

    Depending on what syscheck finds doing this will reinstall your system menu and any ios that are corrupt or out of date etc and hopefully this will fix your problem.

    If you are really paranoid you can make a nand backup first using bootmii, just select the sd card icon and then the icon with the arrow pointing to the sd card, this will dump your nand to a nand.bin file with a keys.bin file which you can use to restore your wii back to the state its in now if anything goes any more wrong. If the Modmii solution does fix you rproblem then i suggest you make a nand dump straight away.
     
  6. ince
    OP

    ince Newbie

    Newcomer
    5
    1
    Jan 24, 2015
    United States
    unfortunately I do not have a nand backup.

    when I select the HBC it goes to a black screen and stays there.

    because I haven't changed any setting and it was working fine I am leaning to a failed bluetooth module as the cause.
     
  7. nikeymikey

    nikeymikey This is now a Spiderman thread.........

    Member
    962
    134
    Nov 19, 2008
    You could be right , could be a hardware related problem.
     
  8. ince
    OP

    ince Newbie

    Newcomer
    5
    1
    Jan 24, 2015
    United States
    quick update. replaced the bluetooth module today and it works. thanks for your assistance nikeymikey.
     
    nikeymikey likes this.
  9. nikeymikey

    nikeymikey This is now a Spiderman thread.........

    Member
    962
    134
    Nov 19, 2008
    No worries mate, glad to help :)