Wii Corrupt System Files On Boot

Discussion in 'Wii - Hacking' started by Jedi Rainman, Jun 3, 2013.

  1. Jedi Rainman
    OP

    Jedi Rainman Newbie

    Newcomer
    2
    0
    Jun 3, 2013
    United States
    I have been searching for almost 3 weeks and yet I cannot find my exact problem or a fix for it anywhere. My launch Wii has been in it's box for almost 2 years. I just recently hooked it back up so my son could play some games. When I turned it on, it said that I had "Corrupt System Files" so I ended up rebooting it with 'Reset' held in and the problem was fixed. The next day, I get the same exact message, but now, the 'Reset' fix isn't working. I went through the whole process of modifying a GameCube controller and the system posts, at the bottom right of the screen, that I have firmware version 4.1 (USA). I couldn't get anything to work. I ended up ordering a WiiKey Fusion and installed it. I'm still at a standstill. I do remember having the HBC installed. I have burnt many discs with no luck. Is there something that I'm missing or is my Wii toast?
     
  2. Duckuss_Maxximo

    Duckuss_Maxximo Advanced Member

    Newcomer
    61
    6
    Nov 20, 2012
    United States
    Hmm that's strange. Can you get to the homebrew channel? If so maybe you could use cIOSX and remove those corrupted IOS if that's the case. Idk for sure as the details are unclear. Could you elaborate more or snap a few photos so someone may be able to assess the situation better? I know when they came out with the Youtube channel for 4.3 I installed it from the shop and it messed up my mods but once I used this it fixed everything and I never had a problem with the shop or any updates again. I recently upgraded the Youtube channel not too long ago through the shop without any problems either.

    http://gbatemp.net/threads/ciosx-rev21d2x-yet-another-hot-fix.277659/
     
  3. Jedi Rainman
    OP

    Jedi Rainman Newbie

    Newcomer
    2
    0
    Jun 3, 2013
    United States
    I power on my Wii, get the system files are corrupt message and that is it. If I plug my GameCube controller into port 4 and hold down the D-Pad, then power up the Wii, I get the 4.1 USA in the bottom right corner on the TV. There is no 'Health and Safety' screen or system menu that loads. Is there something that I'm not doing right or haven't tried?

    ***I've been trying different programs using an SD card that is compatible plus DVD-R media and I always get the same results.
     
  4. worm28

    worm28 GBAtemp Advanced Fan

    Member
    677
    128
    Jun 2, 2013
    United States
    Plug your gamecube controller into port 4 hold down d pad, When you get 4.1u in the bottom right corner of screen insert mario kart game disc into wii or any other game disc with 4.3 update and it should update your wii to 4.3 fixing your problem. correct me if im wrong
     
  5. mauifrog

    mauifrog DA KINE WiiHacker

    Member
    1,585
    90
    Jan 21, 2010
    United States
    Burn super smash bros brawl pal patched to autoboot and regionfrii to usa. Then load smash stack pal. Use modmii to softmod the wii again, tell it your wii is 4.1u virgin, use the smash stack pal exploit to load the hackmii installer.