Whoa! HBC is...upside down?

Discussion in 'Wii - Hacking' started by Dr Awesomo, Dec 20, 2010.

Dec 20, 2010

Whoa! HBC is...upside down? by Dr Awesomo at 5:47 AM (3,208 Views / 0 Likes) 18 replies

  1. Dr Awesomo
    OP

    Newcomer Dr Awesomo Advanced Member

    Joined:
    Jan 20, 2010
    Messages:
    60
    Country:
    Canada
    RESOLVED! Thanks Mauifrog, and everyone else who stuck around to help out.





    Alright guys, try this one on for size...

    Priiloader 4.0 is the recommended protection suite for 4.3u, apparently, so I figured I's set my Wii up with it. This way, I can still play my new RB3 without having to toss my current IOS exploits out the window via it's minor system update (Apperently, it needs stub249, which doesn't fly well with me, and I'd rather stick with v20). I run the priiloader installer, and it says IOS58 needs ES_IDENTIFY to continue. So, I load up Dop-Mii, and apply the patch.

    I run the installer again, it says IOS61 needs the same patch, so again, I patched it with Dop-Mii...

    Now...the Homebrew channel is displayed upside down. Everything works, but it's a pain in the ass.

    Haven't installed priiloader yet, but Ill be working on that while I await some assistance. That said, anyone know how to fix this??

    Thanks in advance

    EDIT: well, it seems that none of the apps at my disposal wish to let my wiimote connect once it's started. However, when I start CFG Loader, it claims that IOS249 doesn't exist, and that I should install it..Apperently, patching IOS61 deletes IOS249...to everyone reading this...DON'T DO THIS! For the sake of being a nice person, TEL YOUR FRIENDS, TOO! Alright, enough Caps lock...Anyone know How I an go abouts reinstalling IOS249 if my Wiimote doesn't work, and no installer seems to support GC controllers?

    Also, the whole upside-down HBC is still an issue....yeah...

    (I think I speak for everyone when I say...WTF Happened? Let's band together and figure this one out ^^)
     
  2. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    Reinstall IOS58 and 61 with NO patches. Then, reinstall HBC 1.0.8 so it uses the unaltered IOS58.

    Then, if you haven't installed priiloader, try installing it again.
     
  3. Dr Awesomo
    OP

    Newcomer Dr Awesomo Advanced Member

    Joined:
    Jan 20, 2010
    Messages:
    60
    Country:
    Canada
    Hahah, I'd love to, but since none of my Homebrew apps register the wimmote anymore, that makes that tactic...impossible, really. Dop-Mii keeps getting stack dumps when I try to use a GC controller, and ciosx Rev20 just doesn't wanna work...which is odd, cause I beleive that was an added feature...

    At any rate, I'm hesitant to jus run the RB3 update, cause there's a lot that could go wrong...any other suggestions?
     
  4. Skiller

    Member Skiller GBAtemp Regular

    Joined:
    Mar 12, 2009
    Messages:
    144
    Country:
    Canada
    thats not a nice error ..

    but its true the only way to fix your error is to Install the normal Ios ..

    Since u have HBC installed and u said u can use it its just your apps not working .. maybe try out

    Multi mod Manager 13.4 this will alow u to delete ios as well as install .. if u can get this loaded it be your best bet ..
     
  5. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    cIOS may very well be hosed. I'd worry about fixing HBC first though.

    If you tell DOP-Mii to use an IOS other than 249 (say, 36 or 236), does the wiimote still work? Or does the remote die as soon you start the app, before you can select anything?

    Also, download Multi-mod Manager and try using that.
     
  6. Dr Awesomo
    OP

    Newcomer Dr Awesomo Advanced Member

    Joined:
    Jan 20, 2010
    Messages:
    60
    Country:
    Canada
    @ Both of ya's

    I actually happen to have Multi-Mod-Manager, and I've been messing around with it with the GC controller, (cause, yes, the wiimote kills upon launch of any app)

    However, it freezes up after a coupla seconds, or when I pass the selection over "Manage Preloader", which ever happens first.
    (I don't even have to pick it, just pass it...kinda ironic, as this all started whilst trying to install said preloader)

    Most of the other mods available don't work for unknown reasons, probably as a result of a missing/stub/non-stub ios249 (confusing, right? I know...)
     
  7. Skiller

    Member Skiller GBAtemp Regular

    Joined:
    Mar 12, 2009
    Messages:
    144
    Country:
    Canada
    wow another thing good to know do u have a Wii that is not connected to wifi/net

    HBC likes to crash apps if u have the AHBPROT mode and no net for some odd reason ..

    u would need to Disable Ahbprot from the Meta file ..
     
  8. mauifrog

    Member mauifrog DA KINE WiiHacker

    Joined:
    Jan 21, 2010
    Messages:
    1,585
    Country:
    United States
    Try to run Multi Mod Manager via disc exploit
    http://www.4shared.com/file/byzXSRT1/boot.html
    When it loads, reload to ios250, reinstall ios58 and 61
    While your in MMM, launch priiloader via the app manager
    Then install priiloader with ios250- assuming it has the es-identify patch.
     
  9. Dr Awesomo
    OP

    Newcomer Dr Awesomo Advanced Member

    Joined:
    Jan 20, 2010
    Messages:
    60
    Country:
    Canada
     
  10. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    Don't worry about remodding until after you fix the wii.

    Try what mauifrog recommended first. If it doesn't work, I'd say the bootmii restore is probably next...
     
  11. burritoboy9984

    Member burritoboy9984 GBAtemp Advanced Fan

    Joined:
    Jan 24, 2009
    Messages:
    845
    Country:
    United States
    You can try using this if you already have the wads. Just make sure to create a wm_config.txt file in the wad directory, and include something like below to automatically load an IOS. It will install ALL the wads in /wad so make sure you only have the fresh IOS wads in there... Or you could hit up the Modify ANY Wii sticky, grab the up42 for your region through the email, load up hbc and run YAWM Multimod Batch, and it will start installing all the latest IOS and it will install system menu 4.2 along with a fresh IOS70 (obviously if you don't want those, delete them from the /wad directory before running the app).

    Code:
    StartupPath=/wad
    cIOSVersion=36
    FatDevice=sd
    -Erik

    Edit: Or if you just want to restore cIOS, you can grab the 43mod pack, and follow the guide as it is almost completely automated (minus the priiloader part which you will need to hit + to install).
     
  12. Dr Awesomo
    OP

    Newcomer Dr Awesomo Advanced Member

    Joined:
    Jan 20, 2010
    Messages:
    60
    Country:
    Canada
    To everybody:

    Nothing like code and gonfig.txt to make it sound reliable. Unfortunately, my wii is incapable of mounting sd/usb devices, based on my attempts thus far. Regardless of the method used to launch an app, all of them return -ret errors when trying to mount the device. Network installs of anything are also out of the question, as for some reason, apps refuse to connect.
    Thanks, guys, for all your help thus far. I hope you'll stick around until we can see this to resolve, or verify that it's totalled...

    I've been thinking about reposting this thread with full details on the situation, but 'm not sure what to call this phenomenon. It's not a semi-brick, cause those at least shows signs of hope. It's not a full brick, but not just a crash...call it a "Crutch"? Well, name isn't important, let's crack this thing.

    EDIT: I'll admit it, I tried the BootMii restore, using as IOS. It warned me it was risky, and something about KONAMI. When I gave it the go, it said "try hard [enter samurai-like name here]...every time I hit go, too. This some kinda joke?
     
  13. Thomas83Lin

    Member Thomas83Lin Retro Gamer

    Joined:
    Jul 22, 2009
    Messages:
    1,485
    Country:
    United States
  14. Dter ic

    Member Dter ic ~

    Joined:
    Feb 19, 2009
    Messages:
    1,757
    Country:
    United Kingdom
    why hasn't anyone suggested him to use Modmii (on sticky) to fix the up-side down hbc [​IMG]
     
  15. tj_cool

    Supervisor tj_cool Stuff

    Joined:
    Jan 7, 2009
    Messages:
    9,942
    Location:
    This planet
    Country:
    Belgium
    All he has to do to fix upside down HBC is:
    - Install a clean IOS58
    - Re-install HBC with hackmii installer

    You don't really need ModMii for that (it would probably tell you the same anyway)
     
  16. Dr Awesomo
    OP

    Newcomer Dr Awesomo Advanced Member

    Joined:
    Jan 20, 2010
    Messages:
    60
    Country:
    Canada
    Hahah, I like the use of the word "all" in this context. The trials required to get it done have been difficult, and I know this because I've been following said ModMii guide, with the conditions discussed previously.

    It alone doesn't tell me how to re-initiate wiimote control, or SD mount support. However, with Mauifrog's suggestion, and a little messing around, everything is in order, now. Thanks to everyone for their help, this situation is resolved.

    I find it ironic, however, how this came abouts in an innocent attempt to install pre/priiloader.
    Does anyone know how to install either on a 4.3u?

    running either installer results in the following:

    preloader .30 - "failure to get root, aborting"
    priiloader .4 - IOS58 is not trucha signed, IOS58 is not patched with ES_Identify"
    priiloader .4 (loaded through cios) - "IOS249 is not patched with ES_DIVerify"

    Now, loading through cios let's m continue, but when all is said and done, priiloader can't load system hacks as a result of either a syntax error, or "expected EOF"

    Any tips?
     
  17. blahkamehameha

    Member blahkamehameha GBAtemp Regular

    Joined:
    Mar 31, 2010
    Messages:
    247
    Country:
    United States
    Had this problem before.

    Try reinstalling the HBC to fix it. Mine was upside down after an update, reinstalled it, then voila.
     
  18. Dter ic

    Member Dter ic ~

    Joined:
    Feb 19, 2009
    Messages:
    1,757
    Country:
    United Kingdom
    You need to hold B, then press +/A to install priiloader with cios.

    Or load priiloader via MMM's app loader with MMM loaded on a patched ios, then you can install with +/A.
     
  19. lulwut

    Member lulwut GBAtemp Fan

    Joined:
    Mar 19, 2010
    Messages:
    331
    Country:
    Japan
    yes, get a decent hacks.ini
     

Share This Page