Which game will I need for ninjhax 2.0?

Discussion in '3DS - Homebrew Development and Emulators' started by mashers, Jul 5, 2015.

  1. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Hi all,

    I'm excited to read the ninjhax 2.0 could be just around the corner. I'd like to get ready for the release so I'm wondering which game I will need in order to run the exploit. Will it run on CN/Zelda OOT like the previous ninjhax release? Or some other game?
     
  2. MeisterFenster

    MeisterFenster GBAtemp Regular

    Member
    167
    33
    Nov 18, 2014
    Gambia, The
    Cubic Ninja.
     
  3. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Thanks buddy. Will any version work? Any region etc?
     
  4. pakrett

    pakrett GBAtemp Maniac

    Member
    1,472
    559
    Apr 6, 2015
    France
    Any version & any region but the region have to match your console.
     
  5. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
  6. pakrett

    pakrett GBAtemp Maniac

    Member
    1,472
    559
    Apr 6, 2015
    France

    You can buy it, its the same game as mine and I have an Eur 3ds.

    [​IMG]

    You see : LNA-CTR-AQNP-EUR

    "AQNP" is the Cubic Ninja's code for EUR.
    "AQNE" for USA.
    "AQNJ" for JAP.
     
    Last edited by pakrett, Jul 5, 2015
    Hashtastrophe likes this.
  7. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Thanks buddy! I've ordered already but I really appreciate you confirming that it will work. It wasn't a bad price either. Cant wait for ninjhax now :)
     
  8. pakrett

    pakrett GBAtemp Maniac

    Member
    1,472
    559
    Apr 6, 2015
    France
    Sorry I misread your post ^^
    However it's a really good price !

    I remember... And totally understand ^^
     
  9. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    That's ok! And yeah I was surprised by the price too. Was quite lucky really as I expected the price to skyrocket since NH 2.0 is hopefully being released soon.
     
  10. pakrett

    pakrett GBAtemp Maniac

    Member
    1,472
    559
    Apr 6, 2015
    France
    I think I will spend many funny time with the 2.0 but 1.1b is already f***ing great !

    Smea (the autor of ninjahax) is motivated since someone offered him a new 3ds xl in 9.5, so I think it's coming soon !

    You are above 9.2 is that why you wait for the 2.0 ?
     
  11. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Oh if I knew Smea needed a new 3DS then I would have gladly donated to help buy him one. Are there any bounties I can donate to?

    Yeah both my N3DSs for me and my boyfriend came with 9.8. I've got an R4 for DS mode homebrew but I really want a native 3DS SNES emulator so I can't want for NH 2.0. The cost of CN is worth it just for that to me :)
     
  12. pakrett

    pakrett GBAtemp Maniac

    Member
    1,472
    559
    Apr 6, 2015
    France
    Haha yes you have to wait for 2.0 and hope...
    I think blargSNES will work on 2.0 with 9.2+ consoles because it's not based on a specific code that requiere a kernel exploit.
     
  13. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    That's what I'm holding out for ;) That forum post even shows SMW and DKC running, which would make me extremely happy!
     
  14. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,540
    5,482
    Mar 17, 2010
    Norway
    Alola
    blargSNES uses dynarec though, right? NINJHAX 2.0 might not support that. He did say it would have limited functionality, which could mean that anything beyond normal game access (like csnd and dynarec) won't be possible.
     
  15. pakrett

    pakrett GBAtemp Maniac

    Member
    1,472
    559
    Apr 6, 2015
    France
    Aie...
     
  16. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Presumably this is so the emulator can recompile [parts of] the SNES ROM on the fly? So, instead of doing this dynamically, could the ROM be patched in advance with the changes which would have been made in dynamic recompile so it will run without needing dynarec on the 3DS?
     
  17. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,540
    5,482
    Mar 17, 2010
    Norway
    Alola
    No, that isn't the problem. It's setting the memory to executable that's the problem. But I guess it's a moot point because NINJHAX will have to do that or overwrite an already executable portion of memory to actually be able to launch homebrew anyway, so dynarec should still be possible. csnd though is another matter.
     
  18. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Oh ok thanks for clarifying. So lack of csnd would mean no audio in the emulator, right?
     
  19. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,540
    5,482
    Mar 17, 2010
    Norway
    Alola
    Yeah. But it's hard to tell if that will be a limitation of it, it depends on what exploits smealum makes use of in 9.3+
    rohax was the one that got patched in 9.3. That's what allows the "hb" service to function, and lets NINJHAX freely map its own memory as executable. So the new version might be heavily limited on the maximum size of homebrew, since it will probably rely on overwriting already executable areas of code.
    But, smea could have found a new exploit that remedies that.
    It seems like it gets csnd access through the browser (on old 3DS, new 3DS browser uses dsp module instead and there's no way to use this from homebrew yet), this should still be doable as the needed exploit hasn't been patched, and most likely can't, as it seems to be a hardware flaw.
    So all in all it seems like NINJHAX 2.0 will have mostly the same capabilities, but being limited on the maximum size of homebrew because it lacks memory remapping. I guess this is what smea meant by it having limited functionality. I'm no expert though, that's just my best guess based on what I have read about how NINJHAX works.