where can i find latest linux cli wbfs manager

Discussion in 'Wii - Hacking' started by Bauldrick, Jul 6, 2009.

  1. Bauldrick
    OP

    Bauldrick GBAtemp Regular

    Member
    1
    Jan 22, 2009
    Is the one linked by fishears here > http://www.gbatemp.net/index.php?showtopic=147032 the one that has fix for that problem when deleting games? I want to compile it for a NAS with mipsel CPU, so can I get the source not static binary, if that one is not the one I need.

    Cheers
     
  2. Arm the Homeless

    Arm the Homeless Custom Title

    Member
    2
    May 26, 2008
    United States
    /home/andy/
  3. Bauldrick
    OP

    Bauldrick GBAtemp Regular

    Member
    1
    Jan 22, 2009
    Thankyou Arm, unfortunately I can only seem to get this to compile on my AMD64 box, which is no good to me. I think I'm missing a trick? I get the same error on ppc and mipsel running Debian:

    gcc -Wall -W -O3 -Ilibwbfs -I. -DLARGE_FILES -D_FILE_OFFSET_BITS=64 -c negentig.c -o negentig.o
    gcc -Wall -W -O3 -Ilibwbfs -I. -DLARGE_FILES -D_FILE_OFFSET_BITS=64 -c tools.c -o tools.o
    tools.c:8:25: error: openssl/md5.h: No such file or directory
    tools.c:9:25: error: openssl/aes.h: No such file or directory
    tools.c:10:25: error: openssl/sha.h: No such file or directory
    tools.c: In function ‘md5’:
    tools.c:69: warning: implicit declaration of function ‘MD5’
    tools.c: In function ‘sha’:
    tools.c:74: warning: implicit declaration of function ‘SHA1’
    tools.c: In function ‘aes_cbc_dec’:
    tools.c:104: error: ‘AES_KEY’ undeclared (first use in this function)
    tools.c:104: error: (Each undeclared identifier is reported only once
    tools.c:104: error: for each function it appears in.)
    tools.c:104: error: expected ‘;’ before ‘aes_key’
    tools.c:106: warning: implicit declaration of function ‘AES_set_decrypt_key’
    tools.c:106: error: ‘aes_key’ undeclared (first use in this function)
    tools.c:107: warning: implicit declaration of function ‘AES_cbc_encrypt’
    tools.c:107: error: ‘AES_DECRYPT’ undeclared (first use in this function)
    tools.c: In function ‘aes_cbc_enc’:
    tools.c:112: error: ‘AES_KEY’ undeclared (first use in this function)
    tools.c:112: error: expected ‘;’ before ‘aes_key’
    tools.c:114: warning: implicit declaration of function ‘AES_set_encrypt_key’
    tools.c:114: error: ‘aes_key’ undeclared (first use in this function)
    tools.c:115: error: ‘AES_ENCRYPT’ undeclared (first use in this function)
    tools.c: In function ‘do_yaz0’:
    tools.c:335: warning: unused parameter ‘in_size’
    make: *** [tools.o] Error 1

    Any pointers?
     
  4. kLiNiKaL

    kLiNiKaL Dr. Greenthumb

    Member
    1
    May 24, 2009
    Jamaica
    Los Ganjales
    try the new on called Withon, really easy to compile and install, even works on Openbox for me with very few libs.

    give it a try theres a thread in the 2nd page i think dude.
     
  5. Arm the Homeless

    Arm the Homeless Custom Title

    Member
    2
    May 26, 2008
    United States
    /home/andy/
    You need openssl.
     
  6. Bauldrick
    OP

    Bauldrick GBAtemp Regular

    Member
    1
    Jan 22, 2009
    I have openssl already!!

    #openssl version
    OpenSSL 0.9.8k 25 Mar 2009

    These Debian boxes are running Squeeze, the AMD64 box I compiled on is running Karmic (Kubuntu) and has a different version of openssl

    #openssl version
    OpenSSL 0.9.8g 19 Oct 2007

    The makefile says something about dodgy versions of openssl, maybe it's this?


    -edit-


    tools.c says that, not Makefile

    @kLiNiKaL this is a headless box, no X System running, and I think Wiithon depends on a whole lot of graphical stuff does it not? As good as it is.. I really like it
     
  7. makiolo

    makiolo Member

    Newcomer
    1
    Jul 2, 2009
    wiithon is cli and gui.

    Examples commands.

    wiithon -c ls

    Also can use wiithon_wrapper(use by gui):

    wiithon_wrapper -p /dev/sdxY formatear
    wiithon_wrapper -p /dev/sdxY ls
    wiithon_wrapper -p /dev/sdxY df
    wiithon_wrapper -p /dev/sdxY add fichero.iso
    wiithon_wrapper -p /dev/sdxY rm IDGAME
    wiithon_wrapper -p /dev/sdxY extract IDGAME
    wiithon_wrapper -p /dev/sdxY rename IDGAME NuevoNombre
    wiithon_wrapper -p /dev/sdxY rename_idgame IDGAME NUEVO_IDGAME

    For copy WBFS to WBFS direct:

    wiithon_wrapper -p /dev/sdxY clonar IDGAME /dev/destinoXY

    Wait it help!
     
  8. Bauldrick
    OP

    Bauldrick GBAtemp Regular

    Member
    1
    Jan 22, 2009
    I appreciate it, but I'm not sure I understand what you mean here?

    Basically, if I run sudo make install_auto_and_fix I get this error:

    http://pastebin.com/m43dc4606

    Which makes sense as I'm not on a i386 box

    If I just run sudo make install I get:

    http://pastebin.com/m493d1ce4

    Any help would be appreciated

    -edit-

    Oh, I changed Makefile t fetch unrar instead of rar as I can't seem t find it in repos, non-free aswell

    and my `o` doesn't wrk very well [​IMG]
     
  9. makiolo

    makiolo Member

    Newcomer
    1
    Jul 2, 2009
    Sorry my english ....

    "E: Package libc6-dev-i386 has no installation candidate"

    You need package "libc6-dev-i386" for compile 32bit applications in 64 bit plataform.
    I dont't know name of your distribution.


    If only want the binary, i upload precompiled:

    http://www.speedyshare.com/740590540.html

    Remind: chmod +x ...
     
  10. Bauldrick
    OP

    Bauldrick GBAtemp Regular

    Member
    1
    Jan 22, 2009
    No need t apoligize, thanks for the help.

    Thing is, these `computers` I'm trying to compile on have a completely different architecture (if that is correct term) a) has mipsel CPU b) has pwerpc CPU so I would not be able to install libc6-dev-i386 (libc6-dev is installed though)

    I'll try your binary, but I don't think it will work due to difference.

    -edit-

    Debian (testing) named Squeeze

    As I expect your binary gives:

    sudo /mnt/hda/share/wiithon*
    /mnt/hda/share/wiithon wrapper: /mnt/hda/share/wiithon wrapper: cannot execute binary file
     
  11. Bauldrick
    OP

    Bauldrick GBAtemp Regular

    Member
    1
    Jan 22, 2009
    I found that I needed libssl-dev to compile kwiirks wbfs.

    I doubt that anyne here would require them, but I've got static binaries for Linkstation1 (powerpc) and Linkstation2 (mipsel) if needed.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice