What's wrong with my wii?

Discussion in 'Wii - Hacking' started by Decatro, Apr 19, 2010.

Apr 19, 2010

What's wrong with my wii? by Decatro at 5:13 PM (2,041 Views / 0 Likes) 13 replies

  1. Decatro
    OP

    Newcomer Decatro Member

    Joined:
    Feb 26, 2010
    Messages:
    25
    Country:
    Sweden
    Well I was once a noob trying to get my wii to run games without really knowing what i was doing with the wii.
    This is the results of years of installing random crap on it but I hope you guys don't mind me asking what
    could be causing all these problems

    My Wii is a Pal (4.0e) with Wiikey (1.9s) installed.
    (I updated it to 4.0 via a safe updater from 3.2)

    My defaults are:

    * Installed Waninkoko's cios38_rev17

    * Installed Hermes 222/223 v5

    * Installed something along the lines with Starlite or something.

    * Installed an usb2 wad file to make my wii run usb 2.0 devices

    * Installed bootmii as boot2 via hackmii

    * Installed Dvdx via hackmii

    There are many problems:

    * I cannot run Usb Loader GX after installing ciosx_rev 19/18

    * Hermes 222/223 v4 causes usb loader GX crash. It boots up fine, but when it fails to find a driver it asks me to use cios 222 or 249, bot which causes it to crash.

    * With Hermes 222/223 v5 installed Usb Loader GX wont start. It stops after it mentions
    cios 222...-2 when starting the loader.

    * I tried to use Trucha Bug Restorer v1.11 but it fails when I try to install ios36.
    I followed This Guide

    * After installing hermes 222/223 v4/v5 configurable usb loader freezes when trying to
    load a game with 222/223. Right after mentioning it.

    * My wii crashes randomly when it starts a software. It's rare but it happens.

    * Uloader fails to initialize my usb drive (ret= -1204)
    -----------------------------------------------------------------------------------------

    I suspect that my ios36 is broken, but I have no idea what to do to fix it.
     
  2. linuxares

    Member linuxares GBAtemp Maniac

    Joined:
    Aug 5, 2007
    Messages:
    1,370
    Country:
    Sweden
    * Installed an usb2 wad file to make my wii run usb 2.0 devices
     
  3. Decatro
    OP

    Newcomer Decatro Member

    Joined:
    Feb 26, 2010
    Messages:
    25
    Country:
    Sweden
     
  4. atomant247

    Newcomer atomant247 Member

    Joined:
    Sep 12, 2009
    Messages:
    12
    Country:
    United Kingdom
    usb2 WAD is not needed, wii bottom usb port is 2.0 compatible anyway.
    Use WAD manager and uninstall this wad, aslo try Wiiflow instead of GX as it's more stable
     
  5. Decatro
    OP

    Newcomer Decatro Member

    Joined:
    Feb 26, 2010
    Messages:
    25
    Country:
    Sweden
    ah sorry, I misinformed you guys, it's its own installer. Not sure how I can uninstall that.
     
  6. PPSainity

    Member PPSainity Blinded by Science

    Joined:
    Jun 6, 2009
    Messages:
    646
    Country:
    Canada
    usb2 WAD is a cIOS made by Kwiirk and usually gets installed as IOS202. Kwiirk's version is used by those in the "pure" Homebrew scene as it does not allow for all the cool Pirate abilities that other cIOS's do while still enabling USB2.0 speeds for Homebrew apps.

    You can use Anytitle Deleter to delete the existing IOS202 to get rid of it, or just install Hermes cIOS202v4 over it. Hermes cIOS202 is much better and stable in my opinion.

    That said, I doubt that your problems are caused by using Kwiirk's cIOS202 (usb2 WAD), I would look at re-installing you other cIOSes, Hermes cIOS222/232v4 and Waninkoko's cIOS249v19. You may want to check what patches you made with StarFall or StartPatch as well.

    -[]D
     
  7. Decatro
    OP

    Newcomer Decatro Member

    Joined:
    Feb 26, 2010
    Messages:
    25
    Country:
    Sweden
    As I described in the first post will hermes v4 and cios249_v19 cause problems with my homebrews I mainly use. Which is why I made this thread.
    I tried, several times, to install Hermes and Waninkoko's cIOS's but it always ends up with crashing homebrews. I mainly use Usbloader gx, i tried configurable usb loader too, which always seem to freeze once I use hermes's cIOS's.

    But maybe you're right, I'm not sure i considered installing hermes cIOS 202 AFTER i installed waninkoko's ciosx v19, I'll try that right away.
    Maybe I'll just have to install things in a certain order?

    Oh, and I'm not sure how I know which ios i should uninstall with Anytitle deleter.
    Since every ios has it's own around 10 digit name?

    EDIT: Is Hermes v4 better than v5? What's the real difference?
     
  8. PPSainity

    Member PPSainity Blinded by Science

    Joined:
    Jun 6, 2009
    Messages:
    646
    Country:
    Canada
    Simply re-installing the cIOSes will overwrite anything that was written in the cIOSes' spot before. Think of each as a numbered parking lot that can only take one car at a time, 202, 222, 223, 249, etc. As for using Any Title Deleter to delete a cIOS, just go to the IOS section and delete the corresponding "car space", IOS202 for cIOS202, IOS249 and IOS250 for cIOS249 (Waninkoko's cIOS is tricky it that in stores a copy of itself as IOS250 as well as installing as IOS249, you'll learn these things the more you read). Just don't mess with any IOS below 200 for now as they should be considered "Critical System Files" and off limits.

    If you are still experiencing problems with running Homebrew and loading backups at least now you can safely exclude the cIOSes as the root of the cause and start troubleshooting elsewhere.

    -[]D
     
  9. Decatro
    OP

    Newcomer Decatro Member

    Joined:
    Feb 26, 2010
    Messages:
    25
    Country:
    Sweden
    Oh i'm afraid i've done that many...MANY times before. Using different combinations and try to get things running remotely stable.
    You see, as fast as I install hermes v4 and cIOSx_rev19/18 ((Rev 17 is installed by default)) my Wii messes up and just REFUSES to recognize my USB drive. Usb loader GX loads up telling me that it cannot find an usb device and let's me choose between 249 and 222. Both options freezes and crashes my wii with quite an annoying high pitched sound.

    I'm trying to get Monster hunter 3 to run you see, and when i use 222/223 as a base boot up with usb loader GX it refuses to start. It gets to Hermes cIOS 222/223 and freezes.
    Configurable usb loader boots up, but when i try to run the game with 222 or 223 the loader freezes with my wii's front light constantly on until i shut it off or shut off my usb drive.
    My usb drive is formatted to WBFS and has only one partitions which is the wbfs one, don't see how this can cause any problems.
    I also tried removing all stubs, and installed trucha signed/bugged IOS's that were available. I upgraded to 4.1E without any signs of difference.
    The ONLY time it seem to work is when i use uLoader 5.0 to run a game via a disc. It can't even find any usb drives at all with either hermes v4 or v5.

    I tried starting from scratch with the complete softmod guide and reinstalled all ios's like you do with a fresh virgin 4.2 Wii (deleting the 222/223/224 ) stubs, and 4.1 or below. Both methods showed no differences at all. Still freezes when i try to load hermes v4 or v5.
    I might add that i always fail to install a custom theme with all installers too, if that has anything to do wit this.
    The only thing that seems to work normally is the waninkoko's ciosx_rev17.

    EDIT: None of the installers fails to install, the only time something failed was when it was trying to reinstall ios36 with trucha bug with the Trucha Bug restorer from wiibrew.

    Thanks for the reply guys, I really do appreciate it! Here are some reports of my current settings on my Wii

     
  10. PPSainity

    Member PPSainity Blinded by Science

    Joined:
    Jun 6, 2009
    Messages:
    646
    Country:
    Canada
    From the what DOP-Mii reports, your IOS36 seems to be installed with the TruchaBug, and you have cIOS rev17 and some version of Hermes' cIOSes. A few points to mention are:
    1) Don't be messing with extra options like custom themes at this point, keep each step simple until everything works again.
    2) If all the cIOSes installed without fail, they are probably not the cause of your problems, time to look elsewhere.

    Now moving on a few questions to ask:
    1) Are any non-USB accessing homebrew having trouble working now? Can they still access your SD card?
    2) Is your SD card formatted correctly? Any known compatibility issues? Some cards have issues running in the Wii and can cause headaches like this.
    3) Is you HDD drive formatted correctly? Any known compatibility issues? Can it still be recognized by a WBFS utility?
    4) Do you have a NAND backup of your Wii where everything was working? It might just be worthwhile to restore off of it and just start over from there on.
    *) If you don't have a NAND backup, make one with BootMii now, always backup before attempting anything with the Wii.

    I can't think of anything else that might help, but I hope this gives you something to go on...

    -[]D
     
  11. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    make sure u remove all GC memory cards or controller when hacking the wii unless otherwise instructed

    u can't go wrong if u start at the beginning of the simplistic mod, or the complete softmod guide, or nus auto downloader custom generated guide
     
  12. Decatro
    OP

    Newcomer Decatro Member

    Joined:
    Feb 26, 2010
    Messages:
    25
    Country:
    Sweden
    Of course. I make sure to do exactly what the guide tells me to do, "Word by Word".
    Apparently it must be something else going on with my Wii, I've re-used the guide countless of times now.

    I know there is a way to -completely- reset your Wii, maybe I should go for that?
    And Wiikey v1 can't cause problems like this can it?

    Thanks for the reply XFlak [​IMG]

    EDIT:

    Alright! I got it running guys......somewhat at least!

    I switched HDD and SD card and reinstalled the Cios's without having any usb's connected to the wii (which i forgot to do the last gazillion times installing hermes and waninkoko). I installed waninkoko's ciosx rev19 and hermes v4. My sd card seem to have problems with this card though, i better buy a new one and use that instead of my old 2gb micro sd kingstone card. I tried using a 2gb scandisk micro sd card and it gave me the same resaults as I've had until now.

    SO! Now Configurable usb loader runs the games with hermes cios v4 HOWEVER the sd card is so messed up that i can't save any config's from cfg-usb-loader.

    Usb loader GX loads up fine with cios 222 as a default now, but still messes up when i try to launch a game with cios 222/223. It crashes and reboots the Wii.

    I also tried using the other usb drive which simply failed to work, so it has been both the drive and SD card causing this mess.

    I also can't use 249 or 250 to install wads anymore due to the rev19 update. But i'll just use 202 for that [​IMG]

    Is there any brands you recommend when it comes to SD cards? As long it's not SDHC that is. I still think Kingstone and Scandisk are good brands, but if there is a certain type that works the best for the Wii i'll try to find one.

    Cheers, and thanks for all your reply's!
     
  13. PPSainity

    Member PPSainity Blinded by Science

    Joined:
    Jun 6, 2009
    Messages:
    646
    Country:
    Canada
    Good to hear that things are improving.

    Concerning USB Loader GX not launching games, keep USB Loader GX boot option to cIOS222 but try setting each game to use cIOS249 and see if that works. Keep in mind that USB Loader GX versions higher than r921.dol have a known problem with cIOSx249 rev19 when loading the game disc sounds.

    Waninkoko introduced the option to choose the IOS base used in cIOSx249 rev19. As a result, if you choose IOS57 as base you get faster USB speeds but can't install WADs, while if you choose IOS38 as base you get the same old features as before including still being able to install WADs *(My bad I see that I wrote that backwards above, sorry).

    As for what SD cards and what HD's work, I personally use a Sandisk 2GB SD card, and a 1TB WD My Book Essential Edition. There are lists of compatible SD Cards and USB Drives available, but I don't know how up-to-date they are. Stick with a quality brand with no frills and you should be good to go.

    -[]D
     
  14. Decatro
    OP

    Newcomer Decatro Member

    Joined:
    Feb 26, 2010
    Messages:
    25
    Country:
    Sweden
    Ah, well then that does makes sense, I installed the latest alpha I believe, and that goes the same for config usb loader. Does config usb loader also use waninkoko's 249/250 to install new updates and so on? I was able to update config usb loader just fine, but it refuses to save settings to the sd card ( SD card is not accessible ) but that is probably due to my old sucky 256mb card.Which i've now replaced with a kingston 1gb SD card which works just fine, but the usb loader gx problem still remains, but i'll use configurable usb loader from now on anyway

    I'm pretty happy with the loading speeds through usb anyway, is it a very noticeable change in the loading speeds if i stick with the IOS57 + ciosx_rev19 installment? Otherwise i'd stick with the ol IOS38 + ciosx_rev19 combo.

    Something odd happened when I was trying out Monster hunter 3. I've only gotten it to run with hermes cios 223 before but now it runs only on cios 222, and that goes for the two last cards i used. No idea why. Usb Loader GX even works now! I'm stunned!
    It must be due to my new SD card? Maybe it is, i haven't tried using the old 256mb card yet but it probably is!

    My HDD seem to work just find though, or rather the IDE to USB adapter since i bought a hdd cabinet to save money. So i'll just stick to that and use good HDD brands, thanks for the recommendations though! I really appreciate it [​IMG]
     

Share This Page