What 3DS games requires what system Update..?

Discussion in '3DS - Games & Content' started by Metoroid0, Apr 28, 2013.

  1. Metoroid0
    OP

    Metoroid0 GBAtemp Maniac

    Member
    1,491
    223
    Nov 2, 2012
    Japan
    SR388
    What [​IMG] games requires what system Update so you can play them?
    [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG]
    (List is below the "How to preform System Update manualy" picture...
    i know it's small, but i'm researching myself, so there will be list updates...)
    (If you would like to update the list, just post down below and i will edit it)​
    There are games that don't require you to​
    update your 3DS System so you can play them.​
    I mean if you for example have System Update v4.1.0-8 on your 3DS you don't need to​
    update your console if you don't like to, just so you can play,​
    let's say "New Super Mario Bros 2" That requires System Update v4.1 and below (naturally)​
    You CAN update, but you don't need to if you don't like to.​
    It's not necessary though...​
    How to manually preform System Update:​
    [​IMG]
    A video explaining & showing you How to manually preform a System Update:
    Here's the Pong's list of what minimum system update
    is required so you can play your 3DS games. Just scroll to the far right.
    There is also all sort of informations about 3DS roms there.
    Thanks Pong :)
     
  2. Tokopimv

    Tokopimv Advanced Member

    Newcomer
    64
    10
    Jun 1, 2012
    Netherlands
    i believe all games that need updates just pick the newest one. though, i've never had to update my 3ds because of a game.
     
  3. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    No, 3DS games have whatever update they need inside the cart itself, so it's specific per-game.
     
  4. Metoroid0
    OP

    Metoroid0 GBAtemp Maniac

    Member
    1,491
    223
    Nov 2, 2012
    Japan
    SR388
    So what games have what specific update, and can not work on update lower than that?
     
  5. Nathan Drake

    Nathan Drake Obligations fulfilled, now I depart.

    Member
    6,192
    2,151
    Jan 2, 2011
    Just figure that a new game will hold the latest firmware in order to operate. If you pick up a game that was just released a couple weeks ago, for example, it will probably have the latest firmware update with it, whereas if you pick up, say, LoZ: OoT, it will only have a very old update if any on the cart.
     
  6. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,932
    Sep 8, 2009
    One's inner self
    New Super Mario Bros 2: 4.1
    Paper Mario: 4.3 (USA), 4.4 (Eur)
    Luigi's Mansion 2: 4.5

    the update files are stored in the game carts so people can get updates even if they have no wifi
     
    Metoroid0 likes this.
  7. Metoroid0
    OP

    Metoroid0 GBAtemp Maniac

    Member
    1,491
    223
    Nov 2, 2012
    Japan
    SR388
    That's good to know in case you don't want to update 3DS
     
  8. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,932
    Sep 8, 2009
    One's inner self
    if you try to boot the game it will just ask "an update needs to be applied to this console to run this game, do you wish to update" A Yes B No
    if you say no it just goes back to the home menu
     
  9. Metoroid0
    OP

    Metoroid0 GBAtemp Maniac

    Member
    1,491
    223
    Nov 2, 2012
    Japan
    SR388
    That's the thing..if you have older updates installed on your 3DS and want to play games that Requires Newer update, You just cant play it.

    I remember on Wii where game also Requires an update so you can play it, but when your Wii is soft-modded and you go to turn off that pop-up screen where it asks you to update or you shall not play, the games that "require" that update can be played just fine under older system update.

    Does that that mean that you don't NEED an update so you can simply play, you need it for some other things (but those things didn't affect my game-play experience on Wii as i remember)
     
  10. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,932
    Sep 8, 2009
    One's inner self
    well there no LEGAL reson why you shouldnt update
    also if you fall to many updates behind Spotpass stops working

    you do indeed NEED the updates to play due to the fact they add New feature forgames
    New Mario Bros 2 (4.1 introduced game integration to the shop)
    Paper mario (the 4.3/4.4 a Large E-shop change was introduced)
    Luigis Mansion 2 you need the update (4.5 introduced download & Store Play, so you dont have to have a constant connection to the host)

    the updates listed where LARGE update, so people with slow internet would have been waiting hours for them to download
     
    Skelletonike likes this.
  11. bmprsvz777

    bmprsvz777 Newbie

    Newcomer
    1
    0
    Sep 29, 2013
    Australia
    New Super Mario Bros. 2 ................. System Update v4.1.0-8
    Paper Mario: Sticker Star ................ System Update v4.4.0-10
    Luigi's Mansion 2/Dark Moon .......... System Update nv4.5.0-10
    Mario and Luigi - partners in time..... System Update v5.1.0-10
     
  12. Nusdogg

    Nusdogg GBAtemp Fan

    Member
    369
    45
    Feb 3, 2013
    United States
    St. Paul, MN
    Damn, that sucks. So an update is a must for newer games. Nintendo is getting smarter about this if you really want to play their games.
     
  13. Metoroid0
    OP

    Metoroid0 GBAtemp Maniac

    Member
    1,491
    223
    Nov 2, 2012
    Japan
    SR388
    It would be good if only Nintendo is the case :P :/
     
  14. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,932
    Sep 8, 2009
    One's inner self
    Metoroid0 likes this.
  15. Metoroid0
    OP

    Metoroid0 GBAtemp Maniac

    Member
    1,491
    223
    Nov 2, 2012
    Japan
    SR388
    Wow Cool! :D