[Weird Thing] Downgrading EmuNAND on N3DS help

Discussion in '3DS - Flashcards & Custom Firmwares' started by cai_miao, Jun 12, 2017.

  1. cai_miao
    OP

    cai_miao Member

    Newcomer
    12
    2
    Jun 6, 2017
    Switzerland
    I know it's a weird question for the b9s/sighax scene... But I'm just little freaky and wanted to do something crazy.

    I'm on a b9s 1.2/Luma 8.0 Japanese N3DS console and attempt downgrading my 9.2.0-20J EmuNAND to 4.4.0-10J (yes, back to o3ds generation),
    using that sysUpdater by profi200 with a update package downloaded by 3DNUS (missing mset and spider from Internet),
    and showing
    20170612151915.jpg

    I don't really know what's up with Homemenu title,
    but I guess it's protected by CFWs (most CFWs include forced FIRM protection for noobs),
    I tried CakesFW (as FIRM protection can turn off) but it have problem with b9s and keep giving me "failed to decrypt cetk" error and can't do anything.

    Really headache. If anyone can provide information of downgrading, I would greatly appreciate.
     
  2. I_AM_L_FORCE

    I_AM_L_FORCE Unban me from Discord

    Member
    879
    268
    Feb 19, 2015
    London
    A better way would be to do a 2.1 ctrtransfer to said emunand and then cart upgrade to 4.5. I am curious though, why?
     
  3. cai_miao
    OP

    cai_miao Member

    Newcomer
    12
    2
    Jun 6, 2017
    Switzerland
    I can't find a proper 2.1 ctrtransfer package, and most important thing is: most CFW don't support NAND lower than 3.x.
    I want to do this since KTR consoles lack of CHN Region package, and I'm just want to region change one to make my little dream come true.
     
  4. I_AM_L_FORCE

    I_AM_L_FORCE Unban me from Discord

    Member
    879
    268
    Feb 19, 2015
    London
    Ah, very true. Still, it could mess up your MCU and leave you bricked couldn't it?
     
  5. cai_miao
    OP

    cai_miao Member

    Newcomer
    12
    2
    Jun 6, 2017
    Switzerland
    It seems safe still but I'm not really know.
     
  6. I_AM_L_FORCE

    I_AM_L_FORCE Unban me from Discord

    Member
    879
    268
    Feb 19, 2015
    London
    Well one way you could do it which is a REALLY old way would be to downgrade the emunand to 4.5 using sysupdater, then using the OTPhelper arm9 payload to "fix" the NAND
     
  7. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,445
    4,762
    Mar 17, 2010
    Norway
    Alola
    Just installing older titles alone won't be enough to boot an o3DS firmware, you also need to change the encryption and header of the NAND so that the 3DS treats it as an o3DS NAND, that can be done with OTPHelper like the person above me mentioned.
    However, I'm not sure if CFW will support booting an o3DS emuNAND on a n3DS, I see no reason why it wouldn't, but at the same time it's not something people ever do and so it's largely untested and may not work.
     
    Quantumcat and wsquan171 like this.
  8. GizmoTheGreen

    GizmoTheGreen GBAtemp Fan

    Member
    388
    106
    Oct 8, 2009
    why do you need to downgrade to 4.5 to regionchange you n3ds though?
     
  9. wsquan171

    wsquan171 GBAtemp Regular

    Member
    GBAtemp Patron
    wsquan171 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    275
    79
    Feb 14, 2015
    China
    Simply downgrading with o3ds system titles won't work, as mentioned by The Real Jdbye. The easiest way I can think of is to simply do a 9.2 ctrnand transfer (o3ds image) then downgrade from there. 9.2 images are easier to find. magnets are available here: https://3ds.guide/region-changing

    As a side note, OTP helper does not have B9S support. You probably need to access it via hb channel on 9.2 emunand, or convert to .firm payload yourself.
    OTP helper's page is here: https://gbatemp.net/threads/release-otphelper-otp-dumping-downgrade-helper.416996/

    Good luck!
     
    Last edited by wsquan171, Jun 13, 2017
  10. I_AM_L_FORCE

    I_AM_L_FORCE Unban me from Discord

    Member
    879
    268
    Feb 19, 2015
    London
    That would fail due to 7.x crypto.
     
    wsquan171 likes this.