Vwii Wiiware/VC

Discussion in 'Wii U - Hacking & Backup Loaders' started by rposlp, Oct 4, 2014.

  1. rposlp
    OP

    rposlp Member

    Newcomer
    25
    3
    Oct 4, 2014
    Hello, im currently using usb loader gx on my wii u, but i cant play wiiware throught emunand, when i try to load a wiiware or vc game installed on the emunand via usb loader or showmiiwads it puts me back to the wii menu. Do i need a specific IOS for wiiware and vc? I currently have installed IOS 236, 249, 250 and 251. Thanks
     


  2. SickPuppy

    SickPuppy New Member

    Member
    1,789
    451
    Jul 29, 2009
    United States
    Try a patched IOS80, do not install that to the real nand, only install it to the emunand. Make sure you have a backup emunand in case it don't work.
     
  3. rposlp
    OP

    rposlp Member

    Newcomer
    25
    3
    Oct 4, 2014
    Thanks for answering. i just created a emunand to play wiiware/vc so if it does not work its ok, but i dont know how to install an ios to the emunand, i only have showmiiwads and installed some wads through it, can i install IOS80 through showmiiwads?
     
  4. SickPuppy

    SickPuppy New Member

    Member
    1,789
    451
    Jul 29, 2009
    United States

    I can't remember how to do that anymore it been a few years since I messed with that stuff.
     
  5. endoverend

    endoverend AKA zooksman

    pip Contributor
    GBAtemp Patron
    endoverend is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,846
    3,550
    Jun 6, 2013
    United States
  6. rposlp
    OP

    rposlp Member

    Newcomer
    25
    3
    Oct 4, 2014
    Thanks for your answers folks but im not going to mess with IOSes risking a brick my vwii :) i thought it was supposed to work thats why i asked, i already have wii and gamecube games loading from usb throught usb loader gx im fine hehe and working like a charm, the wiiware was just the cherry on top of the cake. thank you
     
  7. endoverend

    endoverend AKA zooksman

    pip Contributor
    GBAtemp Patron
    endoverend is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,846
    3,550
    Jun 6, 2013
    United States
    Whoa whoa whoa. Don't let the warning label scare you. It's not gonna brick your vWii. It's just a disclaimer.
     
  8. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,274
    8,748
    Oct 27, 2002
    France
    Engine room, learning
    it's a disclaimer that tells that patching the IOS80 is a possibility that it goes wrong, and you really brick your vWii as it's the IOS used by the System menu. If it's not patched correctly the System menu will not boot anymore.

    For RealNAND:
    The fact that your WiiWare/VC are not working has nothing to do with IOS80.
    USBLoaderGX is using the cIOS set in your loader's setting to load channels. I tried launching official channels on vWii from USBGX and it's working fine.

    Which are the games you are trying to play?
    Is it the same region than your console, or a different region?
    Are the games located on the NAND or on the SD ?

    Channels located on SD can't be launched from USBLoaderGX.



    For EmuNAND :
    The Wii channels you launch from the Wii-created EmuNAND doesn't use vWii IOS80 either!
    You don't need vWii IOS80 patched for emuNAND.

    I'm using a NAND created on/for Wii, not one from vWii.
    I don't know if it matters, but when launching Wiiware/VC, it actually uses the cIOS located on RealNAND (249 for example), and the system files located on EmuNAND (the one created for Wii .. and the channels are expecting the Wii files anyway, so it should work fine. No other IOS from vWii are accessed).



    Patching IOS80:
    Patching the system menu IOS is used to launch fakesigned (pirated) channels installed using Wad files, and then transfered into the SD menu.
    If you launch the channels from System menu (not transfered to SD menu), you shouldn't even need to patch IOS80.
    I didn't test it myself, but I think that's what the patch is used for.


    Solution (maybe?)
    If you have a Wii, dump your NAND from it using USBLoaderGX NAND dumping feature.
    Then use this EmuNAND on vWii.


    You can also create a vWii Sneek if you want. There's a tutorial on this forum.
     
    rposlp and endoverend like this.
  9. rposlp
    OP

    rposlp Member

    Newcomer
    25
    3
    Oct 4, 2014
    Thanks Cyan. I have a wii too, and i tried dump the wii nand with usb loader gx and it worked on wii the wiiware games launch fine through emunand, but when tried on vwii with the wii emunand dump it continues to send me to the wii menu when i try to launch a wiiware game. I dont wanna mess around too much with IOSes, just thought there was a simple way to solve this.. thank you
     
  10. endoverend

    endoverend AKA zooksman

    pip Contributor
    GBAtemp Patron
    endoverend is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,846
    3,550
    Jun 6, 2013
    United States
    Make sure you have the right cIOSes installed... ModMii can help with that.
     
  11. rposlp
    OP

    rposlp Member

    Newcomer
    25
    3
    Oct 4, 2014
    what are the IOSes needed for VC/Wiiware? I have 236, 249, 250, 251
     
  12. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,274
    8,748
    Oct 27, 2002
    France
    Engine room, learning
    on vWii there's not a lot of choices.
    having slots doesn't mean a lot. in a slot you can install what you want, so telling you have 249 doesn't provide information of WHAT you really installed in the slot 249.
    What's important is the actual content inside the slot, not if your slot is used or free.


    What you need :
    d2x cIOS rev10 or rev10-alt
    base 56 : most games are working with a base56
    base 57 : few games not working with base 56 require base 57
    base 58 : few games require base 58 (mainly USB/Music games)

    You can install any other base (38, etc.) suggested by the d2x installer.
    So, I suppose you followed tutorials and installed what has been told to you, so you probably have these 3 bases (56/57/58).
    But if you installed v10-alt, then know that it's less compatible with EmuNAND than v10 normal.

    v10-alt adds support for dual USB Port in detriment to EmuNAND compatibility.
    don't follow guides telling you to install latest versions of everything, knowing what's the difference and choose what you really need.

    If it still doesn't work with v10 (normal, beta52), then I don't know why it doesn't work for you.


    Also, you don't need to install all the three slots!
    you can install only one cIOS with base 56, that's all. If you don't play games which require an IOS 57 or 58, don't install cIOS base57 or base58. only install the one you need. if you have v10-alt in 249/250/251, then you can try to install v10 in slot 249 only, no need to replace the other two slots with v10. Games and homebrew only use one IOS at a time. Having multiple versions has no real purpose if you don't need it.
     
    rposlp likes this.
  13. rposlp
    OP

    rposlp Member

    Newcomer
    25
    3
    Oct 4, 2014
    That must be the problem, i installed cIOS v10 beta53-alt-vwii on 249/250/251 and then IOS236 Installer MOD v8 Special vWii Edition. what do i need to do now?
     
  14. EmceeKerser

    EmceeKerser GBAtemp Maniac

    Member
    1,374
    503
    Jun 3, 2014
    The fuckin' Blue Mountains brah
  15. rposlp
    OP

    rposlp Member

    Newcomer
    25
    3
    Oct 4, 2014
    I have not made a nand backup yet, should i do it now? Even after i have installed the IOSes? So i think i need to install cIOS v10 beta53 on slot 56 right?(the non alt version) the keys thing should i make those too? and with ios236 do i need it? i have installed it because i read it gives permissions to certain things and i thought i needed it cause ahbprot was disabled in YAWMM. thanks
     
  16. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,274
    8,748
    Oct 27, 2002
    France
    Engine room, learning
    You already have beta53 (v10-alt)
    You need beta52 (v10)

    You don't need IOS236. (homebrew on vWii don't use it anymore)
    You don't need to do a NAND dump, but it's recommended. Though it can be a very long process depending on your SD card, so do it later.

    Run the d2x cIOS installer, and select :
    v10 Beta 52
    slot 249
    base 56
    version 21010

    install it. Done.
     
    rposlp likes this.
  17. rposlp
    OP

    rposlp Member

    Newcomer
    25
    3
    Oct 4, 2014
    ....i did what you said and now it is stuck installing the IOS...what do i do know??? im gonna brick?? it says: downloading and patchiung contents (15) getting 00000006 file... and its stuck for 10 minutes......
     
  18. rposlp
    OP

    rposlp Member

    Newcomer
    25
    3
    Oct 4, 2014
    still stuck...will i have to pull the plug? any risk of brick? why this hapenned???
     
  19. rposlp
    OP

    rposlp Member

    Newcomer
    25
    3
    Oct 4, 2014
    pulled the plug seems ok, its possible that it happened because i was running dx2 cios intaller throught homebrew channel 16:9?
     
  20. rposlp
    OP

    rposlp Member

    Newcomer
    25
    3
    Oct 4, 2014
    ok, installed again cios v10 beta 52 and its ok now, wiiware/vc is working now(from emunand)! i think i was installing the wii cios and not the vwii one, thats why it stucked. thanks a lot Cyan!