Hacking [vWii] USB Loader GX black screen when loading Wii games

Bgeo25

Member
OP
Newcomer
Joined
Oct 9, 2016
Messages
11
Trophies
0
XP
40
Country
United States
I've seen this issue in multiple threads, but not for vWii.

As indicated by the title, I'm getting a black screen when attempting to load a Wii game from USB Loader GX running from vWii Homebrew Channel.

SysCheck output:

SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
...runs on vIOS58 (rev 6432).

Region: NTSC-U
System Menu 4.3U (v609)

Drive date: 07.12.2012
Homebrew Channel 1.1.2 running on IOS58

Hollywood v0x21
Console ID: 618316285
Console Type: vWii
Shop Channel Country: United States (49)
Boot2 v0
Found 77 titles.
Found 35 IOS on this console. 0 of them are stubs.

vIOS9 (rev 1290): No Patches
vIOS12 (rev 782): No Patches
vIOS13 (rev 1288): No Patches
vIOS14 (rev 1288): No Patches
vIOS15 (rev 1288): No Patches
vIOS17 (rev 1288): No Patches
vIOS21 (rev 1295): No Patches
vIOS22 (rev 1550): No Patches
vIOS28 (rev 2063): No Patches
vIOS31 (rev 3864): No Patches
vIOS33 (rev 3864): No Patches
vIOS34 (rev 3864): No Patches
vIOS35 (rev 3864): No Patches
vIOS36 (rev 3864): No Patches
vIOS37 (rev 5919): No Patches
vIOS38 (rev 4380): No Patches
vIOS41 (rev 3863): No Patches
vIOS43 (rev 3863): No Patches
vIOS45 (rev 3863): No Patches
vIOS46 (rev 3863): No Patches
vIOS48 (rev 4380): No Patches
vIOS53 (rev 5919): No Patches
vIOS55 (rev 5919): No Patches
vIOS56 (rev 5918): No Patches
vIOS57 (rev 6175): No Patches
vIOS58 (rev 6432): USB 2.0
vIOS59 (rev 9249): No Patches
vIOS62 (rev 6942): No Patches
vIOS80 (rev 7200): No Patches
vIOS236 (rev 65535): Trucha Bug, ES Identify, NAND Access
vIOS249[56] (rev 21010, Info: d2x-v10beta52-vWii): Trucha Bug, NAND Access
vIOS250[57] (rev 21010, Info: d2x-v10beta52-vWii): Trucha Bug, NAND Access
vIOS251[58] (rev 21010, Info: d2x-v10beta52-vWii): Trucha Bug, NAND Access
vIOS512 (rev 7): No Patches
vIOS513 (rev 1): No Patches
Report generated on 08/07/2021.

USB Loader GX config:
- USB Loader v3.0 r1272
- Loader IOS: 58
- Game IOS: 249
- NAND emulation: OFF

The cIOS slots 249,250,251 previously had d2x-v10beta53-alt-vWii installed, but I recently overwrote them with d2x-v10-beta52-vWii in an effort to fix this problem.

I read some sources indicate that "d2x v8 final" should be installed in slot 249 w/ base 57, but I would like to get some feedback/confirmation before I try it.

Thanks for the help!
 
  • Like
Reactions: jeffyTheHomebrewer

mive

Well-Known Member
Member
Joined
Jul 19, 2018
Messages
217
Trophies
0
Age
38
XP
483
Country
Germany
d2x-v10-beta52-vWii is the correct one. afaik there's no v8 for vWii (dont install d2x wii stuff on vwii)

try this
- switch to the usb loader gx version from blackbox (see usbloader gx thread)
- try Loader IOS 249
- try 57 in 249 (or change to IOS 250). This is unlikely the issue, as most wii games should work with both (56 or 57)
 
  • Like
Reactions: jeffyTheHomebrewer

godreborn

Well-Known Member
Member
Joined
Oct 10, 2009
Messages
20,933
Trophies
1
XP
12,925
Country
United States
use a powered hdd. flash drives don't work well with the wii u.

--------------------- MERGED ---------------------------

btw, your syscheck looks fine, so I think that's the problem.
 

Bgeo25

Member
OP
Newcomer
Joined
Oct 9, 2016
Messages
11
Trophies
0
XP
40
Country
United States
d2x-v10-beta52-vWii is the correct one. afaik there's no v8 for vWii (dont install d2x wii stuff on vwii)

try this
- switch to the usb loader gx version from blackbox (see usbloader gx thread)
- try Loader IOS 249
- try 57 in 249 (or change to IOS 250). This is unlikely the issue, as most wii games should work with both (56 or 57)

The version by blackb0x doesn't load from my flash drive (says "Waiting for HDD..." at startup unlike the non-modded), so the game also doesn't show up.

I might need to try other flash drives or use a HDD.
 

godreborn

Well-Known Member
Member
Joined
Oct 10, 2009
Messages
20,933
Trophies
1
XP
12,925
Country
United States
I haven't used any updates by blackb0x. I'm still using 3.0 1271 revision. everything works that I've tried: emunand, neek2o games, wii and gc games, saves, etc, so I've had no need to update. same with nintendont, I haven't updated that in a while. and the reason I'm using 1271 instead of 1272 is that it loads my usb drive faster apparently.

--------------------- MERGED ---------------------------

I should say: everything I need works. there may be others who have issues with certain things that I don't need or haven't encountered.
 

Bgeo25

Member
OP
Newcomer
Joined
Oct 9, 2016
Messages
11
Trophies
0
XP
40
Country
United States
I tried this again using one of my 2.5" HDDs and it worked! Wii games load without problems. One thing to note is that I *had* to use the back/top USB port of the Wii U.
 
  • Like
Reactions: godreborn

godreborn

Well-Known Member
Member
Joined
Oct 10, 2009
Messages
20,933
Trophies
1
XP
12,925
Country
United States
that is normal. I think you can use either with beta53, but beta52 iirc is better, especially if you want to play emunand type games. you have to use a special FAT library that I think is only available with beta52 in order to play emunand with ustealth, otherwise black screen iirc or it might've kicked me out of the game (can't remember).
 

godreborn

Well-Known Member
Member
Joined
Oct 10, 2009
Messages
20,933
Trophies
1
XP
12,925
Country
United States
and by either, I mean the usb ports. I think it's determined by the cios version: beta52 - only one usb port can be used, but it allows for emunand; beta53 - either port can be used (I think), but it's not meant to be used for emunand. emunand would be like if you wanted to inject wads into a nand without risk and I think the size is unlimited afaik or at least big enough to accommodate most games. the vwii nand is only 528MB, but my emunand is over 9GBs. I think you can put stuff on an sd card as well if you patch ios80, which I've never done. it's pointless if you use emunand imo. if you want to use emunand with ustealth, head over to the ustealth thread. a link to the new FAT library is in the op. just overwrite the original FAT library, then reinstall beta52 cios.
 

blackb0x

Well-Known Member
Member
Joined
Apr 22, 2019
Messages
391
Trophies
0
XP
1,505
Country
United Kingdom
The version by blackb0x doesn't load from my flash drive (says "Waiting for HDD..." at startup unlike the non-modded), so the game also doesn't show up.
When this happens you can open the meta.xml file in notepad and change the boot IOS to one that might be compatible with your drive (e.g. 249, 250). Although it might not fix everything, since there's an underlying compatiblity issue with your flash drive.

the reason I'm using 1271 instead of 1272 is that it loads my usb drive faster apparently
Have you actually timed it or are you basing it off of the messages that you see on your screen? Since my version has the faster boot sequence but I've removed, changed and added some text that might make you think that it's doing more than it is.

If your drive is actually slower with IOS58 then it should only be around 1-3 seconds slower, since a cIOS reload happens as soon as your config file is read. But if you're that put off by 1-3 seconds then you can modify the meta.xml file so that the loader immediately reloads to a cIOS instead.
 
Last edited by blackb0x,
General chit-chat
Help Users
    TheNintendoEnthusiast tempBOT: TheNintendoEnthusiast has left the room.