Hardware Vita won't turn on PS button is blue Already swapped battery,no luck

jaxteller

Member
OP
Newcomer
Joined
Apr 10, 2021
Messages
5
Trophies
0
Age
32
XP
34
Country
Netherlands
Charged the battery fully, during charge it was just solid orange When pressing the power button (to turn it on), the PS button turns solid blue, but no sound or no screen, when pressing it again as if you would power it off, it blinks blue like 4 times blue and goes off.

Already tried holding power button for 30 seconds, and it still stays black. Also tried R button plus ps button plus power button, nothing shows up. There is also no audio. Got this vita second hand, and was probably not used for a while. Hooking it up to a PC, it recognizes the vita.

Swapped the battery with one from another vita that works fine Still same issue. At this point. What could be the issue?
 
Last edited by jaxteller,

tfocosta

GBAtemp Z-Warrior
Member
Joined
Jun 2, 2020
Messages
656
Trophies
1
Website
nooooooooooooooo.com
XP
1,372
Country
Canada
Assuming that you have CFW, just try the following:

Black screen on boot
  1. Hold L on boot to disable TaiHEN plugin loading
  2. If your device boots, try editing ux0:tai/config.txt and remove any plugins you may have recently added
  3. If these instructions do not work, your device may be bricked
    • In unlikely event of this happening, please follow this tutorial
 

jaxteller

Member
OP
Newcomer
Joined
Apr 10, 2021
Messages
5
Trophies
0
Age
32
XP
34
Country
Netherlands
You could try discharging any residual power from the vita by turning it on with no battery inserted. Then putting the battery back and trying to turn it on again. Other than that I don't know. Sorry m8. I'm at a loss.
ok man thanks, will probably just send it for repair.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: https://youtu.be/bcwkMfoUATc No more SteamDeck waits