1. jaxteller

    OP jaxteller Newbie
    Newcomer

    Joined:
    Apr 10, 2021
    Messages:
    5
    Country:
    Netherlands
    Charged the battery fully, during charge it was just solid orange When pressing the power button (to turn it on), the PS button turns solid blue, but no sound or no screen, when pressing it again as if you would power it off, it blinks blue like 4 times blue and goes off.

    Already tried holding power button for 30 seconds, and it still stays black. Also tried R button plus ps button plus power button, nothing shows up. There is also no audio. Got this vita second hand, and was probably not used for a while. Hooking it up to a PC, it recognizes the vita.

    Swapped the battery with one from another vita that works fine Still same issue. At this point. What could be the issue?
     
    Last edited by jaxteller, Apr 10, 2021
  2. tfocosta

    tfocosta GBAtemp Z-Warrior
    Member

    Joined:
    Jun 2, 2020
    Messages:
    595
    Country:
    Canada
    Assuming that you have CFW, just try the following:

     
  3. jaxteller

    OP jaxteller Newbie
    Newcomer

    Joined:
    Apr 10, 2021
    Messages:
    5
    Country:
    Netherlands
    nope, no cfw on this one
     
  4. ILuvGames

    ILuvGames The Avatar-less One
    Member

    Joined:
    Nov 13, 2011
    Messages:
    363
    Country:
    United Kingdom
    My bad. Didn't read that you used a different batery.
     
    Last edited by ILuvGames, Apr 12, 2021
  5. jaxteller

    OP jaxteller Newbie
    Newcomer

    Joined:
    Apr 10, 2021
    Messages:
    5
    Country:
    Netherlands
    I guess it's just dead, but it's weird the pc recognizes it as a vita system.
     
  6. ILuvGames

    ILuvGames The Avatar-less One
    Member

    Joined:
    Nov 13, 2011
    Messages:
    363
    Country:
    United Kingdom
    Might not be dead. Could be that the screen has been disconnected or damaged in some other way.
     
  7. jaxteller

    OP jaxteller Newbie
    Newcomer

    Joined:
    Apr 10, 2021
    Messages:
    5
    Country:
    Netherlands
    there is no audio either.
     
  8. ILuvGames

    ILuvGames The Avatar-less One
    Member

    Joined:
    Nov 13, 2011
    Messages:
    363
    Country:
    United Kingdom
    You could try discharging any residual power from the vita by turning it on with no battery inserted. Then putting the battery back and trying to turn it on again. Other than that I don't know. Sorry m8. I'm at a loss.
     
    Last edited by ILuvGames, Apr 14, 2021
  9. jaxteller

    OP jaxteller Newbie
    Newcomer

    Joined:
    Apr 10, 2021
    Messages:
    5
    Country:
    Netherlands
    ok man thanks, will probably just send it for repair.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - swapped, Already, battery