Very strange USB HDD behaviour.

Discussion in 'Wii - Backup Loaders' started by Shady Guy Jose, Feb 28, 2013.

Feb 28, 2013
  1. Shady Guy Jose
    OP

    Member Shady Guy Jose GBAtemp Regular

    Joined:
    Sep 14, 2008
    Messages:
    196
    Location:
    Portugal
    Country:
    Portugal
    I mean VERY strange, and you'll find out why in a minute. First of all, let me just say that I've narrowed this down to the Wii side, having tested multiple USB drives formatted in both FAT32 and NTFS to exactly the same results.

    On my launch day, Wiikey-1-chipped, 4.2E console, I had a 2 year old working setup of HBC 1.0.8 (later 1.1.0) running on IOS61, cIOSX r20b, and CFG USB loader. Recently, for no apparent reason, HBC started refusing to boot with the HDD plugged in. If I remove the HDD, it runs. After having ruled out HDD problems, HBC updates and file system issues, I decided to toy around with IOS's, even though my previous setup worked fine. The results were as follows:

    HBC running on IOS 58 - runs fine without HDD, black screen with it. IOS 61 - same as above, but unplugging the HDD on the fly gets it to boot. On both, using the HDD on port 1 instead of 0 makes it run fine.

    After getting it to run using port 1, I tried CFG loader. This is where it gets strange: with most cIOSs, it just refuses to recognise anything connected to port 1. When I use a cIOS based on IOS 58, it loads everything perfectly, and games work! However, and here comes the dealbreaker, they run at USB 1.1 speed. As you may be able to imagine, this is painfully slow.

    Given all of this, I'm leaning towards a damaged port 0, which sucks big time. Any ideas?

    I am sorry for posting this in two sections, but I wasn't sure in which it fits better, and it's a bit of an urgent matter. If any mods feel one of them should be closed, go right ahead.
     

Share This Page