USB to PCIe x16

Discussion in 'Mobile Phones and Media Players' started by DarkFlare69, May 29, 2016.

  1. DarkFlare69
    OP

    DarkFlare69 GBAtemp Psycho!

    Member
    4,742
    2,600
    Dec 8, 2014
    United States
    Ohio
    I have a capture card that uses a PCIe x1 slot. I have 1 PCIe x16 slot available, 2 PCIe x8 slots, and 1 PCIe x1 slot available. It always gives me a Windows blue screen when trying to use it for more than around 30 seconds. I went into BIOS because I heard that it will update the hardware. It didn't work. OBS uses around 30-40% of my CPU, which is insanely high for me, considering GTA 5 doesn't go above 27%.

    So my question is, can I get this USB to PCIe x16 and use my capture card on there? If so, will there be any loss of quality?

    When removing the capture card, the blue screens go away, but will they come back if this usb adapter idea works?

    also, if anyone thinks this that they can help me get it working properly without any extra hardware, id be open to any suggestions pretty much
     
    Last edited by DarkFlare69, May 29, 2016
  2. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,696
    9,565
    Nov 21, 2005
    United Kingdom
    Reasons to be cheerful for bluescreen if you say it only happens when it is used.

    Something power related. Unlikely with a simple capture card but not impossible.

    Bad motherboard or bad card sending corrupt stuff around the place and other things not being able to handle it. You could try another slot -- you can use more powerful slots than you need, using lower ones is more tricky.

    Drivers.

    It is not impossible that is OBS causing your woes. You could try an alternative capture program like virtualdub http://virtualdub.org/ if you wanted. I would be sort of shocked if it was though. I also hope you screwed it in properly -- not screwing things in could bend the motherboard just enough to cause fun and games.

    You did not say what card it was but given posts you made I assume it is some cheap Chinese thing. Drivers were always an option but here it is a distinct possibility. It could be a conflict with some other drivers or software but it is more likely to be bad drivers. Find out what card it is/what it is based on and see if the internet has suggestions -- cheap capture cards usually have a reasonable following.

    "30-40% of my CPU" -- video encoding it one of the hardest things you can task a computer to do, that is nothing.

    Going into BIOS will mean you have gone into BIOS. You could update the BIOS which might help fix some hardware issues, though usually that means CPU and RAM related bugs than anything like this.

    If you have access to another machine then you might try that.

    The USB adapter... theoretically it could fix any of those issues, or at least prevent bluescreen. Practically it is not likely to do anything other than make it easier to put your card in another machine. It is $5 which is well within my pain point for interesting gadgets and adapters, don't go buying one and waiting on the postman/running home from school each day thinking it is all you need to fix your issue though. As for loss in quality then USB3 is about the same transfer speed so it should work, you may have an increase in latency though.
     
  3. DarkFlare69
    OP

    DarkFlare69 GBAtemp Psycho!

    Member
    4,742
    2,600
    Dec 8, 2014
    United States
    Ohio
    I tried all 3 of the slots, same error

    Yes, I always screw it in before testing it of turning it on

    — Posts automatically merged - Please don't double post! —

    yes it is a cheap chinese one. it came with a cd for drivers and i installed them

    When I record my screen at 1080p48, record dolphin at 1080p60, or record cemu, I have never seen OBS use above 5% of my CPU (8000 bitrate)

    Ive updated my bios plenty of times by now, but when i try it this time it says no valid files found on USB...

    It doesnt bluescreen my other PC, but OBS says failed to get DXGI adapters. I have an ASUS AM1I-a motherboard, athlon 5350 with integrated graphics. The audio driver isn't working and ive been trying fkr months.

    it's only $5 so I'll give it a try if i can't get this fixed within a couple days
     
    Last edited by DarkFlare69, May 29, 2016