Usb pen won't add data or reformat ( help plz )

Discussion in 'Computer Games and General Discussion' started by Ringo619, Oct 13, 2010.

  1. Ringo619
    OP

    Ringo619 GBAtemp Advanced Fan

    Member
    2
    May 24, 2010
    United States
    So i got my usb pen drive back from my friend and he said there was no files in the usb and he also said that it froze his computer , so i tried it it also froze my computer for like 5 mins then i tried adding some files and i got a pop up message saying "item not found" and i even tried other files same thing for each file . So i right clicked on my usb and pressed format and nothing appeared pressed it a few more times nothing happed. Next i installed some software to format the usb ( HP USB Disk Storage Format Tool ) and i got a message saying "There is no media in the specified drive".

    I am not really sure what has happed to my usb and i need it tomorrow for school , so is there any way to fix this up ?
    Thanks in advance , your help will be greatly appreciated
     
  2. Rasas

    Rasas Banned

    Banned
    1
    Apr 7, 2010
    United States
    Try more programs such as Apacer Repair and some other programs. If they all fail on you try to get it replaced or get a new one.
     
  3. Joe88

    Joe88 [λ]

    Moderator
    13
    Jan 6, 2008
    United States
    its probably dead

    flash memory dies after a certain amount read/writes cycles
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice