USB Loader GX won't initialize HDD when started from HBC

Discussion in 'Wii - Backup Loaders' started by Laurensnl, Apr 22, 2017.

  1. Laurensnl
    OP

    Laurensnl Newbie

    Newcomer
    5
    0
    Apr 22, 2017
    Netherlands
    Hello,

    I bought a softmodded wii a couple of weeks ago. I updated the softmod using ModMii. Everything is up-to-date and I am finally able to use the forwarder for USB Loader GX to play backups from my external HDD.

    However, when I start USB Loader GX using the Homebrew Channel it freezes at initializing usb. Where I previously couldn't initialize my external HDD at all, I now can't initialize it using HBC. I find it odd as the forwarder channel works perfectly after updating my softmod.

    Some extra information: I am using a Hitachi 500GB 2,5" HDD which I had laying around due to an SSD upgrade. I formatted the HDD to fat32 using guiformat. In addition, I have used Wii Backup Manager to place the backups on the HDD and I have put the apps folder on my HDD.

    Does anyone have a clue on why USB Loader GX freezes at initializing only when started from HBC?
     
  2. jeannotte

    jeannotte GBAtemp Regular

    Member
    204
    24
    Jun 15, 2016
    France
  3. Laurensnl
    OP

    Laurensnl Newbie

    Newcomer
    5
    0
    Apr 22, 2017
    Netherlands
    Thanks for your reply, here is my SysCheck:
    Warning: Spoilers inside!

    Like I said, I updated my softmod using ModMii, so ModMii now says that my Wii is fully up-to-date. But, yesterday I experienced multiple freezes playing Mario Kart with 2 players. When I just played the Grand Prix in singleplayer, I did not experience any freezes. My HDD is an Hitachi Travelstar Z5K500 (HTS545050A7E380) which I placed in a USB3.0 enclosure. The enclosure does not have a Y-cable. USB Loader GX loads the HDD fine when I use the forwarder channel and all my backups seem to be working. It just randomly freezes playing Mario Kart.

    I might try a different USB loader and see if it still freezes. Any other thoughts?

    EDIT: I tried CFG USB Loader and Mario Kart also froze at the end of a round. I think my HDD is the problem because my 32GB flash drive does not have any problems at all.
     
    Last edited by Laurensnl, Apr 23, 2017
  4. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    3,841
    734
    Mar 2, 2015
    United States
    If the enclosure has any special features like encryption or power saving turn them off.
     
  5. Laurensnl
    OP

    Laurensnl Newbie

    Newcomer
    5
    0
    Apr 22, 2017
    Netherlands
    Well, I used hdparm to deactive energy management and sleep mode on my Hitachi HDD. However, I do not know if my enclosure has such features nor how to turn them off.
     
  6. Durelle

    Durelle GBAtemp Regular

    Member
    179
    31
    Dec 22, 2016
    Canada
    NB, Canada
    make sure your using the right USB port, and also made sure it has the appropriate power, are you using a Y Cable?
     
  7. Laurensnl
    OP

    Laurensnl Newbie

    Newcomer
    5
    0
    Apr 22, 2017
    Netherlands
    I am definitely using the right USB port and as I already stated am not using an Y-cable. The external HDD enclosure came with a single usb cable. However, I don't believe a lack of power is causing the drive to freeze mid game. I am thinking the drive itself is just not compatible, because the drive spinsdown and goes to sleep. I tried HDPARM but the drive just doesn't save the settings, even if I use -K1 in HDPARM.
     
  8. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    3,841
    734
    Mar 2, 2015
    United States
    This is likely the problem. hdparam doesn't deal with the enclosure, just the drive bits.
     
  9. Laurensnl
    OP

    Laurensnl Newbie

    Newcomer
    5
    0
    Apr 22, 2017
    Netherlands
    Well, I've searched online and done everything possible to get the drive to work properly. Guess I go buy a 128gb usb flash drive. Probably a Verbatim as my 32gb works perfectly.
     
    Last edited by Laurensnl, Apr 28, 2017