Hacking USB Loader GX Randomly Stopped Working

TheBeverage

Well-Known Member
OP
Newcomer
Joined
Mar 13, 2015
Messages
74
Trophies
0
XP
473
Country
United States
Hi all, I've been using USB Loader GX for a while to load Wii backups off a USB flash drive without issue, except one day it simply stopped loading games. Especially odd as it had been working earlier the day it started having this issue. As shown in the video I'll link, the Wii just goes to a black screen and stops responding (note: there is still video output or my TV would show "No Signal" immediately).
See here:

I've tried loading GameCube games off an SD card (I usually use Nintendont) to test it and USB Loader GX won't load those games either. I've done a lot of Googling and searching around to no avail, and any help would be greatly appreciated.
 

BlazeHeatnix

Well-Known Member
Newcomer
Joined
Jul 4, 2015
Messages
99
Trophies
0
Age
28
XP
164
Country
United States
Hi all, I've been using USB Loader GX for a while to load Wii backups off a USB flash drive without issue, except one day it simply stopped loading games. Especially odd as it had been working earlier the day it started having this issue. As shown in the video I'll link, the Wii just goes to a black screen and stops responding (note: there is still video output or my TV would show "No Signal" immediately).
See here:

I've tried loading GameCube games off an SD card (I usually use Nintendont) to test it and USB Loader GX won't load those games either. I've done a lot of Googling and searching around to no avail, and any help would be greatly appreciated.
Same exact problem as you, I haven't gotten any help either.
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,418
Trophies
2
Age
43
Location
Engine room, learning
XP
14,504
Country
France
Try another loader to see if the issue is USBLoaderGX or not.
it will first show where we should search for the bug.

if it works in other loader, then it's USBGX issue.
if it doesn't work, then it's your ISO or flashcard or console's softmod, or ... I don't know, we will see after you try a different loader with the same hardware and drive.


Try a lot of "different" element to exclude them one by one. narrow the possibilities. this is how I find bugs and fix them.
 
  • Like
Reactions: TheBeverage

TheBeverage

Well-Known Member
OP
Newcomer
Joined
Mar 13, 2015
Messages
74
Trophies
0
XP
473
Country
United States
Thanks Cyan. I tried loading the GameCube ISOs through Nintendont and that worked fine, so I'm guessing it's a USBGX issue. Guess I have to go looking for a new loader for Wii games.
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,418
Trophies
2
Age
43
Location
Engine room, learning
XP
14,504
Country
France
no, you don't have to go look for a new loader.
You have to go look for the issue, and fix it.

What you just proved is that the ISO and device is still working fine.
now you have to find if the issue is the loader itself or the settings.

things you can try
1. reset the settings and try again
delete GXGlobal.cfg manually from the loader's folder or choose the reset option in the settings.

2. try a different nintendont version
USBGX is loading nintendont and sending parametters to it.
Sometime, nintendont update it's parametter list and the loader is not sending the correct/expected values anymore.
If that's the case, then I need to update these sent parametter and release a new version of the loader.
Did you update nintendont recently?
I just checked, nintendont didn't update its settings since august, but maybe you have an old version of the loader.
Be sure to update both the loader and nintendont.

3. try a different USBloader GX version.
if you updated recently, maybe there's a bug in the latest and old one worked fine?
if you have r1259, try r1256
if you have r1256, try r1246
etc.
don't go too far back, or nintendont will not work anymore.


4. try the same games
you posted a video of New Super mario Wii not booting, I suggested that you try a different loader with the "SAME" game, setup, drive, etc.
For example, Wiiflow or CFGLoader, not nintendont!
try the same game, so we know the wii games don't have other issues.
 

TheBeverage

Well-Known Member
OP
Newcomer
Joined
Mar 13, 2015
Messages
74
Trophies
0
XP
473
Country
United States
I got the game to work when I tried using Wiiflow, and honestly I'm good with that. I appreciate the advice for getting USB Loader GX working again but frankly, so long as I can play the games I'm satisfied.
 

tswntk

Well-Known Member
Member
Joined
Aug 6, 2012
Messages
994
Trophies
0
XP
1,552
Country
Switzerland
I got the game to work when I tried using Wiiflow, and honestly I'm good with that. I appreciate the advice for getting USB Loader GX working again but frankly, so long as I can play the games I'm satisfied.

have you tested all the games you have?
Wiiflow haven't been updated for ages, chances are your Nintendont version is outdated and you are compromising game compatibility.
usnloadergx is the only usb loader that is still active, don't discourage the dev like that
 

BlazeHeatnix

Well-Known Member
Newcomer
Joined
Jul 4, 2015
Messages
99
Trophies
0
Age
28
XP
164
Country
United States
Ok TheBeverage, I can help.

The video clearly says you are using r1180. That's extremely outdated. Go into your settings to the Update menu, and update USBGX.
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,418
Trophies
2
Age
43
Location
Engine room, learning
XP
14,504
Country
France
don't worry, it's not discouraging me. I'm already missing time/will to work on it by myself, no need of other users to do that :lol:
I don't care if users prefer another one, when all three were still active it was only a user preference as all had the same features (more or less).
a lot of people preferred wiiflow, and I respect that.

but I still would have preferred to find where the issue was, first for beverage then for me and also for all the other users finding this thread when searching for a similar issue.


and as bladeHeatnix said, if you are using 1180 that's normal that newer nintendont won't work.
like I explained, nintendont updated many times its config file, and I had to also update the loader to continue "talking" the same language than nintendont.
last internal release is 1256 but has network issue.
last revision (not internal) is 1259 but has cover download bug, and soon 1260 with fixed network and cover issues.

That would fix the nintendont issue, but won't explain the Wii game issue.
Maybe he just set a wrong video mode.
 
  • Like
Reactions: TheBeverage

TheBeverage

Well-Known Member
OP
Newcomer
Joined
Mar 13, 2015
Messages
74
Trophies
0
XP
473
Country
United States
I decided to give it another shot with the update (I had no idea you were the dev, sorry!) and it actually seemed to fix the issue with the Wii games. I'm still not quite sure what the issue was that suddenly appeared, but using the latest version it seems to be completely fixed. I feel a bit silly for not thinking of updating sooner actually.

I do much prefer this one's interface by far, so I'm glad to have it working again! Thanks!
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,418
Trophies
2
Age
43
Location
Engine room, learning
XP
14,504
Country
France
I'm glad it also fixed the Wii launching issue.

About nintendont:
I will remove the "update nintendont" feature in r1260
But it will fix the cover download issue.

for the moment it's one or the other. I think nintendont is not updated as often as last year, so this option is less used. having a working network and cover downloader has priority in my opinion.
You can always update nintendont from the nintendont options (keep B pressed to stop autoboot, and update from options)
 

TheBeverage

Well-Known Member
OP
Newcomer
Joined
Mar 13, 2015
Messages
74
Trophies
0
XP
473
Country
United States
Alright, so as I said it did seem to be working, but every few loads it simply stops again. I'm still using the latest version now, I have to redownload a fresh copy onto my SD card in order for games to load again.
 

WHEELMAN

Member
Newcomer
Joined
Jul 28, 2013
Messages
22
Trophies
0
XP
135
Country
United States
hello i have wiiu and everything done on vwii usb loader stop working on screen file are set up right to any help would be great 32 gb usb flash drive sandisk
 
General chit-chat
Help Users
  • No one is chatting at the moment.
  • mr_switch @ mr_switch:
    Here is hoping 2022 is a good year for DC cinematic universe
    Gift
  • gudenau @ gudenau:
    Honestly don't really know what Dune is.
    Gift
  • gudenau @ gudenau:
    Anyone here know much about Jetbrains InteliJ Idea?
    Gift
  • Sonic Angel Knight @ Sonic Angel Knight:
    Oh, T-hug was here :blink:
    Gift
  • Sonic Angel Knight @ Sonic Angel Knight:
    Hey, where the admins at? Come in the chat. I got a idea. How bout a Sound notification or something when someone tags you in chat? :ninja:
    Gift
  • DinohScene @ DinohScene:
    Post it in the v8 feedback thread
    Gift
  • Gift
  • OzKenny1983 @ OzKenny1983:
    Post what sorry? I'm guessing we were talking about this ages ago, but I haven't been on GBATemp in almost a year so my memory is failing me :-/
    Gift
  • DinohScene @ DinohScene:
    feedback and or bugs that may have popped up since the migration to XenForo 2!
    Gift
  • OzKenny1983 @ OzKenny1983:
    Umm...I think you might have the wrong person, since that may as well have been written in Chinese. I have nothing to do with the management of this site, nor have I ever been involved. I'm just a member, and hardly even qualify as that...like I said my last post was almost a year ago lol
    Gift
  • DinohScene @ DinohScene:
    Lol no, Sonic Angel Knight had an idea, best would be to post it in that thread haha
    Gift
  • OzKenny1983 @ OzKenny1983:
    Sorry, don't know Sonic Angel Knight either...
    Gift
  • The Real Jdbye @ The Real Jdbye:
    this new xenforo version keeps logging me out, whyh
    Gift
  • godreborn @ godreborn:
    not sure. I haven't had that issue. the only computer related issue I've been having is with my isp and the smtp server getting authentication errors randomly. I'm going to have to call them again. this started happening again after changing my password.
    Gift
  • godreborn @ godreborn:
    you may have to check the box that says "stay signed in." psx place used to have a problem like this for random people, including myself. that will prevent being logged out or it did anyway.
    Gift
  • The Real Jdbye @ The Real Jdbye:
    it's happened 3 times already and of course i ticked the box
    Gift
  • linuxares @ linuxares:
    Yeah happened to me as well
    Gift
  • Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    just installed gentoo, i came out alive somehow
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    honestly the install itself wasn't that hard, the hard part was getting my hardware to work
    Gift
  • x65943 @ x65943:
    Is it true what they say, did your neck sprout hairs afterwards?
    Gift
  • The Real Jdbye @ The Real Jdbye:
    good luck actually using it
    Gift
  • Cnrisnm @ Cnrisnm:
    Hi
    Gift
  • SG854 @ SG854:
    When I see a red light all I know is go
    Gift
  • kenenthk @ kenenthk:
    Have you tried squid games based on your skills
    Gift
    kenenthk @ kenenthk: Have you tried squid games based on your skills