Usb loader gx loading issues

Discussion in 'Wii - Backup Loaders' started by Kasheem009, Aug 12, 2013.

  1. Kasheem009
    OP

    Kasheem009 Member

    Newcomer
    12
    0
    Aug 11, 2013
    United States
    Every time I load up a wii game with usb loader gx, the game stops loading about 5 minutes in, if it boots at all. Here is what I'm running.

    Homebrew Channel (v1.1.0)
    USB loader gx (v3.0 r1180)
    d2x_v10 on base 56 slot 249 and base 57 slot 250.

    My HDD is a seagate free agent pro (NTFS with a wbfs folder) and I'm using a sandisk micro sd card to run apps, both are listed on their respective compatibility lists.

    I've tried both d2x_v9 and v8, but the issue still persists. I've also tried switching the hdd and switching to cfg loader, but no luck there either. If anyone could offer any advice or suggestions I'd be grateful. I'm honestly out of ideas.

    Here are my sysCheck results.
    Warning: Spoilers inside!
     
  2. KesanGun

    KesanGun Member

    Newcomer
    21
    0
    Sep 18, 2009
    United States
    I actually use the same hard drive as you, so I'm glad to hear switching the hard drive does not solve the problem, as I don't want to buy a new one. I got less frequent but still occasional freezing by switching to d2x_v10 beta 2.
     
  3. Kasheem009
    OP

    Kasheem009 Member

    Newcomer
    12
    0
    Aug 11, 2013
    United States
    So I remodded my wii using modmii, tried out usb loader gx and cfg loader but the it still wouldn't work. I did notice that the version of cfg that came with modmii had an option to play wii games off my SD card, so I tried putting kirby on there and trying it out. To my surprise, it worked! I've completed the first 4 levels without any errors whatsoever!

    Now here's my question. Why would loading from my sd card (fat32 with a wbfs folder) work when I've tried the exact same thing with a 500gb HDD and 3 separate flash drives?
     
  4. calmwaters

    calmwaters Cat's best friend

    Member
    1,718
    375
    May 27, 2013
    United States
    happy land
    Because Wii games are supposed to load with this configuration. Does your HDD have a wbfs folder on it? Do the loaders detect your HDD? Is the fat32 partition on your HDD both primary and active?
     
  5. Kasheem009
    OP

    Kasheem009 Member

    Newcomer
    12
    0
    Aug 11, 2013
    United States
    My 500gb HDD is purely fat32, and I have a folder on the root named wbfs with the games inside of it. The loaders can all load the games but they all freeze within 5 minutes of playing them. The 500gb HDD doesn't have an external power source so at first I believed that that may be causing this issue, but the issue still persists even when I use 8gb flash drives with the same wbfs folder setup.
     
  6. calmwaters

    calmwaters Cat's best friend

    Member
    1,718
    375
    May 27, 2013
    United States
    happy land
    HDD's/flash drives don't have external power sources; they have USB cables... Can you go into the game's loading options in the loader and set it to 249 instead of Default to see if that makes a difference?
     
  7. Kasheem009
    OP

    Kasheem009 Member

    Newcomer
    12
    0
    Aug 11, 2013
    United States
    Some HDD's do have an external source of power (like a 120v wall plug), and I generally hear that this is recommended over a single usb powered HDD. That's what I was referring to.

    Yeah I have tried 249, 250, and a few others with no luck (with that HDD). They all work with the SD card just fine though.
     
  8. KesanGun

    KesanGun Member

    Newcomer
    21
    0
    Sep 18, 2009
    United States
    Hey Kasheem, I'm going to try a few things tomorrow:
    1. Use Seagate_Manager.exe (Free, legal utility distributed by the manufacturer) to disable the spindown on the Freeagent drive.
    2. Use ModMii to reinstall cIOSes and make sure all my stuff is correct.
    3. See how burned ISOs work out.
    4. Try to replicate running Kirby from an SD card.

    I'll let you know how it goes. Since I'm on 4.3u, I may just try buying an SDHC card later this week and running everything off of that.

    Edit: Does anyone know if loading from NTFS as opposed to FAT32 would cause increased crashes? Also, I've heard Configurable USB Loader has higher compatibility, but I can't get it to load games at all; It says IOS Reload Blocked then hangs.
     
  9. Kasheem009
    OP

    Kasheem009 Member

    Newcomer
    12
    0
    Aug 11, 2013
    United States
    Kesan, I downloaded the Seagate Manager earlier to do exactly what you described, but it didn't work for me. If it works for you, definitely let me know. I'm also looking forward to hearing if burning to disc works or not, and if all else fails you can just buy that SDHC card. I'd like to get use of this 500gb hard drive though, and I'm sure you feel the same way.

    Good luck!
     
  10. KesanGun

    KesanGun Member

    Newcomer
    21
    0
    Sep 18, 2009
    United States
    I found a thread about this from back in the day exploring an extremely similar issue to what we've experienced. At least one person fixed it by going into Computer-Manage-Disk Management and marking the partition on their External HD as Active in addition to Primary. Hope this helps, I'm trying it now.
     
  11. KesanGun

    KesanGun Member

    Newcomer
    21
    0
    Sep 18, 2009
    United States
    I found a thread about this from back in the day exploring an extremely similar issue to what we've experience. At least one person fixed it by going into Computer-Manage-Disk Management and marking the partition on their External HD as Active in addition to Primary. Hope this helps.
     
  12. Kasheem009
    OP

    Kasheem009 Member

    Newcomer
    12
    0
    Aug 11, 2013
    United States
    Any luck?
     
  13. KesanGun

    KesanGun Member

    Newcomer
    21
    0
    Sep 18, 2009
    United States
    I can't use discs because I am on a Black Wii, so the drive will not run burned discs no matter what. Also, USB Loader GX doesn't load from the SD card so I wasn't able to try that.

    I have verified some things: 1. The console doesn't crash whenever it's not loading from the HDD. 2. The console will crash eventually loading any game I can find from the HDD. 3. My cIOS setup is good, my WADs are good, and I have the latest version of USB Loader GX.

    I think we just got burned on this HDs, man. While some people have had success with SOME Freeagent HDDs they make at least seven varieties and ours just don't seem to cut it. I even talked to Cyan about it on IRC, the original gangster who made USB Loader GX, and he said he had never heard of our issue. I am going to look for another external HD and I will get back to you on whether I can get that one working.

    I also find it suspicious that I have a WAD/cIOS setup that checks out 100% but have no success running games on ANY of the three backup loaders. I know I have another HDD here so I will try to find it eventually and see if that one works better.

    Edit: Hey, found my old NexStar 3. Moving games to it and trying it out today. Thus far I have been unable to reproduce the issue on the other hard drive.
     
  14. Kasheem009
    OP

    Kasheem009 Member

    Newcomer
    12
    0
    Aug 11, 2013
    United States
    Really? That's good news you are making some headway. I actually bought a new WD My Passport 500gb, and unfortunately I have the exact same issue. I have an original wii, so the disc burning stuff my work me for though. That NexStar 3 work out 100% for you?

    Edit: I know what you mean, I've checked the wads and cios at least 20 times and I know we are good there. I'm almost certain it's the hdd because games work fine when I run them off my sd card.