USB Loader GX: Black screen when loading Wii games

Discussion in 'Wii - Backup Loaders' started by iamfearlezz, May 14, 2014.

  1. espositodnl86

    espositodnl86 Member

    Newcomer
    1
    Sep 26, 2016
    Italy
    Hi,

    I am experiencing the same issue. I have a PAL console and USB Loader GX has always worked like a charme with PAL titles but now I'm trying to play the NTSC version of Bully and I get a blank screen even after changing the video mode to "Disc default".

    What could the problem be?

    Thanks for the help!
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    is an old version of the loader working fine? if it works, do you know which version broke it?
     
  3. espositodnl86

    espositodnl86 Member

    Newcomer
    1
    Sep 26, 2016
    Italy
    Thanks for you reply!

    I have always used the same version (3.0 r1262) since I modded my Wii so I can't answer your question.
    Bully launched without problems after selecting English as game language in the loader settings but with Crash M.O.M. I get a blank screen even by applying the same settings. I have also tried to apply the "Dol video patch" without success...
     
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    if some of the games are working, I suppose you are using usb port0. (if you used port1 by mistake no game would work).

    If it used to work, there is no reason it stopped working one day for no reason, so something has changed but we don't know what. either the settings, the drive content, or the system.
    Did you try to reset the loader's settings? first thing to try, using a clean install with no cache or settings, just to see if it's a wrong setting problem.

    if reseting the settings didn't help, it's either the drive (or its content), or the system (IOS and cIOS).
    If you changed/updated your softmod recently, maybe you replaced d2x v8 or v10 with v10-alt? some guide tell people to update to latest version, but latest is bad! r53 is bad, never use it.
    you can post a syscheck if you don't know what you have. (guide in my signature)

    if syscheck reports v8 or v10r52, then it's a device issue.
    did you try another HDD ?
    if you have a flash drive instead of HDD, don't use flashdrive (they can work, but not always. and badly).
     
  5. espositodnl86

    espositodnl86 Member

    Newcomer
    1
    Sep 26, 2016
    Italy
    No, this game in particular never worked and I haven't changed anything after modding my Wii.
    I have attached my SysCheck so that you can take a look at it.

    Again, thanks for the help!
    SysCheck
     
    Last edited by espositodnl86, Feb 5, 2019
  6. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    thanks, your syscheck/cIOS are good.

    ah, that game never worked?
    some games are not working because of Anti-piracy features in them, or because they require a specific IOS base :
    Animal Crossing new leaf : cIOS base38 to use the keyboard
    spongebob boating bash : cIOS base53 (tested on Wii) or 58 (tested on vWii)


    Do you know if this game usually work for other users?

    quick search:
    not working : https://gbatemp.net/threads/crash-mind-over-mutant-ntsc-freeze-with-usb-loader-gx.158999/
    not working : https://forum.romulation.net/threads/wii-crash-mind-over-mutant-black-screen.65358/

    the compatibility list says :
    Black Screen with Usb Loader 1.5 / Played for over an hour using USBloader_gx rev449 with CIOSrev13 installed, no black screen.
    Attention: DO NOT install cIOS below rev14 on newer console, it can brick! (or maybe it was rev7, but still, don't try!)

    what you should know : rev13 used base38, since rev18 the base can be selected by the user and most guide tell users to use base56 and/or 57, but some games don't work with these base.
    So, what I suggest :
    install d2x cIOS v8 final base 38 on slot 248 : IOS248[38]

    launch usbloaderGX, select that game, go to settings, game option, IOS slot : replace "use global" with 248.
    save the game's setting
    launch the game. let me know :)
    if it works, better update the wiki than leaving a dangerous information.
     
    Last edited by Cyan, Feb 5, 2019
  7. espositodnl86

    espositodnl86 Member

    Newcomer
    1
    Sep 26, 2016
    Italy
    Can you guide me on how to do that? I'm not very experienced...
     
  8. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    create a folder here sd:/apps/d2x_installer/
    extract this link into the folder
    http://www.mediafire.com/file/5ggh53tj9hhp1tr/d2x-cios-installer-3.1-v6-v7-v8-v10-wii.7z

    be sure the network is working (I'll just assume IOS are still available on nintendo servers, I didn't test nor had conformations yet)
    launch d2x installer from HBC.
    select :
    d2x v8 final
    slot 248
    base 38
    version whatever you want (default or 65535 are fine)
    press A and A to install, once done exit the installer.


    once done, follow what I said above to edit the game settings in the loader.
     
    Last edited by Cyan, Feb 6, 2019
  9. justwannaplayw11

    justwannaplayw11 Newbie

    Newcomer
    1
    Feb 7, 2019
    United States
    Black screen/crash after loading via 249,250.
    Here is my system check:
    Warning: Spoilers inside!
     
  10. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    you quoted a message I posted in 2014, and it doesn't have any relation to your problem ?

    about your syscheck result, there is something wrong :
    Homebrew Channel 1.0.0 running on IOS0

    1.0.0 is outdated a little (1.1.0 can be installed, or even newer)
    IOS0 does not exist.

    go to HBC, press the home button, look at the info on the top.
    tell me the IOS number and version you see.


    I think you updated only the IOS modmii told you, but should also update your HBC.
    modmii didn't generate a guide to follow? maybe you didn't followed it entirely?
     
    Last edited by Cyan, Feb 11, 2019
  11. justwannaplayw11

    justwannaplayw11 Newbie

    Newcomer
    1
    Feb 7, 2019
    United States
    Yes my bad it was the only place i could find that was experiencing same issue i had? i noticed that on the system check as well, i am looking at hbc now and it says-- 1.1.2 ios58 v24.32... i now have ios 249 [56] v65535, 250 [57] 65535. not sure why hbc says 1.0.0 on ios0 ?? thats clearly the problem. heres system check
    Warning: Spoilers inside!
     
  12. tswntk

    tswntk GBAtemp Advanced Fan

    Member
    5
    Aug 6, 2012
    Switzerland
    don't use outdated syscheck app, use the one linked in Cyan's signature and see if it checked differently?
    If its still the same, update/reinstall HBC
     
    justwannaplayw11 likes this.
  13. justwannaplayw11

    justwannaplayw11 Newbie

    Newcomer
    1
    Feb 7, 2019
    United States
    Here is the updated syscheck report, everything looks to be normal? must just be my hdd. there is a couple stubs on the beginning ios's, idk ive been doing this for a good 10 hours from the past week. Honestly about over by now.
    Warning: Spoilers inside!
     
  14. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    everything is good on your syscheck now :)

    you'll have to give more information about your "crash after loading", it doesn't explain if it's after loading the loader, or the game, which game, which hdd format, etc.
     
  15. justwannaplayw11

    justwannaplayw11 Newbie

    Newcomer
    1
    Feb 7, 2019
    United States
    usb loader boots up fine and it shows the game and play the music like it would if it was the actual disk, i hit start and screen goes black and controller shuts off/crash. hard reset and tried as many settings i read will work and same thing. At the moment i adding a game i know will work, my 16gb thumb drive is formatted in fat32. I am hoping it was just the games ive downloaded. one said it was usa but when i looked at the info it was all in spanish? Same with the other game ive been trying to load. Ive been unzipping with winzip then torrent then adding to drive with wii back up manager and it goes to wbfs folder on my usb root. Now im just unzipping then loading the iso with wii backup manager So far i think the games ive found have all been trash/ different regions?
     
    Last edited by justwannaplayw11, Feb 12, 2019
  16. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    thumb drives don't work with cIOS and give black screen at game launch.
    use a real external HDD instead.

    if you don't have any, you can try to format the thumb drive to WBFS format instead of FAT32. it usually work, but still have write issues (you can't dump disc to thumb for example).
     
    Last edited by Cyan, Feb 12, 2019
    justwannaplayw11 likes this.
  17. justwannaplayw11

    justwannaplayw11 Newbie

    Newcomer
    1
    Feb 7, 2019
    United States
    I have a 4tb hdd for my xbox one but cant lose any of the data. Can i use that if its right format, which i dont think it is. ill just order one if nothing else. feel like a jackass tying to get usb to work lmao. thank you so much for all your time ill keep you updated..
     
  18. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    very few flashdrive are compatible.
    if you want to buy a new HDD, get preferably one smaller than 2TB if you want the most easiest compatibility for all homebrew.
    if you get a bigger than 2TB, it'll be more complicated, but still possible if you get a Western digital. Other brands will be harder or not compatible with some homebrew or features (specifically emuNAND and neek). No problem if you only want wii or gamecube games though.

    1. WD recommended
    2. less than 2TB if possible.
     
    Last edited by Cyan, Feb 12, 2019
  19. Ryanx

    Ryanx Member

    Newcomer
    1
    Thursday
    United States
    Hi,

    I have been searching the internet for days including this forum to solve my issues but only in vain(BTW my salute to Cyan and Wolf whom I have come to appreciate for their great contribution and help throughout the search)

    Like many others I also had to go through hoops at first going through outdated blogs and u tube videos that weren't relevant or applicable and finally reached the conlusion that gx loader with Cyan's recommended settings are the best way to go. Unfortunately this still hasn't been able to resolve my issues.


    I would really appreciate your help and especially if Cyan could shed some light on the trouble I am having.

    My problem at hand is that Some (but not all) of my games fail to launch in using gx loader (or cfg loader or Wiiflow)

    1. Trouble : everything else(launching the gx loader, homebrew apps, cover download, themes, etc)with gxloader works fine except
    - Black screen freeze or other similar screen freeze in launching some of the games
    - I have about 100 games and about 80% work fine with gx loader(the latest version : Rev1271 IOS249(Rev 21008) + AHB (d2x v8final base 56) but 20% of them fail when launching the games
    - The games that fail in launching include : Monster hunter tri, DragonBall Z Budokai Tenkaichi 3, DragonBall Revenge of King Piccolo, Dragon Blade Wrath of Fire, Spiderman 3, Spiderman-Shattered Dimesions, The Amazing Spiderman, X-men Origins:wolverine, etc

    2. My system and specification ;
    (Apologies, I can't upload my syscheck since I don't have a SD card right now but if needed will post it later)

    - Wii 4.3
    - Softmodded in accordance with the latest modmii
    - homebrew : latest version
    - cIos d2x v8 final for both 249 and 250 in accordance with Cyan's recommendation.
    (Considered upgrading to v10 beta52 but didn't try yet after finding Cyan's advise that v10 has nothing to do with game compatibility but only hard drives)
    - Using wiibackupmanager (latest version) to install the games
    - tried on 2 different hard(500 GB beezap HDD and 70Gb toshiba HDD) drives to make sure it wasn't the hdd issue(the games mentioned above failed in both hard drives except for "Tom Clancy's double agent" which was successfully loaded on the toshiba HDD but failed in the beezap HDD.
    - Beezap has 2 partitions(first partition in fat32 format and the second partition in wbfs format with all the games) and the toshiba has one partion formatted in fat32.

    3. SHA-1 verification
    - tested using Wii backupmanager to verify both the SHA-1 and MD5. All verification shows no errors
    - tried different files(iso, wbfs) just to make sure it wasn't the game files that were corrupted, but all files failed the same.(one game file was due to file corruption but the rest of the games remain the same - black screen freeze when launching the game; mostly at the very beginning of launching the games or right after the remote manual screen)

    4. Different loaders
    - tried Cfg loader and Wii flow light(latest version) but also in vain.

    5. Different settings/ IOSs
    - tried ios 250, 251, (222 and 223 for monster hunter tri) but all in vain
    - tried changing other setting like 'force ntsc' but also in no vain (changed the settings in accordande with what I could search in this forum or in the internet, gave up after a number of attempts after finding Cyan's comment that these games should work with the default settings (ios 249) and after confirming the game compatibility table on a site.
    - BTW I was able to successfully launch COD games by changing the ios to 250.
     
    Last edited by Ryanx, Feb 14, 2019 at 2:43 PM
  20. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    if it's on specific location in game, and in all loaders, I'd tend to think it's an ISO corruption. even more if you ever used WBFS partition format in the past (or still do).
    did you check your games integrity with wiibackupmanager's sha1 option?

    if the ISO is good, it can then be a baseIOS or cIOS version problem, but that much game with the same issue is unusual.
    v8 base56 is known to not work only for very few games (call of duty, just dance, sing it?)
     
    Last edited by Cyan, Feb 14, 2019 at 12:22 PM
Loading...