USB Loader GX automatically changing to cIOS 250, "USB device not initialized"

Discussion in 'Wii - Hacking' started by DecemberStars, Mar 16, 2016.

  1. DecemberStars
    OP

    DecemberStars Newbie

    Newcomer
    7
    0
    Dec 17, 2014
    United States
    Hey everyone,
    I'm really inexperienced with the whole homebrew thing but after much trial and error, a few months back I was finally able to get everything I wanted working correctly. However, now, whenever I open USB Loader GX, on the startup screen it loads cIOS 249 (which is what I have always used it on) but then a new message comes up that says "reloading to the config file's cIOS" and it loads cIOS 250. After it's done loading, an error message pops up saying "USB device not initialized", and so none of my games can be accessed. The only thing I've changed recently was trying to install newer versions of d2x in an attempt to have two microphones work for Rock Band 3. The guide I followed for that said to install it in both 249 and 250, so presumably that's the issue somehow. I've plugged my hard drive into my PC to try to find the config file and change it but every file I find has 249 written in it, so I have no idea why it's changing to 250. Any help would be really appreciated and I apologize in advance for asking any stupid questions.

    Thank you :)
     
  2. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,024
    776
    Mar 2, 2015
    United States
    Can you run SysCheck and post the .csv file in spoiler tags just to make sure nothing is wrong with your IOSes? (Use the syscheck in that link. It's the most current and reliable version. It will write a "syscheck.csv" on your SD card root after it's done.)

    Also, what version (actual revision number like r1180, r1260, etc) is your USB Loader GX and how you install it? Older versions were available as a full channel but they're not supported or updated anymore.
     
  3. DecemberStars
    OP

    DecemberStars Newbie

    Newcomer
    7
    0
    Dec 17, 2014
    United States
    Thanks for the suggestion! Unfortunately, the SD card slot on my Wii is broken so I do everything through USB, and the page for SysCheck says it won't work through USB. Is there another way to do it?

    The version of USB Loader I have is indeed a full channel. It's r1230. It's been quite a long time since I installed it so I really don't remember how I did it.
     
  4. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,024
    776
    Mar 2, 2015
    United States
    You can still get the installer for the full channel from the loader's repository. It can be uninstalled with a mod manager like Multi Mod Manager by selecting it and choosing uninstall rather than install.

    You should be able to run everything except SysCheck from USB. It's probably the old GX version causing your issue but please follow up if it's not and we'll see if we can figure something out.

    This is the installer WAD for the old "UNLR" channel that you can use to uninstall it. (You can probably just remove the channel from the system menu settings, too.)

    The ones you'll want to replace it with are these:
    Forwarder (UNEO) channel: Wii vWii
    This goes in usb:/apps/usbloader_gx/: r1260

    Once you have the newer version you can just update it from its internal menu in the future.
     
  5. DecemberStars
    OP

    DecemberStars Newbie

    Newcomer
    7
    0
    Dec 17, 2014
    United States
    I just installed that new version and the same errors are happening. It seems even more likely now that this is a result of me screwing up the d2x installations in some way, but I have no clue where to even begin troubleshooting for that.
     
  6. Clutz450

    Clutz450 GBAtemp Advanced Fan

    Member
    614
    98
    Jul 20, 2013
    United States
    Go into the apps folder and then the usbloader_gx folder. Look for a file named meta.xml. Right click on it and open it in notepad. If I remember correctly (I'm not in front of my computer tonight but I'll check tomorrow) there may be a line of code in there that would force another cios to load. But I'm pretty sure though that you would have had to go into the meta.xml file manually and delete some line of code to make it active.

    Like I said, I'm not in front of my computer but just try messing around with the xml file and see if you can find your answer in there. Otherwise tomorrow I'll be able to help you better.
     
  7. DecemberStars
    OP

    DecemberStars Newbie

    Newcomer
    7
    0
    Dec 17, 2014
    United States
    This worked! I had to remove a line of code which allowed me to enable arguments and there was already an argument in the file to force 249. Unfortunately, now, for whatever reason, USB Loader GX isn't loading any of the saves I have in my emuNAND (I had a lot of games running on "partial" prior to this issue). Every game boots up as if it's never been played before. Any ideas on what to do for that?
     
  8. Clutz450

    Clutz450 GBAtemp Advanced Fan

    Member
    614
    98
    Jul 20, 2013
    United States
    Go to settings, custom paths and make sure that emunand path points to where your emunand actually is.

    You say it's not loading your saves. But when you do save does that stick and load the next time you play?

    Also, did you delete the full channel, install the forwarder and update USB Loader GX to rev1260? Because you shouldn't have to enable arguments to get it to work the way you want it to. Plus, if you ever update the loader from inside USB Loader GX it may also update the meta.xml file and you would have to enable the argument again.
     
    Last edited by Clutz450, Mar 18, 2016
  9. DecemberStars
    OP

    DecemberStars Newbie

    Newcomer
    7
    0
    Dec 17, 2014
    United States
    My emuNAND is on the root of the drive, so I'm sure it's pointed to the right location. It appears to be loading save data off of my actual NAND and not my emuNAND. I deleted the full channel and installed r1260, but I didn't install the forwarder (it seemed pointless to install it until I got everything working right).
     
  10. DecemberStars
    OP

    DecemberStars Newbie

    Newcomer
    7
    0
    Dec 17, 2014
    United States
    I've tried many things to fix this issue the past few days, none of which have worked. I'm really out of ideas. Is there any way to extract the RB3 DLC from my emuNAND so that I can use it in something other than USB Loader GX? If so, how would I go about doing that and what other program should I use?
     
  11. Clutz450

    Clutz450 GBAtemp Advanced Fan

    Member
    614
    98
    Jul 20, 2013
    United States
    I'm sorry. I've never done anything like that before so I don't have an answer or even an idea of where to start. Hopefully someone else will be able to help you.