USB Loader channel won't open

Discussion in 'Wii - Backup Loaders' started by fadafwet, May 22, 2015.

  1. fadafwet
    OP

    fadafwet Newbie

    Newcomer
    4
    0
    May 22, 2015
    Canada
    Hi

    I am new to the forum but I did a bunch of reading trying to solve my problem before posting with no avail.
    I was able to make the application USB Loader GX to run if I start it from the homebrew channel
    But I would like to use the full channel for this USB Loader GX
    I have done all the stuff in the complete softmod guide
    https://sites.google.com/site/completesg/home

    I have try to install the channel manually
    I have try to install the fowarder channel manually
    I have try the Windows automatic installer

    The installation always seem to work (which mean that a new icon appear on the wii menu) but when I click on this menu nothing happen and then I am redirected to the wii menu

    I am running a wii that is hard and soft moded
    I am trying with USB Loader GX v 3.0 r1239
    I am using the wii software 4.3U

    I have read that I should install the iOS58 but they say it came with the Wii OS version 4.3 so I don't think I need to install it.

    Do you have any advice on how to solve this problem

    Thank you very much for your help
     
  2. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,276
    823
    Mar 2, 2015
    United States
    The full channel for USB Loader GX is no longer maintained. Use the latest forwarder channel for your console (there is a Wii and vWii one) and the latest version of the the dol loader.
    If you installed the full channel (UNLR) then uninstall it. Just use the UNEO forwarder. They are both in the first post of the GX support thread.

    You don't need to do anything to IOS58 to get it to load but you do need a custom IOS installed in slot 249 in order to boot Wii games.
     
  3. fadafwet
    OP

    fadafwet Newbie

    Newcomer
    4
    0
    May 22, 2015
    Canada
  4. fadafwet
    OP

    fadafwet Newbie

    Newcomer
    4
    0
    May 22, 2015
    Canada
    Ok I have downloaded these 2 files from this topic :
    http://gbatemp.net/threads/usb-loader-gx.149922/

    Download the dols only (r1239)

    DOWNLOAD Wii Forwarder only

    and it does the same thing
    the usb loader gx seem to work from the homebrew channel but when I start the fowarder icon, I have a black screen then it refresh and I go back to the Wii menu

    Can you tell me what more do I need to make it work
    Do I need to install another ios, do I need to use another wad manager to install the fowarder
    Is there any think I can check


    I have a question under the Fowarder link it says this " Targets: device:/apps/usbloader_gx/boot.dol and device:/apps/usbloadergx/boot.dol"
    I copy the folder called usbloader_gx but there is no folder called usbloadergx in the apps folder. Is it suppose to have one

    Thank you for your help
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    You probably miss IOS58 (even if you "should" already have it if you are on 4.3x)
    you need to install it to use channels.

    run this from HBC : http://wiibrew.org/wiki/IOS58_Installer

    After installing it, you should re-install the homebrew channel to use IOS58 too.
    You can check your current used IOS for HBC in HBC's home menu->top-right of the screen. (it's probably IOS61 right now)

    after installing IOS58, run hackmii installer again (launch it from HBC, no need to use a game disc again to run an exploit) and select install HBC. it will re-install it and use IOS58 now.


    Using IOS58 for HBC has the advantage to allow USB 2.0 Access without cIOS.
    The forwarder use IOS58 to mount USB drive too, etc.

    ****
    if your HBC is already running on IOS58 then it means the IOS is installed and should be good (or else HBC would be upside down).
    You can try to reinstall IOS58 even if you already have it. but the installer from the link above is not installing the latest version.
    I'll explain more if you already have IOS58.
     
    GreyWolf and dimmidice like this.
  6. fadafwet
    OP

    fadafwet Newbie

    Newcomer
    4
    0
    May 22, 2015
    Canada
    you are right, I have the homebrew channel v1.1.2 running on iOS61
    After following your instruction homebrew channel is now running on iOS58 v24.31
    And the fowarder is launching with success

    Thank you very much for your help

    I have a couple of question if you don't mind
    Can you tell how to run hackmii from the homebrew channel ? I ran it using the letter bomb exploit again (this is the only way I know how to run it)

    you said that the link above for iOS58 is not installing the latest version, do I need to get it update to the latest version ? if so where can I find it ?

    In this article
    http://wiibrew.org/wiki/IOS58_Installer
    they say that iOS58 is included in Wii Menu 4.3. Since I needed to install it to make it work is this mean that it's not true that it's included in 4.3 ?

    Thanks again
     
  7. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    I'm happy for you, my explanation was enough for you to fix it :)

    just put the boot.elf on a folder, like any other homebrew.
    /apps/hackmii installer/boot.elf
    HBC should list all boot.elf and boot.dol files.


    yes, it should have been installed in your 4.3
    but it depends how you updated to 4.3.
    if you used a disc or network update, then you should have it.
    if you use a homebrew/hack/softmod to install 4.3 then you probably updated the system menu version only, not the other files usually installed when updating the console.