USB gecko Com port not found

Discussion in 'Wii - Hardware, Devices and Utilities' started by Cyan, Apr 21, 2010.

  1. Cyan
    OP

    Cyan GBATemp's lurking knight

    Global Moderator
    18,557
    8,908
    Oct 27, 2002
    France
    Engine room, learning
    I just received my USBgecko, but I can't make it working, I don't know if I'm missing something.


    I'm on WinXP SP2.
    After first connectinon, it asked for the driver, I installed the one provided by the Gecko driverCD
    All went good. (though, I see it's outdated, drivers are from 2007. and now it refuse to install the latest driver found on ftdichip.com).

    Then I run Geckoreader, and it can't detect the Com port automatically, so I tried some numbers randomly.
    Only COM1 is working and I get this :

    Warning: Spoilers inside!

    And then nothing else.
    I tried running few Wii application (like sneek), but I got no output in this window.
    Port 1 is obviously not the correct port.

    HBC is detecting the gecko correctly (the icon is highlighted).
    Windows is showing "USB Serial Converter" in the device manager when I connect it.
    So, is checked the VCP website driver, in the installation guide (pdf) (page 11, fig 2.13) they show the device manager with the USB/COMx port.

    I don't have any com port next to USB Serial Converter [​IMG]
    [​IMG]



    Did I miss a step ?
    Do I need to install anything else ?
    Do I need to uninstall the drivers and .inf manually ?
    Note : I tried rebooting, it didn't help.
     
  2. giantpune

    giantpune GBAtemp Addict

    Member
    2,860
    122
    Apr 10, 2009
    United States
    find the usb gecko in the device manager.
    right click->properties
    advanced
    check the little box
    click ok a few times
    unplug the gecko
    plug it back in
    let the CD install something else
    COM shit works

    all that was in a pdf on my usb gecko CD
     
  3. Cyan
    OP

    Cyan GBATemp's lurking knight

    Global Moderator
    18,557
    8,908
    Oct 27, 2002
    France
    Engine room, learning
    I checked again the manual.pdf, it's not specified.
    It ends right after "new device ready to use" [​IMG]

    I wasn't sure if I had to check that box in the device manager.
    I'll test it after my work.
    Thank you.
     
  4. matsurisan

    matsurisan Member

    Newcomer
    33
    0
    Aug 18, 2009
    Where did you get the usb gecko, btw?

    They are getting quite rare and hard to find nowadays.
     
  5. Cyan
    OP

    Cyan GBATemp's lurking knight

    Global Moderator
    18,557
    8,908
    Oct 27, 2002
    France
    Engine room, learning
    I bought it on a French website using a system to meet sellers and buyers for second handing thing.
    Though, there are also professional sellers with new (not used) stuffs.
    I think I had the chance to find one, but the manual.pdf and drivers seems outdated [​IMG] (18 oct 2007).
    I hope it will work fine.


    Edit :
    I tried the VCP checkbox, and it installed the new driver.
    The COM3 is now available in the Com list at the bottom.

    When I run Geckoreader, it still can't detect the Com port automatically.
    Inputting it manually doesn't always work fine, the reader terminate.
    I have to unplug the usb and plug it back right before running geckoreader.

    Then, I find the logging is buggy. it doesn't log everything on the file and stop few lines from the start instead of complete log to the bottom.
    It adds a lot of NULL characters too.

    except these problems, I got it working [​IMG]
    I could debug my problem with sneek2+di (but found another one >_