upgrading from 3.2E to 4.0E

Discussion in 'Wii - Hacking' started by Benjay, Jun 19, 2009.

Jun 19, 2009

upgrading from 3.2E to 4.0E by Benjay at 9:07 AM (1,272 Views / 0 Likes) 7 replies

  1. Benjay
    OP

    Member Benjay Hardstyle Addict

    Joined:
    May 25, 2009
    Messages:
    898
    Location:
    Amiens
    Country:
    France
    Hi everybody !!

    i have an old wii (from the launch day ^^) , with a wiikey (1.9S) , and running under 3.2E with starfall and cIOS rev12.
    i also have installed bootmii as boot2. (and made a nand backup)
    Everything is running fine (Wiiflow , usb loader GX etc...) , but yesterday i started to deal with mymenu and cSM.
    And i found this amazing cSM called darkwii , so i installed it on my wii , so beautiful.

    BUT , the 3.2 version of DarkWii is not a "full" cSM , i mean it changes only the "main" page , while settings and other pages stay white.

    I've seen that there is a full version of DarkWii , but only for 4.0 wii.

    So since i think 4.0 is no more a problem for homebrews , could anyone tell me how to update to official 4.0 with the less loss possible ? (and the easiest way too , i'm lazy ^^)
    i mean , without having to run things through bannerbomb etc... , since HBC is already on my wii.
    and what must i install to prevent further updates once i'm on 4.0 etc etc......

    And i talk about a REAL 4.0 update , not the Waninkoko's one [​IMG]

    Is it possible to do that ? what way ?

    thx.
     
  2. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    Why do you want to do a real 4.0 update instead of waninkoko's? It accomplishes the same thing but you'd kinda lose more with the official one.

    http://gbatemp.net/index.php?showtopic=144835

    Basically from where you're at, do step 4 and 5 of the online guide and you're done.
     
  3. Base

    Newcomer Base Advanced Member

    Joined:
    Mar 25, 2008
    Messages:
    99
    Country:
    Australia
    Yeah, I would also suggest to just do what the guide above says.
     
  4. Benjay
    OP

    Member Benjay Hardstyle Addict

    Joined:
    May 25, 2009
    Messages:
    898
    Location:
    Amiens
    Country:
    France
    Thx for infos [​IMG]

    Well i wanted an official update because i red somewhere that waninkoko's 4.0 was not a good thing.
    But after reading some pages of this guide (i was reading it while waiting for your answers ^^) , i changed my mind.

    It seems to work flawlessly , so i'm gonna do with waninkoko's 4.0 [​IMG]

    Thanks again for your advices.

    EDIT : should i uninstall Starfall first (update block is activated) ? and i'm i obliged to install preloader if i already have bootmii installed ?
     
  5. Base

    Newcomer Base Advanced Member

    Joined:
    Mar 25, 2008
    Messages:
    99
    Country:
    Australia
    Yeah, just uninstall Starfall. Thats what I did anyway. And yeah your going to have to install Preloader if you still want to run backup disks through the disc channel. Also it doesn't hurt to have Preloader AND Bootmii, just means you gotta go through a bit more until you get to the Wii menu. [​IMG]
     
  6. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    Well he has a mod chip so he doesn't need preloader for backups right?. But yes just uninstall starfall as I don't think it works on 4.0 anyways, but if you still want the hacks you can get preloader just for that or you can use startpatch for 4.0 which will just be the hacks without the whole moving of system menu business.

    But yea preloader and bootmii can both be installed and both can be set to autoboot things so it doesn't really add too much more to any startup time I think. But I'd suggest just going with startpatch anyways if you just want the hacks for like update blocking and stuff again.
     
  7. Benjay
    OP

    Member Benjay Hardstyle Addict

    Joined:
    May 25, 2009
    Messages:
    898
    Location:
    Amiens
    Country:
    France
    ok , thank you all.

    i think i'll stay with bootmii only , cause i have a chip , so no problem to read backup from disc channel , and for the moment i just keep on playing games from my HDD , so no update.
     
  8. Lindfalas

    Newcomer Lindfalas Member

    Joined:
    Feb 26, 2009
    Messages:
    33
    Country:
    Sweden
    I´ve done about 20 Wii from diffrent version to 4.0E. I never had any problem with that.
    I do upgrade from Nintendo and do some other things to get all work. Like the new banner bomb to install brewchanel and stuff.
    Its easy and it work like a charm.
    If you are not on 4.0 then you should upgrade. use nintendo upgrade, for it works.
    Dont see the point to use other upgrade stuff.
    I can play any game I get my hands on.

    Greetz
     

Share This Page