updating for pokemanz

Discussion in '3DS - Flashcards & Custom Firmwares' started by zael91, Oct 16, 2013.

  1. zael91
    OP

    zael91 Member

    Newcomer
    11
    3
    May 19, 2013
    Senegal
    Sry if question has been asked in the forum.

    I cant wait for gateway to implement support for 6.x firmware. I NEED MY POKEMANZ.
    Still playing BW2 but once im done i want to jump straight to x and y. 2 questions.

    1. If im not mistaken x/y comes with firmware 6.1 right? So that means im able to still play on my dstwo?

    2. Can you still go online in game even though the firmware is not up to date or will they force the update in-game to access online features.

    Sphanks you.
     
  2. Bonny

    Bonny GBAtemp Advanced Fan

    Member
    616
    104
    Dec 8, 2008
    Germany
    Bavaria
    :rofl: ...

    Yes.

    No.

    No. DS TWO can't play any 3DS rom, only DS games... and Gateway is not online compatible at all.

    Are you sure you own an 3DS? Or are you trying to play Pokemon X/Y on your DS with your DS TWO? :rofl2:
     
    kyogre123 likes this.
  3. zael91
    OP

    zael91 Member

    Newcomer
    11
    3
    May 19, 2013
    Senegal
    i have a 3ds, and a dstwo. I want to update to play x/y but i still want support for dstwo cause there are a few other ds games that i still havent tried yet which is why i asked if its still possible to go online on x/y without having up to date firmware on the console. I KNOW DS TWO DOES NOT PLAY 3DS GAMES.

    Jeez, im not dumb
     
    insidexdeath, NEP and Sicklyboy like this.
  4. Sicklyboy

    Sicklyboy Resident Mechanical Keyboard Addict

    Global Moderator
    5,736
    4,737
    Jul 15, 2009
    United States
    [̲̅$̲̅(̲̅ ͡° ͜ʖ ͡°̲̅)̲̅$̲̅]
    :sleep: let's bring some actual sense to this discussion.

    Provided you update your DSTWO beforehand, you won't have a problem using it. DSTWO supports up to the current firmware, so just make sure that you flash the new firmware to it before you update your 3DS.

    If I am not mistaken, Pokemon WILL force you to update to the newest 3DS firmware in order to play online. The DSTWO does support it still, like I said, however.
     
    NEP, zael91 and Vengenceonu like this.
  5. zael91
    OP

    zael91 Member

    Newcomer
    11
    3
    May 19, 2013
    Senegal
    Sicklyboy
    Oh thank you very much! Finally a proper answer.
    I wonder why some people would think that anyone asking a question is stupid enough to not know at least abit about what they're asking.

    Ok basically, my 3ds is on 6.1.0-12U and i updated my dstwo way back when 6.1 was the latest firmware, i just checked and they had an update to support 6.3 firmware on dstwo.
    So, just to be sure. I'll just update my dstwo to support the current latest firmware (6.3)

    What firmware does pokemon x/y comes with? Is it 6.1 or 6.3? If its 6.1, it means that i wont have to update my 3ds's firmware to play it right?

    Asked a friend who just bought a 3dsxl that the game update that came with pokemon was 6.1 which is also confirmed in a video in one of the other threads i saw.
    What i really want to know is if i choose to go online would it force another update to 6.3?
     
  6. how_do_i_do_that

    how_do_i_do_that Blue Wizard is about to die.

    Member
    4,952
    270
    May 16, 2008
    Antarctica
    You have insufficient posts to view user location.
    The use of the pokemon bank will likely come in the form of a DLC, that requires a trip to the eShop. It was said that the pokemon bank will not be available until closer to christmas.
     
    NEP and zael91 like this.
  7. Sicklyboy

    Sicklyboy Resident Mechanical Keyboard Addict

    Global Moderator
    5,736
    4,737
    Jul 15, 2009
    United States
    [̲̅$̲̅(̲̅ ͡° ͜ʖ ͡°̲̅)̲̅$̲̅]
    Yep. Go ahead and update the DSTWO and you'll be good for any firmware up to and including 6.3.

    As for what firmware it ships with/requires, I'm not positive, but I do think I recall hearing it was 6.1. Online game play goes through Nintendo's online services though, and since their updates usually have a few anti-hack/cheat components in them, they require the newest update to create the best shot at security and fairness. I don't know of any game that doesn't require the newest update to go online, so I'd say it's safe to assume Pokemon does too. Edit - just to make sure you understand this point, trying to go online will not force an update, it will prompt one, which you can deny, at the cost of still not being able to use the online services.

    I've got my 3DS on 6.3 (and I update when an update is available) because it was already too updated to use the Gateway, and buying games for it doesn't really bother me. I've both gone online with Pokemon Y and I've used my DSTWO today, so that's definitely not an issue. The only issue is that the further you update, the further you put your chances of being able to use the Gateway on it again.

    Considering that, if Pokemon is a must for you, I'd say use the cartridge to update to whatever update it requires, then try to go online. If you can, you're golden, if not then you probably ought to just update again anyway.

    Your other best case scenario (aside from the cost...) would to be to try to find another 3DS in a retail store that was manufactured in 2012 (says so on the box). Just ask the employee to check. Ones from 2012 almost all have FW 4.5 on it, so then you get to choose whether you want to use an old system for the Gateway or a new system for it, and then you can use the other system for games that require a newer firmware that aren't compatible with the Gateway. Again though, that's not exactly cheap or feasible for most people.

    Edit 2 - also if you're asking about needing/not needing to update because of a poor internet connection (though I would question your ability to take the game online at that point), know that the cartridge holds the minimum required firmware update in order to play it. Any update needed to play the game offline will be shipped on the game cartridge and installed if your system does not have said update.
     
    zael91 likes this.
  8. zael91
    OP

    zael91 Member

    Newcomer
    11
    3
    May 19, 2013
    Senegal
    how_do_i_do_that : thanks for the info but i dont think i'm really interested in the pokemon bank so eshop accessibility-wise, im all good.

    Sicklyboy : Come to think of it, i've pretty much played and bought all the games i've wanted to play on the 3ds (SMT4 and FireEmblem) and like you said you updated yours to the latest firmware because you felt that your system was too updated to use the Gateway and i think i'll do the same too. Since the 3ds isnt my main source of entertainment i guess i could live with not being able to play all the games in the 3ds library. Maybe in the future Gateway will have support for current up to date firmwares but until then, it doesnt really bother me (its just if you could save a couple of bucks with a Gateway then why not yknow? haha) Thanks again dude :)
     
  9. Ankoku

    Ankoku Member

    Newcomer
    39
    4
    Apr 25, 2010
    Malaysia
    I'm more interested in how Gateway users are going get that event Torchic, provided if the Gateway team fixes the game to work on the cart.
    As users mentioned about not being able to get online and all, or will it work ala B/W/2 style.
     
  10. Arnold0

    Arnold0 GBAtemp Fan

    Member
    386
    114
    Oct 1, 2011
    France
    Vire, France
    My friend bought the 3DS xl collector edition (so it's on 6.1) and updating to 6.3 was not needed for him to play pokemon Y online.
     
    zael91 likes this.
  11. PityOnU

    PityOnU GBAtemp Advanced Fan

    Member
    908
    327
    Jul 5, 2012
    United States
    With the influx of younger members posting for the first time after playing Pokemon X/Y, most of the usual forum residents are at the point where they assume any new members posting about Pokemon are absolutely retarded. They are usually right.

    It's the way of things. Sorry about that.
     
  12. zael91
    OP

    zael91 Member

    Newcomer
    11
    3
    May 19, 2013
    Senegal

    Just got it yesterday and im on 6.1 and not needing an update to 6.3 to have access to online features ^^


    Its okay, you dont have to apologize for him. :)
     
  13. kyogre123

    kyogre123 Mexican Pride

    Member
    2,919
    1,261
    Sep 23, 2013
    Mexico
    I don't understand why you are so afraid of updating if you just gave up from using Gateway. DS TWO works on 6.3 and I doubt Nintendo will patch DS Flashcarts at this point, they are pretty much putting their efforts on combating piracy of 3DS games.
    If I were you (thank goodness I still have my 3DS on 4.5) I would update to the latest to enjoy whatever demos are currently available on the eShop.
     
  14. zael91
    OP

    zael91 Member

    Newcomer
    11
    3
    May 19, 2013
    Senegal
    I understand what you're saying, but when i posted that i didnt know DSTwo had support up to 6.3 . I guess i already explained why i asked if going online on x/y would require an update (cause at that time i have yet to make up my mine if i wanted to wait for GW to have support for 6.1).

    Right now, playing on 6.1 is fine since its possible to go online without an update so i might as well stick on 6.1 unless the only way to go online is to update. Yeah, that would mean that i wont be able to play any demos of the latest games but i dont see a point in playing a game that has only 10-15 mins of content, even if the game is something that im really interested in.
     
  15. kyogre123

    kyogre123 Mexican Pride

    Member
    2,919
    1,261
    Sep 23, 2013
    Mexico
    Then you missed the whole point of my post.
     
  16. shinyquagsire23

    shinyquagsire23 SALT/Sm4sh Leak Guy

    Member
    1,966
    3,249
    Nov 18, 2012
    United States
    Las Vegas
    I still find it amazing that the DSTwo has lasted through every one of Nintendo's updates. Completely amazing.