Update Switch to a certain firmware?

Discussion in 'Switch - Hacking & Homebrew' started by PeopleRaging, Apr 23, 2017.

  1. PeopleRaging
    OP

    PeopleRaging Newbie

    Newcomer
    1
    0
    Apr 23, 2017
    Canada
    i just bought my switch today and it came with version 1.0.0 is there any way to update it to 2.0?
     
  2. ZoneBlaze

    ZoneBlaze GBAtemp Regular

    Member
    135
    45
    Aug 14, 2014
    United States
    Not at the moment. Probably won't be for about a year. Who knows.
     
  3. Soluble

    Soluble Member

    Newcomer
    30
    7
    Mar 12, 2017
    As above, currently no. May be possible in the future but I wouldnt wait around for it. Update and stay wherever you are would be my advice.
     
  4. RemixDeluxe

    RemixDeluxe GBAtemp Psycho!

    Member
    4,584
    1,357
    Nov 23, 2010
    United States
    I'm at 2.1 myself and I'm not sure if I should stay or just move up to 2.2. Always best to stay as low as possible until the community deems it safe. Not like the eShop doesn't work without updating where that was the case with 3DS and Wii U.
     
  5. sj33

    sj33 GBAtemp Addict

    Member
    2,702
    1,710
    Oct 22, 2013
    Japan
    I wouldn't worry about avoiding updating just yet, it's too early. More webkit exploits will appear, the existing exploits are really just useful for devs looking for lower level exploits.

    I remember all those people who kept their Wii U on firmware 2.0.x (or similar) because of the webkit exploit, then the kernal exploit landed on a much newer firmware with a new webkit exploit.
     
    RemixDeluxe likes this.
  6. RemixDeluxe

    RemixDeluxe GBAtemp Psycho!

    Member
    4,584
    1,357
    Nov 23, 2010
    United States
    Its still in good practice to have protection now so theres no regrets later down the road. But I get what your saying, its too early in the game.
     
  7. zoogie

    zoogie simple pimp tool

    Member
    6,237
    7,896
    Nov 30, 2014
    United States
    Was it ever determined if lego undercover had the 2.0 update? (by booting it on a 1.0 system)
     
  8. sj33

    sj33 GBAtemp Addict

    Member
    2,702
    1,710
    Oct 22, 2013
    Japan
    Well, are people really buying Switches with no intention of playing any Switch games for the next 2 years? Because that's the situation people keeping their Switch consoles on 1.0.0/2.0.0 will find themselves in. Whatever future exploits appear will not require launch period firmware, there's no precident for this.

    I have my PS4 kept on 4.07, but there comes a point where you're missing out on so many games that ownership of that console becomes pointless.
     
    Last edited by sj33, Apr 23, 2017
    PaBo and RemixDeluxe like this.
  9. Sketchy1

    Sketchy1 gbatemp's shadiest warez dealer

    Member
    1,492
    370
    Aug 9, 2016
    United States
    Unless you dropped about $600 for 2 insted of 1
     
  10. badpix11

    badpix11 Member

    Newcomer
    12
    6
    Mar 14, 2017
    Serbia, Republic of
    Fairy World
    Last edited by badpix11, Apr 25, 2017