Unable to request a particular page, "Cannot assign requested address"

Discussion in 'Computer Programming, Emulation, and Game Modding' started by raing3, Dec 8, 2012.

  1. raing3
    OP

    Member raing3 CNET_Richard

    Joined:
    Apr 2, 2009
    Messages:
    529
    Location:
    Australia
    Country:
    Australia
    After spending all day yesterday trying to resolve an issue requesting a particular page I've decided it's time to reach out for some help.

    Details:
    • Attempting to request the page through PHP/cURL.
    • PHP script works correctly when making the request when uploaded to another server.
    • PHP script is able to request other URLs through cURL on my machine.
    • I only have one internet connection at home which is via tethering my phone.
      I have attempted tethering via both Wi-Fi and USB.
    • I have attempted restarting both the PC and the phone multiple times.
    • It seems to fail intermittently on other requests, I noticed it failed randomly on AJAX requests on my ISPs website, so far I've only obvserved the issue failing on POSTs not GETs.
    • Trying to connect to and use various other web sites works fine.
    • The error content seems to be spat out by Squid on the ISPs side since it is the same consistent error message across the places I have encountered it.
    • The arseholes at Optus (my ISP) technical support say they can't help me because it must be a browser issue because I was able to load the Optus home page on my mobile.
    • Tried reflashing my phone in case it happened to be caching some broken request and serving it to the PC.
    So... in conclusion the issue seems to be related to my ISP as that seems like the only suitable explanation from my tests.

    [​IMG]

    PHP script download: http:///raing3.gshi.org/test/test.zip

    Any help to resolve or workaround the issue would be greatly appreciated because this single stupid issue is driving me nuts.

    Thanks!!!!!

    EDIT: More screenshots:

    [​IMG] (randomly happening when trying to update this post)
    [​IMG] (randomly happening on the Optus website)
     
  2. raing3
    OP

    Member raing3 CNET_Richard

    Joined:
    Apr 2, 2009
    Messages:
    529
    Location:
    Australia
    Country:
    Australia
    The issue was indeed a problem with the ISP: http://www.facebook.com/pages/Hey-O...nnot-assign-requested-address/400790446667146.

    Fortunately it seems like they have finally fixed it, keeping my calm while trying to talk with their "technical support" staff was quite a challenge though. I contacted them every night this week trying to get answers and advise them it was a fault on their end, every time I got a different operator which meant going through the problem and then having them giving me suggestions which I had already tried.

    Finally on Wednesday I got through to someone who was actually very helpful and admitted it was likely to be an issue on their end and finally today it looks like it has been fixed.

    Doesn't it just grind your gears when trying to talk to a technical support person and you've already spent hours trying to resolve the issue, provided them a massive amount of information on what you had tried only for them to tell you to rinse and repeat? RAGE!!!!
     
  3. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Takes too many calls to get elevated past script-based support, yeah.
     

Share This Page