Trouble with usb loader GX

Discussion in 'Wii - Backup Loaders' started by Whompy, Dec 6, 2015.

  1. Whompy
    OP

    Whompy Newbie

    Newcomer
    4
    0
    Dec 6, 2015
    United States
    So I've tried following numerous recommendations in response to other threads on similar issues, but so far no luck.
    I will start by saying CFG loader work perfectly fine, wii games load right away no issue.

    But I would like to use usbloader GX instead because of certain features and its UI/style.

    When I try loading a wii game in GX, the screen goes black and then I'm taken back to the HBC. (wiiflow has similar results) There is also no banner when selecting any wii game in GX. Gamecube games load and play fine.
    My backups I believe are labeled correctly, they all show up in the loader. (Animal Crossing Wii [RUUP01] for folder, RUUP01.wbfs for file). I've ensured that GX is using 249 (also tried 250). I've tried both usb ports, Ive tried reformatting the drive and starting over, both with fat32 and ntfs, can always see the games, but can never load them :/

    I've tried numerous version of GX, and different combinations of d2x cIOS in 249 and 250 with no luck.
    I'm about at my wits end D:
    Any advice would be appreciated <3
    syscheck
    Warning: Spoilers inside!
     
    Last edited by Whompy, Dec 6, 2015
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,698
    8,993
    Oct 27, 2002
    France
    Engine room, learning
    no banner = bad dump of the game.
    bad dump, corrupted ISO, etc.

    redump the game, find a new iso, don't think that "it's not bad because it used to work", it can be bad now.

    your current slot249 is now good for all games. (base57 has more compatibility than base56, and v8 final is fine, you don't need v10)
     
  3. Whompy
    OP

    Whompy Newbie

    Newcomer
    4
    0
    Dec 6, 2015
    United States
    I can try making another copy of a few when i get home., but I have over 100 Wii games on the HD, and they all do the same thing in Gx, but load fine in cfg loader for some reason. I feel like I'm missing something.

    Edit: banner works in cf loader, just not in other
    Another edit: this is a freshly modded Wii, so its not that the games used to work,, just that they work in CFG loader but won't work in any version of USB loader GX
     
    Last edited by Whompy, Dec 6, 2015
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,698
    8,993
    Oct 27, 2002
    France
    Engine room, learning
    all the games are not working?
    if it reboot when launching a game it means the game data couldn't be loaded, it's either wrong cIOS (bad slot? bad install?), bad ISO (but all games? that's not likely), or HDD not detected or not compatible.

    Games could load fine, but have errors later in game.
    If CFG has banner cache, then it could display the banner because it's loaded from SD or USB, but not from the ISO.
    I would recommend checking the game's checksum even if it works on cfg.
    use wiiBackupManager and select a game then the Sha1 option.


    verify you are correctly using slot249 in the loader's settings or the game settings.
    maybe reinstall d2x, just in case it's a bad install (it happens). but it shouldn't work with CFG if it's the cIOS issue.
     
  5. Whompy
    OP

    Whompy Newbie

    Newcomer
    4
    0
    Dec 6, 2015
    United States
    Ya, this doesn't make sense. I tried GX first immediately after putting all the games on HD and nothing works, then tried cfg immediately after that and they all work, so there wasn't any banner cache yet. Is it possible the HD works with cfg but not with Gx? Or is it entirely cios dependent.
    I'll try verifying some games tonight
     
    Last edited by Whompy, Dec 6, 2015
  6. Whompy
    OP

    Whompy Newbie

    Newcomer
    4
    0
    Dec 6, 2015
    United States
    Welp, after reformatting the hdd again and copying just a couple games at a time, I finally got the GX loader working :D. I still don't understand why CFG worked when GX wouldnt, but oh well. I didn't change anything else, though i did check some game checksums, no issues. But its workin now :) thank Cyan for the help!
     
  7. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,698
    8,993
    Oct 27, 2002
    France
    Engine room, learning
    If the drive wasn't compatible with USBGX you wouldn't see the games in the loader or it wouldn't detect the drive at launch (HDD detection count down to 0 and load channel mode instead).
    If it was cIOS, launching game from CFG would not work either.

    glad it works now
    too bad we won't know what the issue really was.