to update or not to update is the question

Discussion in 'Wii U - Hacking & Backup Loaders' started by vetteguy112233, Jan 6, 2014.

  1. vetteguy112233
    OP

    vetteguy112233 Newbie

    Newcomer
    1
    0
    Jan 5, 2014
    United States
    We got our kids a new wii u for Xmas and it's been a lot of fun. I also have a wii that I modded 5ish years ago and it's been the best system I've ever owned. Keeping games on a hdd, with 3 boys has been so nice. Currently my U is on version 3.0.1U and I understand how important it is not to update the system if you want mods to work. I know there isn't currently any U mods like storing games on a hdd, but I'm afraid of updating it and ruining any potential of this option if it's ever cracked in the future. I would like to try the new wii u sports, but have to update to download it.

    Would you guys keep it on the version it is now or update and hope it's able to be modded in the future?
     
  2. Taleweaver

    Taleweaver Storywriter

    Member
    5,606
    1,644
    Dec 23, 2009
    Belgium
    Belgium
    I'd update. Hacks are usually based on found exploits, but with no released hacks, it's harder for nintendo to find and fix them (it's possible, certainly, but not as likely).

    EDIT: nevermind. Bad advice, as it turns out. :unsure:
     
  3. crediar

    crediar Possiblenator

    Member
    338
    1,308
    Mar 5, 2006
    This is a very bad advise, you should never update until you have or want to.

    On the 3DS many kernel exploits very fixed without them ever being released and Nintendo just updated the browser on the Wii U which is the main entry point for exploits.
     
  4. Huntereb

    Huntereb GBAtemp Addict

    Member
    2,748
    949
    Sep 1, 2013
    United States

    People were told not to upgrade past 4.5 when the DS Profile exploit was found, but there was no purpose to stay on 4.5, so people updated. They were warned though.
     
  5. SirByte

    SirByte GBAtemp Fan

    Member
    494
    191
    Dec 30, 2012
    Canada
    A browser bug was fixed in 4.0.0 which just might be needed at one point to install the homebrew channel (even if the browser bug is only used to determine your drive encryption key).

    All my games run fine with 3.1.0 so that's where I am staying.

    Note: "just might" indicates a non-zero probability, nothing more, nothing less.
     
  6. fatsquirrel

    fatsquirrel GBAtemp Advanced Maniac

    Member
    1,828
    1,296
    Nov 11, 2013
    Just a question. Do all wii U s ship with 310? Because Im buying a new one and Id like to keep my chances for a hack.
     
  7. kat13

    kat13 Newbie

    Newcomer
    8
    0
    Jan 8, 2014
    Serbia, Republic of
    Hi
    The same problem as have vetteguy112233 :) Having the WiiU with OFW 2.1.0, factory. Playing Zombie, Nintendoland & some others normally.
    Getting Mario 3d World as a present on holidays and... cant playing :) needing system update but do not wanting to do it - waiting a "miracle" :)
    Badly that we not have an opportunty to update the system NOT to last possible FW - but sequentially. Like xbox or ps3 - disk content have a FW to complete minimal requirement of the game. If were's some guidance from Scene.. (sigh)
     
  8. spiderben25

    spiderben25 Advanced Member

    Newcomer
    84
    7
    Aug 29, 2007
    France
    East of the France

    Just got mine today (EU pack with NSMB), it was 4.0E
     
  9. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    5,863
    879
    Nov 6, 2002
    Portugal
    Proud to be Portuguese but I am in USA.
    What firmware is the best for Wii U not to update to be safe? I do not have one.. NOT YET.
     
  10. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    5,863
    879
    Nov 6, 2002
    Portugal
    Proud to be Portuguese but I am in USA.
    Bump ?? :D
     
  11. fatsquirrel

    fatsquirrel GBAtemp Advanced Maniac

    Member
    1,828
    1,296
    Nov 11, 2013
    Lower than 4.0 Id assume...just assume though. Noone knows at this point.
     
  12. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    5,863
    879
    Nov 6, 2002
    Portugal
    Proud to be Portuguese but I am in USA.
    Ahh, assume, huh ? So that's not a fact yet.. Jeez.

    Anybody know ?
     
  13. fatsquirrel

    fatsquirrel GBAtemp Advanced Maniac

    Member
    1,828
    1,296
    Nov 11, 2013
    You cant read can you?:unsure:
    I said nobody knows
     
    pelago likes this.
  14. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    5,863
    879
    Nov 6, 2002
    Portugal
    Proud to be Portuguese but I am in USA.
    I know. Can't I ask for a 2nd opinion ? :)
     
  15. Ray Lewis

    Ray Lewis Banned

    Banned
    1,518
    386
    Dec 30, 2012
    United States
    Browser bug is only used to get drive encryption key? Talking disc drive? Do you know more info or are you pulling that asserition out of your..."arm"? Lol