to patch or not to patch

Discussion in 'Wii - Hacking' started by cokeman118, Jan 15, 2009.

  1. cokeman118
    OP

    cokeman118 Advanced Member

    Newcomer
    59
    0
    Nov 2, 2008
    United States
    Ok, I haven't posted much on here but I have been reading a lot and trying to learn more about the backup loaders and whatnot, but I have a question. Not sure this has been answered yet or what, but haven't really been able to find an answer. I use the latest gamma loader, but have read that 1:1 backups should work fine with it. I'm pretty new at this so I made 4 1:1 backups: mario galaxy, metroid prime 3, guitar hero world tour, guitar hero aerosmith. All worked and are playable, then I tried MK: Armageddon. Of course I get to the controller screen and then it goes black. So I searched and it said to patch the game with IOS 249, which I did and the game works flawlessly. Anyway, my question is how do you know when to patch a game?? Is it basically trial and error to see if it works 1:1, and if not try patching to IOS 249?? Can I just patch any game with IOS 249 and will the chances of it working be greater than if I didn't? I'd like to know if there is an answer because I would really hate to constantly burn 2 discs to see if I can get it working. Then you have the compatibility threads, but it seems there are a lot of contradictory statements on if a game works or not.

    Also, why does a game that doesn't work 1:1 work with IOS 249?? What is this IOS doing to make it work vs. 1:1

    Thanks.

    sorry if these are noob questions, but it doesn't seem like I can find any answers to this.
     
  2. Jedis

    Jedis Advanced Member

    Newcomer
    69
    7
    Jan 10, 2009
    United States
    Not sure man... I'm using CIOSCORP and have yet to try MK:A. I wonder if it works without modifications with the CIOSCORP? If it does, maybe it's an easier route to go...
     
  3. Jizmo

    Jizmo GBAtemp Advanced Fan

    Member
    500
    0
    Oct 23, 2008
    United States
    The games that require patchintg to IOS249 for gamma do not need patched for CIOSCORP. However, remember that at this time only In Region games run from Disc Channel. Out of Region games you still have to use Gamma. So if you are running CIOSCORP and you have the wrong region game, your better off usually to Region Patch it than IOS Patch it. If you region patch it, it then shows up in Disc Channel and runs from there, meaning it doesn't need the IOS patch.

    So General Rule is... (doesn't apply 100% of the time)

    If your gonna use Gamma, IOS Patch when necessary. (NFS Undercover, MK Armagedden, etc.)
    If your gonna use CIOSCORP, Regioin Patch out of Region Games
     
  4. Tichinde925

    Tichinde925 Marth Ditto Money Match?

    Member
    1,096
    0
    Jul 14, 2008
    United States
    Warwick, Rhode Island
    My question is why doesnt Starfall automatically allow out of region games to be played with CIOSCORP? It blocks updates perfectly though.
     
  5. WalkerOfTheDay

    WalkerOfTheDay GBAtemp Advanced Fan

    Member
    848
    5
    Oct 10, 2008
    Netherlands
    I basically patch all my games to 249. I know it's not necessary, but in 99 of al cases it worked out great for me.
    (Except for Bully Scholarship. That one, I couldn't get to work, not the original, and not the 249.
    I have a NTSC version converted to PAL (I have a PAL Wii) but I cannot get it to work.
    Even with forcing PAL or NTSC...)
     
  6. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Bookmark this page:
    http://gbatemp.net/index.php?showtopic=123...p;#entry1639626

    If you have a game which is not listed there, but you can't get it to work, post it there. Please describe the issue you have then as precise as you can, or else i can't help you.

    I thought NFS Undercover doesn't need the IOS Version Patch.
     
  7. david432111

    david432111 GBAtemp Advanced Fan

    Member
    859
    0
    Jul 17, 2008
    Denmark
    It doesn't if you use the version of gamma with the 002 fix.
     
  8. spritefreak

    spritefreak GBAtemp Fan

    Member
    375
    0
    Jan 7, 2009
    United States
    I just want to be sure I understand everyone correctly. As long as I am use the gamma launcher, I do not need to patch or change the region on any game.
     
  9. Det1re

    Det1re det1re.de

    Member
    1,272
    1
    Oct 28, 2008
    Gambia, The
    Germany
    You're right, spritefreak. Because it's based on GeckOS.
     
  10. spritefreak

    spritefreak GBAtemp Fan

    Member
    375
    0
    Jan 7, 2009
    United States
    Well, I don't have GeckoOS, so does that matter? And as far as games not having to be patched or change the region, can I then play any game through the gamma loader without fear of bricking my Wii?
     
  11. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Gamma is a modified Gecko OS. Not all out of region games work fine with Gamma, you'll see when you have a game in black and white.
     
  12. spritefreak

    spritefreak GBAtemp Fan

    Member
    375
    0
    Jan 7, 2009
    United States
    And if I do have a game that does not work with Gamma, I may be able to change the configuration of the Gamma Launcher to make it work correct?
     
  13. david432111

    david432111 GBAtemp Advanced Fan

    Member
    859
    0
    Jul 17, 2008
    Denmark
    Yup by forcing it to a specific video mode, it's in the settings.