Homebrew Thinking out loud regarding Nintendo FW Updates ...

Darkuni

Well-Known Member
OP
Newcomer
Joined
Apr 13, 2006
Messages
52
Trophies
0
XP
284
Country
United States
I'm sure this has been explored by someone, but ...

We (meaning the hacking community) seem to have a really good handle on how content is delivered from Nintendo to the 3DS.

I recently nuked my kid's Pokemon 3DS XL trying to fart around with upgrades and downgrades (system reset might work - haven't tried it yet - but if it does, it will leave him with FW 11). Got me thinking...

Couldn't we SPOOF Nintendo's upgrade servers? I mean, if you upgrade right now - no matter what FW you're on, you get 11. What if we set up a server that we can redirect 3DSs to "update" - and it only delivers the "latest safe" firmware?

This would rock in my case - because even with this system reset, I could get 10.5 down which is still safe to hack.

Seems like this would be easy to spoof with all the knowledge the community has.

Thoughts? Am I crazy?
 
D

Deleted-379826

Guest
I'm sure this has been explored by someone, but ...

We (meaning the hacking community) seem to have a really good handle on how content is delivered from Nintendo to the 3DS.

I recently nuked my kid's Pokemon 3DS XL trying to fart around with upgrades and downgrades (system reset might work - haven't tried it yet - but if it does, it will leave him with FW 11). Got me thinking...

Couldn't we SPOOF Nintendo's upgrade servers? I mean, if you upgrade right now - no matter what FW you're on, you get 11. What if we set up a server that we can redirect 3DSs to "update" - and it only delivers the "latest safe" firmware?

This would rock in my case - because even with this system reset, I could get 10.5 down which is still safe to hack.

Seems like this would be easy to spoof with all the knowledge the community has.

Thoughts? Am I crazy?
I don't think that's how it works. As other people would say, "it would of been done already"!
 

Hayleia

Well-Known Member
Member
Joined
Feb 26, 2015
Messages
1,485
Trophies
0
XP
1,273
Country
France
What's your current firmware right now?

If you're below 9.2, I'd say you're not crazy. It would be better to just fiddle with internet settings then do a regular update to get to a clean 9.2 rather than doing "complicated" stuff involving browsers (that not everyone has if they updated with carts) or DS flashcarts (that not everyone has either).
If you're above 9.2, you have no reason to be willing to update anyway. Either you're on 11.0 and there is no update or you're not on 11.0 and what you want is a downgrade.

Now that's not even discussing the feasibility, no idea about that :P
 
  • Like
Reactions: Sonic Angel Knight

Darkuni

Well-Known Member
OP
Newcomer
Joined
Apr 13, 2006
Messages
52
Trophies
0
XP
284
Country
United States
The problem is more along the lines of - I have a brick. And aside from a hard mod, the only potential solution is to do the system reset - which boots to updating your system (which will leave it as 11).

The whole purpose of my dicking around with sysnand is because I could't register the NNID on a 9.2 system.

So my plan was to UPDATE to 10.x - get the NNID on sysnand, then downgrade back to 9.2. THEN clone to emunand and start over again.

Something failed along the way - thing won't boot - with or without an SD card.
 

TheKawaiiDesu

Ball of Kawaiiness
Member
Joined
Aug 23, 2015
Messages
1,436
Trophies
0
Location
Lowee
XP
1,590
Country
Korea, North
That's not possible, because the 3DS uses SSL / https to connect to Ninty's update servers iirc, which makes redirecting to another website pretty much impossible without having a kernel exploit. But if you have a kexploit, except in rare cases (updating a 8.1 JP N3DS to 9.2), you don't really need that to update.
 
Last edited by TheKawaiiDesu,

Darkuni

Well-Known Member
OP
Newcomer
Joined
Apr 13, 2006
Messages
52
Trophies
0
XP
284
Country
United States
That's not possible, because the 3DS uses SSL and https to connect to Ninty's update servers iirc, which makes redirecting to another website pretty much impossible without having a kernel exploit. But if you have a kexploit, except in rare cases (updating a 8.1 JP N3DS to 9.2), you don't really need that to update.

Yeah, that makes sense. I didn't think about SSL in the loop. Sigh ..

It was a nice dream while it lasted.
 

I_AM_L_FORCE

Unban me from Discord
Member
Joined
Feb 19, 2015
Messages
1,062
Trophies
0
Age
21
Location
London
XP
1,430
Country
United Kingdom
If this even WAS possible there'd be the issue of the .cia's being a lower ver than the one you're currently on, so the system wouldn't install the "update".

Why not edit the CIA you ask?

Well this would break the SIG patches and make it uninstallable anyway.
 
General chit-chat
Help Users
    DEMONGreninjaPG @ DEMONGreninjaPG: what yall doing