Hacking TegraRcmGUI sucessfuly injected payload -> Battery icon -> Black screen

CaueCarneiro

Member
OP
Newcomer
Joined
Feb 16, 2021
Messages
9
Trophies
0
Age
33
XP
25
Country
Brazil
Hello, sorry for another one of these. Out of nowhere I'm getting a black screen when trying to load into SX OS. I'm injecting the payload, seeing a battery icon on the top left, and then nothing, no nintendo switch name or logo appears. My TegraRcm log says:

No RCM device detected
RCM Device detected
Invoking TegraRcmSmash.exe with args : "C:\Users\caue-\OneDrive\Área de Trabalho\payload.bin"
TegraRcmSmash (32bit) 1.2.1-3 by rajkosto
Opened USB device path \\?\usb#vid_0955&pid_7321#5&16bdd27b&0&5#{aa0dbd45-3117-f331-5c49-76bf65225042}
RCM Device with id 4004FD0E000000180073306401101062 initialized successfully!
Uploading payload (mezzo size: 92, user size: 27748, total size: 93964, total padded size: 94208)...
Smashing the stack!
Smashed the stack with a 0x7000 byte SETUP request!
Payload successfully injected

I've tried using either SX OS 2.9.2 or 3.1.0 BETA, tried removing all files from my MicroSD, change the payload, nothing works. Payload is from sx xecuter com.

My serial number is XAJ40009496961. I also several similar treads but truly have no idea what to do, sorry to bother everyone with this but I would extremely grateful if anyone could help. Thanks!
 

CaueCarneiro

Member
OP
Newcomer
Joined
Feb 16, 2021
Messages
9
Trophies
0
Age
33
XP
25
Country
Brazil
I forgot to mention I do see SX OS screen, after that it shows the battery icon on the top left but then nothing happens
 

WiiMiiSwitch

RiiConnect24 STAN
Member
Joined
Dec 18, 2020
Messages
1,744
Trophies
1
Age
22
Location
Not Society
XP
3,775
Country
United States
Hello, sorry for another one of these. Out of nowhere I'm getting a black screen when trying to load into SX OS. I'm injecting the payload, seeing a battery icon on the top left, and then nothing, no nintendo switch name or logo appears. My TegraRcm log says:

No RCM device detected
RCM Device detected
Invoking TegraRcmSmash.exe with args : "C:\Users\caue-\OneDrive\Área de Trabalho\payload.bin"
TegraRcmSmash (32bit) 1.2.1-3 by rajkosto
Opened USB device path \\?\usb#vid_0955&pid_7321#5&16bdd27b&0&5#{aa0dbd45-3117-f331-5c49-76bf65225042}
RCM Device with id 4004FD0E000000180073306401101062 initialized successfully!
Uploading payload (mezzo size: 92, user size: 27748, total size: 93964, total padded size: 94208)...
Smashing the stack!
Smashed the stack with a 0x7000 byte SETUP request!
Payload successfully injected

I've tried using either SX OS 2.9.2 or 3.1.0 BETA, tried removing all files from my MicroSD, change the payload, nothing works. Payload is from sx xecuter com.

My serial number is XAJ40009496961. I also several similar treads but truly have no idea what to do, sorry to bother everyone with this but I would extremely grateful if anyone could help. Thanks!
Firmware please
 

WiiMiiSwitch

RiiConnect24 STAN
Member
Joined
Dec 18, 2020
Messages
1,744
Trophies
1
Age
22
Location
Not Society
XP
3,775
Country
United States
I'm sorry, is there a way for me to see which firmware even though I can only get to the SX OS home screen?

I don't remember the firmware but I'm sure it wasn't ver. 11.0.1 since my Switch's been on airplane mode and didn't update.
You must boot up ofw and see system update (don't press it) it will tell you your current firmware
 
  • Like
Reactions: CaueCarneiro

Wickedchew

Masks Works..Wear it!!
Member
Joined
Mar 19, 2016
Messages
184
Trophies
0
Age
36
XP
762
Country
United States
have u tried changing SD card,, i have a 400gb that wont boot to SX OS as well,,but try a 128gb and works fine..

im currently diskparting the 400gb,. and try reformatting again;
 
  • Like
Reactions: BigOnYa

CanIHazWarez

Well-Known Member
Member
Joined
Jan 21, 2016
Messages
339
Trophies
0
Age
30
XP
952
Country
United States
Do you have themes installed?
^Check this. I've even just had the dark theme on one of my nands and it caused a failure to boot.


If its showing a battery icon, then that just means it is out of battery.
OP, was your Switch undocked before you first experienced this problem? Your battery was possibly just drained. If your Switch has autoRCM, and you do not send a payload, it will just show a black screen when it boots. This black screen is indistinguishable from the Switch just being off. The system will not charge while on this black screen. When you plug in the system to charge it, the system tries to power on. However, since you're not injecting a payload, it just stays on the black screen. Since it can't charge on the black screen, the system does not get charged. The way to fix this is to plug in the system, hold down the power button for a good 10 seconds to turn it off (since it's on the black screen), and wait five minutes for it to charge. Then unplug it from the charger and turn the system on while injecting the payload. Once you have the system actually booted, you can put it back on the charger to let the battery charge the rest of the way.
If it doesn't work the first time, don't panic. You probably just turned the system ON whenever you held the power button instead of OFF. It's impossible to tell whether the system is on or off without injecting the payload. If it won't boot with the payload injected, it means the battery is still dead and to try charging it again. And if you're using something like an SX Pro dongle, make sure the dongle is charged as well (takes less than five seconds to charge it).
 
General chit-chat
Help Users
    Veho @ Veho: Who knows, maybe one exists among the billion obscure indie titles out there.