1. Silent_Gunner

    OP Silent_Gunner Crazy Cool Cyclops
    Banned

    Joined:
    Feb 16, 2017
    Messages:
    2,696
    Country:
    United States
    So, I've been out of the Switch hacking game for the better part of the year since this whole pandemic hit, and it seems like things have changed; no longer do you need Zadig, because apparently, TegraRCMGUI will install the driver for you?

    Well, anyways, after some very unsuccessful forays into using Linux (tl;dr - only use Linux if you don't value your free time), I decided to go back to Windows 10, and have been setting things back up and getting everything up and going. I tried to do the usual method from, like, a year ago ever since I last needed to use Zadig to get Windows to recognize the Switch so I could use TegraRCMGUI/TegraRCMSmash to boot into a payload (which, btw, you'd think there'd be a way to permanently softmod the Switch at this point, but whatever). When that didn't work, I went and deleted the libusbK.dll files from the System32 folder and the SysWOW64 folder, and also removed the APX driver from the Device Manager. I tried to reinstall the driver, but it wasn't sticking for whatever reason, as every time I closed the TegraRCMGUI program, it kept acting like the USB Driver was knocked out, and prompted me to install the APX driver. After that failed again, I figured I'd restart my PC and then try via this method...and it still doesn't work.

    So, what the fuck am I supposed to do here? Like I said, it's been a long time ever since I even booted up my Switch ever since this mess with COVID-19 happened and essentially made the portability my hacked Switch offers somewhat moot when I can just play the same games on my PC without the hassle of dealing with the closed ecosystem of a console that, IMHO, after 3 years of being on the market, you'd think someone would have figured out a way to permanently softmod this so you don't have to worry about having to go through all of this again because you don't feel like charging one device you barely use anyways due to circumstances out of your control that, upon the device inevitably losing all of its charge, will require a new uploading of the payload.

    EDIT: Just remembered that you're supposed to install the WCID Driver...but now it seems like the TegraRCMGUI takes a shit when trying to upload the payload to the Switch which is being recognized as being in RCM mode and crashes. I downloaded the latest version of hekate and Nyx, and it isn't changing how this is playing out.

    EDIT The Second Runner: Managed to get it to work...only for the Switch to say that its at 12%, and then act like it's got to turn off to preserve the battery... :(

    Alienware UFO, where are you!?
     
    Last edited by Silent_Gunner, Jul 14, 2020
  2. a7mag3ddon

    a7mag3ddon GBAtemp Regular
    Member

    Joined:
    Mar 17, 2013
    Messages:
    193
    Country:
    For me i couldnt be arsed with all that, spend very little money on a usb dongle to enable hack instead.

    SX ftw
     
  3. sudeki300

    sudeki300 GBAtemp Advanced Fan
    Member

    Joined:
    Nov 20, 2004
    Messages:
    788
    Country:
    you can send payload from a phone, to expect the device to be tethered softmodded just cause its been out for a while is a bit naive as it has nothing to do with length of time
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - TegraRCMGUI, apparently, missing