SystemSettings "An error has occured" after sysupdater freeze

Discussion in '3DS - Homebrew Development and Emulators' started by Rodimus, Jan 7, 2016.

  1. Rodimus
    OP

    Rodimus Member

    Newcomer
    37
    16
    Aug 21, 2012
    United States
    So I was attempting to downgrade my o3DS, I think sysupdater froze after I hit the Y button to downgrade. All I saw was a single line of incomplete text. I waited for about 20min, nothing changed. Powered off the 3ds and restarted, out of curiosity I went to check the system setting app an I got hit with a "An error has occuured" message everytime I try to open it.

    I can still launch Homebrew, and other apps still load fine.

    I tried to boot into safe mode, but that does not work, I just get a black screen with safe mode.

    What can I do?
     
  2. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,143
    3,440
    Nov 13, 2014
    United States
    Go to the eShop and do a system update while you still can.
     
  3. Rodimus
    OP

    Rodimus Member

    Newcomer
    37
    16
    Aug 21, 2012
    United States
    Will the eshop even give me a prompt to update? I can try.
     
  4. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,143
    3,440
    Nov 13, 2014
    United States
    Yes because your not on the latest firmware.
     
  5. nero99

    nero99 GBAtemp Addict

    Member
    2,041
    954
    Sep 18, 2014
    United States
    If you downgraded, yes.
     
  6. Rodimus
    OP

    Rodimus Member

    Newcomer
    37
    16
    Aug 21, 2012
    United States
    The system started out on 10.3
    I just tried loading the eshop, I got an update prompt, when I chose to update I got the same error.
    I guess Im SOL since the system setting app cant load and I cannot update the 3DS.

    — Posts automatically merged - Please don't double post! —

    It froze right at the beginning of the downgrade. I dont think the system even downgraded.
     
  7. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,143
    3,440
    Nov 13, 2014
    United States
    Can you enter the Homebrew launcher?
     
  8. Rodimus
    OP

    Rodimus Member

    Newcomer
    37
    16
    Aug 21, 2012
    United States
    Yes I can, I have menuhax and Ironhax
     
  9. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,143
    3,440
    Nov 13, 2014
    United States
    Can you still install CIA's to lets says Sysnand using FBI?
     
  10. Rodimus
    OP

    Rodimus Member

    Newcomer
    37
    16
    Aug 21, 2012
    United States
    I dont even have cfw to use fbi let alone install cia's
     
  11. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,143
    3,440
    Nov 13, 2014
    United States
    Ok try to keep up with me boot hbl and run mini pasta this will kick you into a sig patched Sysnand. From there enter hbl through ironhax and run FBI https://github.com/Steveice10/FBI/releases/download/1.4.17/FBI.zip use FBI to install sysupdater on Sysnand https://github.com/profi200/sysUpdater/releases. Then shutdown load menuhax and mini pasta then run Sysupdater on Sysnand to downgrade/update down to whatever firmware you tried to get to (I don't know of any 2DS CIA packs). This is a super janky method and I have no clue if it will even work.
     

    Attached Files:

  12. Rodimus
    OP

    Rodimus Member

    Newcomer
    37
    16
    Aug 21, 2012
    United States
    Can I update via cart?
     
  13. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,804
    5,684
    Mar 17, 2010
    Norway
    Alola
    He probably isn't downgraded enough that CFW will work.
    Re-run the downgrader.
     
  14. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,143
    3,440
    Nov 13, 2014
    United States
    You can try that aswell if you are aware of a game that has a higher firmware. Then try updating through system update again.
     
  15. Rodimus
    OP

    Rodimus Member

    Newcomer
    37
    16
    Aug 21, 2012
    United States
    I would try to downgrader, but i will risk a brick if it goes wrong again.
    I have a copy of pokemon super mystery dungeon that prompts me to update to ver 9.90-28U. Can update via the cart or will I brick it? Does this game have an update on the cart?

    Is there a way to tell what system firmware Im on via hombrew?
     
    Last edited by Rodimus, Jan 8, 2016
  16. nero99

    nero99 GBAtemp Addict

    Member
    2,041
    954
    Sep 18, 2014
    United States
    Update with sysupdater?(the downgrader has a update option).
     
  17. Rodimus
    OP

    Rodimus Member

    Newcomer
    37
    16
    Aug 21, 2012
    United States
    Is it less likely to get bricked if I try to update? What is the most stable of sysupdater?
     
  18. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,143
    3,440
    Nov 13, 2014
    United States
    The one I linked 0.4.2
     
  19. Rodimus
    OP

    Rodimus Member

    Newcomer
    37
    16
    Aug 21, 2012
    United States
    Is there anywhere I can find 10.3 files for sysupdater.
     
  20. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,143
    3,440
    Nov 13, 2014
    United States
    Run 3DNUS 1.9 https://gbatemp.net/threads/3dnus.376488/
    Type 10.3.0-28 into the Title ID field and US into version and make sure you have Old 3ds selected then click download.

    — Posts automatically merged - Please don't double post! —

    You should end up with 110 CIA's. Put them all into the Update folder after emptying the folder of other CIA's.