System update needed

Discussion in 'Switch - Backup Loaders & Modchips' started by maelstrom341, Nov 7, 2019.

  1. maelstrom341
    OP

    maelstrom341 Newbie

    Newcomer
    1
    Nov 18, 2016
    Gambia, The
    Hello guys. I have a problem which makes me crazy since yesterday. My switch was on firmware version 8.0.1. I tried installing witcher and its update. The witcher base game worked but when I installed the update then it started saying a system update is required in order to play. I updated my FW to 9.0.0 and updated Atmosphere as well. Got the latest sig patches too. However I still can't get the updated version of witcher to work. Today I installed fifa 20 and again the base game works but the update wants a system update when I try to run the game. I tried everything but I can't find a solution. Can anybody think of anything that can cause this problem? Any help is appreciated.
     
  2. KHANV1CT

    KHANV1CT GBAtemp Regular

    Member
    3
    May 22, 2013
    United States
    Maybe it needs 9.0.1
     
    Hardline likes this.
  3. thesjaakspoiler

    thesjaakspoiler GBAtemp Regular

    Member
    3
    Nov 20, 2018
    Afghanistan
    Games/updates do have a field which indicates the minimum required firmware.
    Tinfoil has an option to ignore the firmware version.
    I'm not sure what that does but you could give it a try.
     
  4. maelstrom341
    OP

    maelstrom341 Newbie

    Newcomer
    1
    Nov 18, 2016
    Gambia, The
    You were absolutely right. I updated to 9.0.1 today and all the game updates worked again. I hope this post helps anyone that wonders why the updates are not working.
     
    Hardline likes this.
Quick Reply
Draft saved Draft deleted
Loading...