System Files Corrupted / Priiloader Works

Discussion in 'Wii - Hacking' started by CameronBrk, Aug 9, 2014.

  1. CameronBrk
    OP

    CameronBrk Newbie

    Newcomer
    1
    0
    Aug 9, 2014
    United States
    Huntington Beach, California
    Hello,

    It's been a while since I've touched anything related to hacking my wii. But just today I launched it and the system was starting up normally, but before any of the channels would show completely I got the message "sytem files are corrupt, please refer to instruction manual". After scouring the forums I found that I had installed priiloader a while back and had got it to launch fine by holding reset and using a wavebird to navigate.

    I could not however open the home brew channel or do much else from there.
    Does anyone have a solution with what to do when this happens? I have not done anything to my wii that I know of for it to be doing to this to me right now other than letting it collect some dust.

    Can anyone refer me to a topic or help with my predicament. It would be much appreciated!
     
  2. angelboy777

    angelboy777 Newbie

    Do you have a NAND backup and BootMii?
     
  3. Brav0

    Brav0 GBAtemp Regular

    Member
    116
    12
    Jun 26, 2014
    Romania
    im not really an expert but if you can launch priiloader (holding down reset) and go into the homebrew channel
     
  4. Yepi69

    Yepi69 Vivid and busy gamer

    Member
    2,421
    1,018
    Nov 29, 2010
    Portugal
    Behind you

     
  5. 466

    466 yes, it says 466

    Member
    200
    30
    Mar 28, 2014
    United Kingdom
    Earth
    Do you have BootMii as IOS?
     
  6. ccbrk

    ccbrk Newbie

    Newcomer
    5
    0
    Dec 31, 2014
    United States
    I do have priiloader and bootmii as an ios. I am running 4.2u. Any ideas? This is "CameronBrk" btw. Somehow I got locked out of my other account.
     
  7. petspeed

    petspeed GBAtemp Advanced Fan

    Member
    531
    50
    Nov 13, 2009
    In Priiloader try to choose Launch Title and then choose Homebrew Channel. If that works then it should be possible to fix the Wii
     
  8. ccbrk

    ccbrk Newbie

    Newcomer
    5
    0
    Dec 31, 2014
    United States
    I am in homebrew channel. I noticed my VBA emulator isn't working, and I cannot get a wiimote to sync. Do I just simply re-install the system menu? What are the next steps? I am running HBC 1.1.2 on IOS61.
     
  9. nikeymikey

    nikeymikey This is now a Spiderman thread.........

    Member
    962
    134
    Nov 19, 2008
    I have had this trouble before, it happened to me after installing a corrupted wad file, a channel forwarder i think but thats irrrelivent. All i did to fix it was to reinstall the system menu wad using Multi Mod Manager (MMM). Just be sure that install the system menu that matches the one thats corrupted. If you were on 4.3 then install 4.3, if you were on 4.2 then install 4.2 etc etc
    You can use modmill on your pc to get both MMM and the system menu wad and copy them to ur sd card.
     
  10. petspeed

    petspeed GBAtemp Advanced Fan

    Member
    531
    50
    Nov 13, 2009
    Please be VERY carefull abouot installing the system menu because that will uninstall Priiloader. If that doesn't solve your problem then you have a serious problem because you can't use Priiloader to access Homebrew Channel anymore.

    I sugest you run Syscheck and post the result here then we take it from there.
     
  11. ccbrk

    ccbrk Newbie

    Newcomer
    5
    0
    Dec 31, 2014
    United States
    Thanks! The only issue now standing in the way is re-configuring my internet without a wii-remote because it won't allow me to sync a wiimote currently. If I can configure the internet, MMM should be able to connect and re-install 4.2u.
     
  12. ccbrk

    ccbrk Newbie

    Newcomer
    5
    0
    Dec 31, 2014
    United States
    SYSCHECK:

    Region: NTSC-U
    System Menu 4.2U (v481)
    priiloader installed
    Drive date: 05.26.200605
    Homebrew Channel 1.1.2 runnion on IOS61

    Hollywood v0x11
    Consolde ID:67125966
    Console Type: Wii
    Shop Channel COuntry: United States (49)
    Boot2 v4
    Found 203 titles.
     
  13. nikeymikey

    nikeymikey This is now a Spiderman thread.........

    Member
    962
    134
    Nov 19, 2008
    What petspeed said about being very careful is true... after you reinstall the system menu Priiloader will be gone... and that seems to be your only brick protection.... I have full BootMii so i wasnt worried about that.

    Also i see you have 203 titles installed... Do you remember the last one that you added because that could be the cause of your problem.
     
  14. petspeed

    petspeed GBAtemp Advanced Fan

    Member
    531
    50
    Nov 13, 2009
    Please post the full syscheck including all IOS'es.
    Your drive is very old so are you sure that your Wii can't install bootmii in boot2? That would give you extra brick protection.
     
  15. ccbrk

    ccbrk Newbie

    Newcomer
    5
    0
    Dec 31, 2014
    United States
    I have bootmii installed as boot2 now also. I have IOS 4, 9, 10-17, 20-22 , 28, 30, 31, 33-38, 50-51, 53, 55-57, 60-61, 70, 202, 222, 223, 248, 249, 250.
     
  16. petspeed

    petspeed GBAtemp Advanced Fan

    Member
    531
    50
    Nov 13, 2009
    Okay with bootmii in boot2 it's less dangerous. Please make sure you have a sd card setup with bootmii files so you can access bootmii when you turnon your Wii (don't remember exactly how as my Wii is too new to allow bootmi in boot2) and that you can launch Homebrew Channel from there.

    Once that works try to remember if you have installed a wad file just before your problem started and then delete that title again either by using the wad or by using Anytitile deleter. If you are sure you didn't install anything you could try to reinstall the system menu. Download it on your computer using Modmii.
     
  17. nikeymikey

    nikeymikey This is now a Spiderman thread.........

    Member
    962
    134
    Nov 19, 2008
    Yep if u now have bootmii as boot2 then u r pretty much bulletproof.. ive done all sorts to my wii over the years and thanks to good old bootmii ive always been able to restore it. I would use bootmii to make a nand dump as soon as you have it all fixed and then you always have a quick and easy way to wind back the clock by restoring your nand dump with bootmii.