1. manubrio

    OP manubrio Newbie
    Newcomer

    Joined:
    Oct 20, 2020
    Messages:
    6
    Country:
    Antarctica
    Hi, I have just installed the SX Core into a Mariko Switch.
    At the first boot it has asked me to update the firmware and plugin the power supply.
    I have tried ti touch the continue button without success.

    After some minutes I have tried again and this time the touch worked and the firmware has been updated.
    The switch rebooted and, after some seconds, the display has showed the standard three buttons (Boot custom FW, Boot original FW and Options), but the touch does not work again.

    Please, someone have some idea on how to solve the touch problem?

    Thanks
     
  2. hakkinen

    hakkinen Member
    Newcomer

    Joined:
    Oct 7, 2020
    Messages:
    16
    Country:
    France
    Verify your sd card reader connection, it's very sensible (and fragile too, so be careful)
     
  3. AsideX

    AsideX Newbie
    Newcomer

    Joined:
    Sep 19, 2018
    Messages:
    7
    Country:
    Italy
    Hello.

    I have a very similar problem! Have you found a solution?
     
  4. manubrio

    OP manubrio Newbie
    Newcomer

    Joined:
    Oct 20, 2020
    Messages:
    6
    Country:
    Antarctica
    No, I change the Nintendo Switch before solve the problem.
    However I suggest you to check the SD connector. Be sure it's well connected.
     
  5. hakkinen

    hakkinen Member
    Newcomer

    Joined:
    Oct 7, 2020
    Messages:
    16
    Country:
    France

    99% it's the problem of sd card reader 's connection
     
  6. Jopa777

    Jopa777 Member
    Newcomer

    Joined:
    Sep 20, 2020
    Messages:
    39
    Country:
    Portugal
    Hi, to those with touch screen issues after installing sx lite or sx core. This is caused by a burned cap on the upper part. Had this issue and confirmed it in 2 consoles where I've installed chips. Don't know what provoques it but replaced cap and resolved issue (horrible job to do since these caps are microscopic. Discovered this reading tx forums where 1 person had the same problem. This issue won't let use touch screen and sxos detects this and won't let you execute recovery menu with power button +volume + freezes on sx screen. You can just use emunand if already created- in one of my consoles this happened hours after sx lite installed. Kindly see photos of cap
     

    Attached Files:

Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - problems, touch,